View Issue Details

IDProjectCategoryView StatusLast Update
0001618ArchFeaturepublic2014-12-08 20:55
Reporterteobo Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.15 
Summary0001618: Arch.makeRoof(face,angle) with arbitrary angles
Descriptionhttp://forum.freecadweb.org/viewtopic.php?f=22&t=6995
"...Nevertheless I would like to have optional angle parameters for this tool. The tool looses to much of its power. ..."
There could be a list with angles for each edge of the base face that gets in effect when requested like the diffuseColor design.
The tool could be of good use, because there are normally difficult roofs in the real world.
TagsNo tags attached.
FreeCAD Information

Activities

teobo

2014-07-16 15:36

reporter   ~0004801

It should be Feature request not a bug report.

Related Changesets

FreeCAD: master 6aa91b36

2014-12-07 23:18:29

rockn


Committer: yorik Details Diff
Ready for merge : fix issues 0001618 and 0001607

Implement getSubVolume to cut wall with roof.
Now Roof is not hidden when removing it to a wall.
Affected Issues
0001607, 0001618
mod - src/Mod/Arch/ArchCommands.py Diff File
mod - src/Mod/Arch/ArchRoof.py Diff File

Issue History

Date Modified Username Field Change
2014-07-16 15:12 teobo New Issue
2014-07-16 15:36 teobo Note Added: 0004801
2014-07-23 12:36 wmayer Project FreeCAD => Arch
2014-12-08 20:21 yorik Changeset attached => FreeCAD Master master 6aa91b36
2014-12-08 20:55 yorik Status new => closed
2014-12-08 20:55 yorik Assigned To => yorik
2014-12-08 20:55 yorik Resolution open => fixed
2014-12-08 20:55 yorik Fixed in Version => 0.15