View Issue Details

IDProjectCategoryView StatusLast Update
0001608SketcherBugpublic2015-09-12 12:59
ReporterCDFacetsAssigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDell Latitude, FreeCAD .14OSVista Business, SP2OS Version2007
Product Version0.14 
Target VersionFixed in Version0.16 
Summary0001608: Part and cross hairs disappear in Sketch Workbench
DescriptionThis is very repeatable on my machine.
When starting FreeCAD, using Sketcher, the circle function fails to display the circle.

After doing a few tests, if you sketch a circle first, the circle and grid disappears.
If you draw a line first, then draw a circle, it seems to work ok.


Steps To Reproduce1) Start FreeCAD
2) Close the Start Page
3) Using Toolbar, drop list box and choose Sketcher
4) Click Create Empty Document icon
5) Click Unnamed in the Project window to the left
6) Click on icon for Create or Edit new Sketch
7) Choose XY-Plane sketch orientation, the grid and cross hairs correctly appear
8) Click the "Create a Circle" icon
9) Click on the origin, then move upward 40mm (also tried with 4mm) and click a second time.
At this time the circle will disappear, the grid disappeared, and all that is left is the cut off version of the cross hairs with a "Create tangent Constraint between two entities"
If you click anywhere in the screen outside of the circle, the cross hairs also disappear.

Additional InformationI just noticed the "tool tips" do not pop-up anymore, but do appear in the bottom status bar of the window.
TagsNo tags attached.

Relationships

duplicate of 0000909 closedlogari81 Disappearing sketches due to tangency autoconstraint 

Activities

ian.rees

2014-07-14 00:11

developer   ~0004789

Hi CDFacets,

I noticed a similar version of this bug recently too, or at least a very similar sounding bug. The problem with the circle comes about because of the automatic tangent constraint - essentially the solver is trying to make the circle's centre stay on the origin, while simultaneously keeping the Y (same works for X) axis tangential to the circle. I imagine that the grid issue follows on from this, but haven't investigated.

A workaround for FreeCAD 0.14 is to untick the "automatic constraints" box in the sketcher task view, or don't put your second click as close to the axis.

I'm currently working on keyboard shortcut for disabling automatic constraints (and snap-to-grid with a different key), and hope to have it ready for testing within a few days. The current version will compile and gives you Ctrl to disable auto constraints; it's not done, but feel free to pull it and test ;) : https://github.com/ianrrees/FreeCAD_tinkering - branch sketcher-cancel-auto-constraints .

More permanent fixes might include:
* Prevent suggestion of constraints for obvious degenerate cases like this, or better attempt to solve a sketch before suggesting constraints.
* Have Sketcher report an error/warning message when this situation occurs.
* Suggest the perpendicular constraint when it's a better fit than the tangential.

wmayer

2015-09-12 12:59

administrator   ~0006397

Since it's a duplicate of the fixed 909 this can be closed, too.

Issue History

Date Modified Username Field Change
2014-07-11 16:55 CDFacets New Issue
2014-07-14 00:11 ian.rees Note Added: 0004789
2014-07-23 12:43 wmayer Project FreeCAD => Sketcher
2014-07-23 12:44 wmayer Summary Part and cross hairs disappear in Schetch Workbench => Part and cross hairs disappear in Sketch Workbench
2014-07-23 12:51 wmayer Relationship added duplicate of 0000909
2015-09-12 12:59 wmayer Note Added: 0006397
2015-09-12 12:59 wmayer Status new => closed
2015-09-12 12:59 wmayer Resolution open => fixed
2015-09-12 12:59 wmayer Fixed in Version => 0.16