View Issue Details

IDProjectCategoryView StatusLast Update
0001601PartDesignBugpublic2018-09-16 14:41
Reporterwieszak17Assigned Towandererfan 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.17 
Summary0001601: Pad fails on 'non-one-solid' element
DescriptionWhen attempting to pad a sketch mapped to object which contains more then one solid (sory, i cant remember how it is professionally called ;) ), pad is created only on one of them, and rest are discarded, see example.
Steps To Reproduce1. create sketch with two non intersecting closed figures
2. pad it (you get this non-one-solid or what its called)
3. map sketch to face on plane which touches both solids (eg, same plane as was forst sketch done)
4. draw any closed figure in this mapped sketch
5. pad it - you get padded last figure but one of two solids from p.2 is lost.
Additional InformationI think in previous versions it worked as expected, so maybe it is a regression of some kind.
TagsNo tags attached.

Relationships

related to 0001707 closedwandererfan PartDesign - Inconsistent handling of multiple pieces 

Activities

wieszak17

2014-07-11 09:36

reporter  

regr.fcstd (7,559 bytes)

normandc

2014-07-17 04:28

manager   ~0004805

I think it's the reverse - if it worked before, it was not intended. AFAIK Part Design is not supposed to support multi-body parts at the moment. The fact the first Pad now accepts two separate closed profiles (I'm sure it didn't in v0.13) may be the unintended result of a fix to the Transformation features.

I believe multi-bodies will be possible when the Body container is introduced.

Kunda1

2017-01-31 01:19

administrator   ~0008116

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20386

normandc

2018-09-16 14:41

manager   ~0011759

As previously mentioned, PartDesign enforces a strict single solid rule. On July 13th 2018 a warning message was added in master as well as in the releases/FreeCAD-0-17 branch. Related commits are 1889f1f8, 1dd565ee and 5c3f7bf8. This is included in FreeCAD 0.17.13528 or later.

The single-solid rule may be lifted at a later date, but for now I am closing this old report.

Issue History

Date Modified Username Field Change
2014-07-11 09:36 wieszak17 New Issue
2014-07-11 09:36 wieszak17 File Added: regr.fcstd
2014-07-17 04:28 normandc Note Added: 0004805
2017-01-09 18:03 wmayer Relationship added related to 0001707
2017-01-31 01:19 Kunda1 Note Added: 0008116
2018-09-16 14:41 normandc Assigned To => wandererfan
2018-09-16 14:41 normandc Status new => closed
2018-09-16 14:41 normandc Resolution open => fixed
2018-09-16 14:41 normandc Fixed in Version => 0.17
2018-09-16 14:41 normandc Note Added: 0011759