View Issue Details

IDProjectCategoryView StatusLast Update
0001571FreeCADBugpublic2019-04-06 19:00
ReporterdenemAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformAllOSAllOS VersionAll
Product Version 
Target VersionFixed in Version 
Summary0001571: Sweep with closed profile with acute angles does not work
DescriptionSample project contains two sketches. If we select more than one segment from Wire Sketch to make sweep than resulting figure will either be obstructed (see pic 1) if we will set solid=false or the sweep process will be failed with message "---------------------------
Input error
---------------------------

---------------------------
OK
---------------------------
"

This bug affects .13 and .14
Steps To ReproduceUse the attached project
Additional InformationThis issue arrears to be related with bug 0001570
TagsOCC 7.3, OCC Bug, sweep, upstream

Relationships

related to 0001570 confirmed Part sweep bug with acute angle (Upstream OCC bug) 

Activities

denem

2014-06-05 10:46

reporter  

Freecad_bug.zip (Attachment missing)

shoogen

2014-06-05 15:52

developer   ~0004733

your example contains acute angles. In what way is the result different from the problem described in 0001570 ?

denem

2014-06-06 08:23

reporter   ~0004736

The behaviour is slightly different for open and closed wires. For open wires we always able to see the result. For closed profiles system appears to have an internal exception at least in the half of the cases and because of that does not generate any profile at all. I think that after the fix these two bugs should be tested together. I can provide more sample projects if it wil help you to solve this problem. I'm interested in gothic cathedral windows construction, so this issue makes completely unable to use this wonderful program! Looking forward to get the fixed version.

shoogen

2014-06-06 15:22

developer   ~0004738

Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 109.23955054578
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 116.063732202451
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 107.096928594517
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 109.239550545767
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 116.063732202547
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 107.096928594518

Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Fail of TrimCorner
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 109.239550545781
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 116.063732202247
Projection not done
Projection not done
SameParameter : Tolerance not reached!
tol visee : 0.0001 tol obtained : 107.096928594516
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Compile with option DEB : if problems with intersection : IntWalk_PWalking_1.gxx (lbr le 1erdec98)
Fail of TrimCorner
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
Draw[6]> checkshape Sweep
 **** probleme de SameParameter au point :
         26.2613909351997 14.35961570099 0.85548271990202
   Erreur detectee :3.78592234732288 Tolerance :1e-07
 **** probleme de SameParameter au point :
         29.1343753167111 13.3580154836856 3.59739187306738
   Erreur detectee :1.27496243309754 Tolerance :1e-07
 **** probleme de SameParameter au point :
         -25.1235054537064 15.5632238381015 0.855482719902038
   Erreur detectee :3.61390646301809 Tolerance :1e-07
BRepCheck_NoCurveOnSurface or BRepCheck_InvalidRange
 **** probleme de SameParameter au point :
         -25.4572733285634 18.552101405819 3.59739187306756
   Erreur detectee :1.0944119327006 Tolerance :1e-07
BRepCheck_NoCurveOnSurface or BRepCheck_InvalidRange
 **** probleme de SameParameter au point :
         -6.77744491084376e-09 -31.1264476644595 0.855482719902033
   Erreur detectee :4.19853418392951 Tolerance :1e-07
BRepCheck_NoCurveOnSurface or BRepCheck_InvalidRange
 **** probleme de SameParameter au point :
         8.80184813922824e-13 -37.1042028116357 3.5973918730673
   Erreur detectee :3.4016855877909 Tolerance :1e-07
BRepCheck_NoCurveOnSurface or BRepCheck_InvalidRange
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
DBRep_IsoBuilder : PCurve is null
On Shape faulty_1 :
BRepCheck_UnorientableShape
Shape faulty_2 on shape faulty_1 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
On Shape faulty_3 :
BRepCheck_UnorientableShape
Shape faulty_4 on shape faulty_3 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
On Shape faulty_5 :
BRepCheck_UnorientableShape
Shape faulty_6 on shape faulty_5 :
BRepCheck_NoCurveOnSurface
Shape faulty_7 on shape faulty_5 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
Shape faulty_8 on shape faulty_5 :
BRepCheck_NoCurveOnSurface
On Shape faulty_9 :
BRepCheck_UnorientableShape
Shape faulty_10 on shape faulty_9 :
BRepCheck_NoCurveOnSurface
Shape faulty_11 on shape faulty_9 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
Shape faulty_12 on shape faulty_9 :
BRepCheck_NoCurveOnSurface
On Shape faulty_13 :
BRepCheck_UnorientableShape
Shape faulty_14 on shape faulty_13 :
BRepCheck_NoCurveOnSurface
Shape faulty_15 on shape faulty_13 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
Shape faulty_8 on shape faulty_13 :
BRepCheck_NoCurveOnSurface
On Shape faulty_16 :
BRepCheck_UnorientableShape
Shape faulty_17 on shape faulty_16 :
BRepCheck_NoCurveOnSurface
Shape faulty_18 on shape faulty_16 :
BRepCheck_InvalidCurveOnSurface
BRepCheck_InvalidSameParameterFlag
Shape faulty_12 on shape faulty_16 :
BRepCheck_NoCurveOnSurface
On Shape faulty_19 :
BRepCheck_NotConnected

Faulty shapes in variables faulty_1 to faulty_19

Kunda1

2017-06-20 20:30

administrator   ~0009472

@yorik please advise

yorik

2017-06-26 14:02

administrator   ~0009541

Don't know what to say, the bug is more than 2 years old... MAybe the OP can tell if the problem still exists?

Kunda1

2017-06-26 19:10

administrator   ~0009549

@denem ping

Kunda1

2017-07-12 12:37

administrator   ~0009737

@denem does this problem still exist?

Kunda1

2017-12-11 16:59

administrator   ~0010569

@denem i know this is an old ticket but could you possibly re-up the attachment so testers can recreate the problem and also test for when it is solved?

denem

2017-12-20 17:10

reporter   ~0010622

Lemme check if i still have it. I'll create new ones if i don't.

Kunda1

2018-05-30 15:46

administrator   ~0011306

@denem please re-up attachments.. OCCT 7.3 was just released and I'd like to know the outcome on this issue.

Kunda1

2018-08-01 03:02

administrator   ~0011576

@denem ping

Kunda1

2018-10-14 11:25

administrator   ~0012024

@denem ping

Kunda1

2018-10-17 20:30

administrator   ~0012052

@denem ping

Kunda1

2018-10-28 02:38

administrator   ~0012104

@denem please respond

Kunda1

2019-01-05 11:48

administrator   ~0012381

@denem this ticket would usually be closed by now but since it's a child of 0001570 it won't. Can you please, nevertheless, add an example file as requested (which you chimed in and said you would?)

Kunda1

2019-04-06 19:00

administrator   ~0013002

Closing ticket as it is referenced in 0001570
Still haven't heard from OP, which is a shame.

Issue History

Date Modified Username Field Change
2014-06-05 10:46 denem New Issue
2014-06-05 10:46 denem File Added: Freecad_bug.zip
2014-06-05 15:46 shoogen Relationship added related to 0001570
2014-06-05 15:52 shoogen Note Added: 0004733
2014-06-05 15:53 shoogen Tag Attached: OCC Bug
2014-06-05 15:54 shoogen Tag Detached: OCC Bug
2014-06-06 08:23 denem Note Added: 0004736
2014-06-06 15:22 shoogen Note Added: 0004738
2017-01-19 17:03 Kunda1 Tag Attached: sweep
2017-06-20 20:30 Kunda1 Note Added: 0009472
2017-06-26 14:02 yorik Note Added: 0009541
2017-06-26 19:10 Kunda1 Assigned To => Kunda1
2017-06-26 19:10 Kunda1 Status new => feedback
2017-06-26 19:10 Kunda1 Note Added: 0009549
2017-07-12 12:37 Kunda1 Note Added: 0009737
2017-07-22 12:07 Kunda1 Assigned To Kunda1 =>
2017-07-22 12:08 Kunda1 Additional Information Updated View Revisions
2017-12-11 16:59 Kunda1 Note Added: 0010569
2017-12-11 16:59 Kunda1 Tag Attached: OCC 7.3
2017-12-11 16:59 Kunda1 Tag Attached: OCC Bug
2017-12-11 16:59 Kunda1 Tag Attached: upstream
2017-12-20 17:10 denem Note Added: 0010622
2017-12-20 17:10 denem Status feedback => new
2018-05-30 15:46 Kunda1 Note Added: 0011306
2018-05-30 15:47 Kunda1 Status new => feedback
2018-08-01 03:02 Kunda1 Note Added: 0011576
2018-10-14 11:25 Kunda1 Note Added: 0012024
2018-10-17 20:30 Kunda1 Note Added: 0012052
2018-10-28 02:38 Kunda1 Note Added: 0012104
2019-01-05 11:48 Kunda1 Note Added: 0012381
2019-04-06 19:00 Kunda1 Status feedback => closed
2019-04-06 19:00 Kunda1 Resolution open => duplicate
2019-04-06 19:00 Kunda1 Note Added: 0013002