View Issue Details

IDProjectCategoryView StatusLast Update
0001566FreeCADBugpublic2017-01-14 21:26
Reporterulrich1a Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.17 
Summary0001566: Projection of a helix perpendicular to helix-axis fails
DescriptionThe Draft-workbench has the projection to make a 2D-projection of a shape. This fails for a helix. The same function is used in the Drawing-workbench. The Drawing-Workbench function fails too with "Fatal error occured while projecting shape".
Surprisingly the Draft-Workbench function for making a Drawing-Projection works.

Making a 2D-helix-projection works in FreeCAD 0.13.1828. So it seems to be a regression.
Steps To ReproduceMake a helix with height 5-times the pitch in the Part-workbench.
Make a 2D-Projection in the Draft-workbench.
It fails.
Additional Informationraceback (most recent call last):
  File "/home/ulrich/Sourcen/FreeCAD/Build_20140504/Mod/Draft/Draft.py", line 4346, in execute
    obj.Shape = self.getProjected(obj,obj.Base.Shape,obj.Projection)
  File "/home/ulrich/Sourcen/FreeCAD/Build_20140504/Mod/Draft/Draft.py", line 4268, in getProjected
    groups = Drawing.projectEx(shape,direction)
<type 'exceptions.Exception'>: Unknown C++ exception
TagsOCC Bug, upstream
FreeCAD Information

Relationships

related to 0001697 closedyorik projection of edges fails 

Activities

wmayer

2014-05-29 17:44

administrator   ~0004728

Apparently this seems to depend on the used OCC version. I got it only working with OCC 6.3 on Win32 but also compiled with the very latest FreeCAD sources.

wmayer

2014-05-29 22:13

administrator   ~0004730

When debugging through the OCC code the algorithm inside Update() of the class HLRBRep_Algo fails because it expects a face but there is none.

In a certain way this seems logical because using an HLR (hidden line removal) algorithm for shapes without faces doesn't make too much sense. As replacement for these cases the class BRepProj_Projection could be used.

ulrich1a

2014-06-19 20:22

reporter   ~0004758

I think this is a regression in OCC. Such a function should just check for the existence of a face and if there is none, do not hide any line instead of throwing an exception.

shoogen

2014-09-29 10:56

developer   ~0005165

http://tracker.dev.opencascade.org/view.php?id=25214

wmayer

2016-12-18 19:34

administrator   ~0007531

Fixed upstream. According to OCC it's fixed in version 7.1 but this case works for me for version 7.0, too.

Issue History

Date Modified Username Field Change
2014-05-25 16:18 ulrich1a New Issue
2014-05-29 17:44 wmayer Note Added: 0004728
2014-05-29 22:13 wmayer Note Added: 0004730
2014-06-19 20:22 ulrich1a Note Added: 0004758
2014-09-29 10:50 shoogen Relationship added related to 0001697
2014-09-29 10:56 shoogen Note Added: 0005165
2016-12-18 19:34 wmayer Note Added: 0007531
2016-12-18 19:34 wmayer Status new => closed
2016-12-18 19:34 wmayer Resolution open => fixed
2016-12-18 19:34 wmayer Fixed in Version => 0.17
2017-01-14 21:26 Kunda1 Tag Attached: OCC Bug
2017-01-14 21:26 Kunda1 Tag Attached: upstream