View Issue Details

IDProjectCategoryView StatusLast Update
0001552FreeCADBugpublic2014-08-05 09:36
Reporterulrich1a Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.15 
Summary0001552: Sketcher lines on construction lines are not selectable
DescriptionSometimes it is useful to have a normal line on top of a construction line in the Sketcher. But the normal line is not selectable.
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0000693 closed Sketcher Sketcher: No GUI to select overlapping lines in sketches 

Activities

normandc

2014-05-17 18:55

manager   ~0004685

Last edited: 2014-05-17 18:55

View 3 revisions

Forum topic is located here: http://forum.freecadweb.org/viewtopic.php?f=3&t=6496

IMO this is a duplicate of bug 0000693 but I'll let the devs decide.

Related Changesets

FreeCAD: master 1011dd41

2014-08-04 17:36:22

wmayer

Details Diff
Squashed commit of the following:

commit 695becbbfff961b13e3edb5a4e1e4487bc53b4bb
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Aug 4 15:24:33 2014 +0200

- Making combo disable state.
- Updating Art (Thanks Jim!)

commit d5391d40ace450fa2e65fe2b4ab8029ad37cacf8
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Fri Aug 1 00:40:15 2014 +0200

- Adaptation of code to Workbench's new Template structure.
- Minor adaptation of new ViewProvideSketch code to new constraint code (only in code extensions needed for element Widget)

commit ecdec20afa33c9a950e6054e80e4aa9c72aad8b6
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jul 31 15:31:38 2014 +0200

Fix so that when applying a coincident constraint to a plurality of points,
if one constraint on a couple of points exists, no new coincident constraint is
added to this couple.

Fixes: http://forum.freecadweb.org/viewtopic.php?f=3&t=6890

commit 32ef59d76e6c63356f5d36598ca11eb47c2e52af
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jul 31 14:13:58 2014 +0200

Add some placeholder art for icons to avoid having a cross icon and annoying icon not found messages.

commit ccb60a3a7e71a0eb8ad5d896542314a98ef314a8
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Jul 28 20:15:29 2014 +0200

- Fixed Length Constraint accelerator (D) to SHIFT+D to avoid colision with other higher level FreeCAD accelerator assignment.
- Selection Accelerators now toggle on shortcut execution, and act when no other element is selected (fixed bug)

TODO: Art+Toolbar

commit 791358d046e8eeb03fa00272f5627c75254c48eb
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Jul 28 15:12:07 2014 +0200

Fixing shortcut system:
- Take shortcuts automatically from CommandManager.
- Fixed two shortcuts in CommandConstraints (Point on Object - O and
Parallel Constraint - P to SHIFT+O and SHIFT+P to avoid collision with other constraints)
- Fixed shortcuts in CommandConstraintAccel to non-already-existing combinations
- Fixed Sketcher Menu to show accelerators

commit 12d366406a45038ce1a4f725a98e4f570475084b
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Jul 28 11:53:37 2014 +0200

Implemented SHIFT multiple selection functionality in listwidget.

commit 0606ea7dfe38fdf8924f65f14382f1b327145c80
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Jul 28 11:02:02 2014 +0200

Added Sketcher Accelerators for:
- Selection of H Axis
- V Axis
- Origin

Main TODO: Shortcuts and Shift in list widget implementation

commit 297464807fc56fbcf31efadff9625fc05bb20c41
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Wed Jul 23 11:37:21 2014 +0200

Implementation of:
- Switch on 'Z' instead of 'Shift'
- Checkbox to select whether element internal name (e.g. Edge10) should be presented on list or not (Sponssi requested)
- Checkbox to force going back to "Edge" type on change from one element to the next (Sponssi requested)

commit c8764b116acdcfdc7ef7658dc6009fb8db807906
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Wed Jul 23 07:57:11 2014 +0200

TaskSketcher Elements:
- Store Vertex within elements for optimization (reduce loops searching for vertex in every function call)
- Added the accelerators described below + Toggle Construction as context menu commands
- Fixed bug (Thanks sponssi!): After some element has been preselected from the list and the cursor moved to the drawing area,
the preselection doesn't seem to be resetted in the widget or whereever it is handled.
Tapping shift still swaps the preselection between the points of the previously selected element.
The left mouse button has to be clicked in the draw area to get rid of this.
http://forum.freecadweb.org/viewtopic.php?f=10&t=6861&sid=7eea4adc7ecf4cebd561b357601866a2&start=20
- Extended naming of elements, to facilitate writing python code (as requested by sponssi).
- Minor modifications (creation of utility fuctions, code readibility, ...)

Sketcher Workbench:
- First effort to add a toolbar with the accelerators.

Sketcher Accelerators: (Perform actions on existing elements, as opposed to Geometry Creation, not restricted to applying constraints)
- Close Shape : of selected edges (i.e. lines and arcs)
- Connect : selected edges (connect endpoint edge with starting point of next edge according to selection order)
- Select Constraints : associated with currently selected edges

commit 1dc18204a4e2e38f71d729a7692383f50a7d4654
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Sat Jul 12 16:06:48 2014 +0200

New alternative implementation of the Sketch Element List.

This version comprises:
- Identification via icon of type of geometric element (Point, Arc, Line, Circle) and
Type of selection (Edge, Starting Point, End Point, Center Point)
- Corrected a bug where upon selection from the combobox, the icons were not updated (Thanks Jim!)
- Implementation of jump to next valid type of last preselected element (aka fast-forward) for all the types.

commit 4d472ef796362405c3982355f86489fa92cbfe6d
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jun 26 17:15:51 2014 +0200

Feature request by jmaustpc
- When an object does not have an element, lets put a different icon.
- Currently the constraint lock icon is used until availability of a new one.

commit 6d15478f6533ff3805520a8ca36d1c41908cb0af
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jun 26 14:54:23 2014 +0200

Bug fix (preselection not disappearing on changing element without the element Type).

commit e33043e17781fcf6399257696f115f68ab4580ec
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jun 26 14:39:20 2014 +0200

New nicer icons by jmaustpc. They look much nicer :-)

commit 2ce2d6ff1ad2d81b0b1e30ffcbe9f2cc445f2e5b
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Thu Jun 26 14:37:21 2014 +0200

Fast-Forward functionality:
- If an element not having "midpoint" is preselected, then on pressing SHIFT the
Type will jump from EndPoint to Line skipping midpoint.
- This is intended as a productivity feature, as most sketch elements usually are lines

commit 1865d06d06582a49da10ddc123133807a4593060
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Wed Jun 25 15:47:22 2014 +0200

Bug fix (thanks jmaustpc)
- Preselection is maintained even though the geometric element does not have the "Type".
- Fix involves calling for remove preselection in TaskSketcherElement
- Implementing the response to the message RmvPreselection in ViewProviderSketch

commit 14e21da4b4ed0e9a2b3e846a4e51f6745d5e0ab7
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Mon Jun 23 14:25:35 2014 +0200

Fix Bug with null pointer (thanks jmaustpc!)
Clean up code

commit 0d99eb633f1bca45d4e7bb22c57bd4892767a390
Author: Abdullah Tahiri <abdullah.tahiri.yo@gmail.com>
Date: Wed Jun 11 16:32:48 2014 +0200

New widget for the Taskbar of the Sketcher WB.

The objectives of this widget are:
1. Allow editing of sketches when they have (partially) overlapping lines of any type
(construction/external/normal).
2. Allow the construction of sketches using the keyboard (less mouse intensive)

The widget works as follows:
1. A QListWidget presents a list of elements, element is here a geometric element
formed Types edges, starting points, end points and midpoints (e.g. circles, arcs)
2. On hovering/Entering one item in the list, it is preselected for easy identification.
3. The selection can be switched from one type to another using the SHIFT key
(press and release) in a round-robin fashion (or you can select it using the droplist)
4. Selection of different types is possible (e.g. two points and a line).
5. The contextual menu accessible by right click allow to apply a constraint to the
selection.
6. The constraints in the contextual menu have shortcuts, so you can actually use the
shortcut directly from the QListWidget.

Additional features introduced to other parts during development...
- New color introduced for Types that are selected and preselected at the same time
- Edges is a SoLineSet. You can not apply many So modifiers (width,offset) to parts of a SoLineSet.
An edge part of a SoLineSet that is drawn after another one, covers it unless it is closer to the
camera. The system of manual offsets already in place for points has been extended to properly
handle (i.e. show) overlapping lines part of a SoLineSet.
Affected Issues
0000693, 0000930, 0001552
mod - src/Mod/Sketcher/App/SketchObject.cpp Diff File
mod - src/Mod/Sketcher/App/SketchObject.h Diff File
mod - src/Mod/Sketcher/Gui/AppSketcherGui.cpp Diff File
mod - src/Mod/Sketcher/Gui/CMakeLists.txt Diff File
mod - src/Mod/Sketcher/Gui/CommandConstraints.cpp Diff File
add - src/Mod/Sketcher/Gui/CommandSketcherAccel.cpp Diff File
mod - src/Mod/Sketcher/Gui/Makefile.am Diff File
mod - src/Mod/Sketcher/Gui/Resources/Makefile.am Diff File
mod - src/Mod/Sketcher/Gui/Resources/Sketcher.qrc Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_CloseShape.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_ConnectLines.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Arc_Edge.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Arc_EndPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Arc_MidPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Arc_StartingPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Circle_Edge.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Circle_MidPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Line_Edge.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Line_EndPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Line_StartingPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_Point_StartingPoint.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_Element_SelectionTypeInvalid.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_SelectConstraints.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_SelectHorizontalAxis.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_SelectOrigin.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/Sketcher_SelectVerticalAxis.svg Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_CloseShape.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_ConnectLines.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Arc_Edge_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Arc_EndPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Arc_MidPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Arc_StartingPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Circle_Edge_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Circle_MidPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Line_Edge_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Line_EndPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Line_StartingPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_Point_StartingPoint_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_Element_SelectionTypeInvalid_sm.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_SelectConstraints.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_SelectHorizontalAxis.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_SelectOrigin.xpm Diff File
add - src/Mod/Sketcher/Gui/Resources/icons/small/Sketcher_SelectVerticalAxis.xpm Diff File
mod - src/Mod/Sketcher/Gui/TaskDlgEditSketch.cpp Diff File
mod - src/Mod/Sketcher/Gui/TaskDlgEditSketch.h Diff File
add - src/Mod/Sketcher/Gui/TaskSketcherElements.cpp Diff File
add - src/Mod/Sketcher/Gui/TaskSketcherElements.h Diff File
add - src/Mod/Sketcher/Gui/TaskSketcherElements.ui Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.h Diff File
mod - src/Mod/Sketcher/Gui/Workbench.cpp Diff File
mod - src/Mod/Sketcher/Gui/Workbench.h Diff File

Issue History

Date Modified Username Field Change
2014-05-17 18:01 ulrich1a New Issue
2014-05-17 18:55 normandc Note Added: 0004685
2014-05-17 18:55 normandc Note Edited: 0004685 View Revisions
2014-05-17 18:55 normandc Note Edited: 0004685 View Revisions
2014-05-20 13:40 wmayer Relationship added related to 0000693
2014-08-05 09:36 wmayer Changeset attached => FreeCAD Master master 1011dd41
2014-08-05 09:36 wmayer Status new => closed
2014-08-05 09:36 wmayer Resolution open => fixed
2014-08-05 09:36 wmayer Fixed in Version => 0.15