View Issue Details

IDProjectCategoryView StatusLast Update
0001545FreeCADBugpublic2015-01-24 22:48
ReporterfooonsAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform64-bitOSUbuntuOS Version14.04 LTS
Product Versiontrunk 
Target VersionFixed in Version0.15 
Summary0001545: Folders with tick in the name cannot be opened
DescriptionWhen I want to explore content in a folder wich have tick in the name appears greyed and can't access the content.

Folder Imágenes, Música, Vídeos appears as Imgenes,Msica,Vdeos
Steps To Reproduce1. Open file
2. Select from tree a tick named folder
Additional InformationThis problem appears in Spanish language
TagsNo tags attached.

Relationships

related to 0001852 closedshoogen The python interpreter does not recognize the posix locale settings 

Activities

fooons

2014-05-14 16:14

reporter  

Captura de pantalla de 2014-05-14 18:01:00.png (Attachment missing)

wmayer

2014-12-03 21:40

administrator   ~0005352

That's not a FreeCAD bug. It's a bug in the system file dialog. What desktop environment do you use?

wmayer

2015-01-07 11:45

administrator   ~0005546

Last edited: 2015-01-07 14:38

View 2 revisions

When Qt determines the storage path of e.g. QDesktopServices::storageLocation(QDesktopServices::DesktopLocation) then it reads in the file user-dirs.dirs which usually is under $HOME/.config or where the environment variable XDG_CONFIG_HOME points to. See also http://www.freedesktop.org/wiki/Software/xdg-user-dirs

So, the user-dirs.dirs file contains the correctly translated text but because in the main() function "putenv("LANG=C");" is used to fix an OCC bug Qt fails to read in any non-ASCII characters. This leads to a path which doesn't exist and that's why the item is greyed out.

Related Changesets

FreeCAD: master f32caef4

2014-12-09 17:24:34

shoogen

Details Diff
respect locale environment except for LC_NUMERIC

fixes 0001852
Affected Issues
0001545, 0001852
mod - src/Main/MainCmd.cpp Diff File
mod - src/Main/MainGui.cpp Diff File

Issue History

Date Modified Username Field Change
2014-05-14 16:09 fooons New Issue
2014-05-14 16:14 fooons File Added: Captura de pantalla de 2014-05-14 18:01:00.png
2014-05-14 16:16 wmayer Relationship added has duplicate 0001546
2014-12-03 21:40 wmayer Note Added: 0005352
2015-01-07 11:38 wmayer Relationship deleted has duplicate 0001546
2015-01-07 11:38 wmayer Relationship added related to 0001852
2015-01-07 11:45 wmayer Note Added: 0005546
2015-01-07 14:38 wmayer Note Edited: 0005546 View Revisions
2015-01-24 22:47 wmayer Changeset attached => FreeCAD Master master f32caef4
2015-01-24 22:48 wmayer Status new => closed
2015-01-24 22:48 wmayer Resolution open => fixed
2015-01-24 22:48 wmayer Fixed in Version => 0.15