View Issue Details

IDProjectCategoryView StatusLast Update
0001544FreeCADFeaturepublic2014-05-25 16:48
ReportershoogenAssigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0001544: Python function to retrive direct children of a shape using TopoDS_Iterator
DescriptionCurrently all subshapes can be accessed by their type using the properties Vertexes, Edges, Wires, Faces, Shells, Solids ...
But this does not express the hierarchy of the subshapes.
Additional Informationhttp://opencascade.blogspot.de/2009/02/topology-and-geometry-in-open-cascade_27.html
TagsNo tags attached.

Relationships

related to 0001537 closedyorik python function to apply a placement to a shape 

Activities

wmayer

2014-05-14 16:19

administrator   ~0004676

See git show f9ff3b2

shoogen

2014-05-25 16:33

developer   ~0004726

Last edited: 2014-05-25 16:43

View 3 revisions

The cumOri parameter seems to have no effect.

print face-revwire.childShapes(False,False)[0].Orientation
print face-revwire.dumpToString()

EDIT: This seems to work for cumLoc
Maybe i just don't get how a orientation works.
in dump it looks like the "-2" reverses the orientation. But the plain wire that was used to create the wire was oriented forward.

shoogen

2014-05-25 16:34

developer  

face-revwire.brep.bz2 (Attachment missing)

shoogen

2014-05-25 16:48

developer   ~0004727

> [v.Orientation for v in f.childShapes()[0].childShapes()[0].childShapes()]
['Reversed', 'Forward']

Related Changesets

FreeCAD: master f9ff3b25

2014-05-14 18:14:06

wmayer

Details Diff
+ fixes 0001544: Python function to retrive direct children of a shape using TopoDS_Iterator Affected Issues
0001544
mod - src/Mod/Part/App/TopoShapePy.xml Diff File
mod - src/Mod/Part/App/TopoShapePyImp.cpp Diff File

Issue History

Date Modified Username Field Change
2014-05-14 10:51 shoogen New Issue
2014-05-14 10:53 shoogen Relationship added related to 0001537
2014-05-14 15:50 shoogen Assigned To => shoogen
2014-05-14 15:50 shoogen Status new => assigned
2014-05-14 16:19 wmayer Note Added: 0004676
2014-05-14 16:38 wmayer Changeset attached => FreeCAD Master master f9ff3b25
2014-05-14 16:38 wmayer Assigned To shoogen => wmayer
2014-05-14 16:38 wmayer Status assigned => closed
2014-05-14 16:38 wmayer Resolution open => fixed
2014-05-25 16:33 shoogen Note Added: 0004726
2014-05-25 16:33 shoogen Status closed => feedback
2014-05-25 16:33 shoogen Resolution fixed => reopened
2014-05-25 16:34 shoogen File Added: face-revwire.brep.bz2
2014-05-25 16:40 shoogen Note Edited: 0004726 View Revisions
2014-05-25 16:43 shoogen Note Edited: 0004726 View Revisions
2014-05-25 16:48 shoogen Note Added: 0004727
2014-05-25 16:48 shoogen Status feedback => assigned
2014-05-25 16:48 shoogen Status assigned => closed
2014-05-25 16:48 shoogen Resolution reopened => fixed
2014-05-25 16:48 shoogen Fixed in Version => 0.14