View Issue Details

IDProjectCategoryView StatusLast Update
0001531FreeCADMerge requestpublic2014-05-03 17:21
Reportertanderson69Assigned Towmayer 
PrioritylowSeveritytrivialReproducibilityN/A
Status closedResolutionfixed 
Platformamd64OSKubuntuOS Version 13.10
Product Versiontrunk 
Target VersiontrunkFixed in Version0.14 
Summary0001531: Option for new check in part check geometry
DescriptionI added an additional geometry check(BOPAlgo_ArgumentAnalyzer) for the part check geometry command. This new check isn't giving us much benefit if any. It reports errors on solids that seem to work fine with boolean ops. It is also really slow.

I have made a change that looks for a parameter before running this new check. Parameter defaults to "false"(check won't be run). The user can still edit config file to turn it back on if wanted.

to get this patch.
//assuming origin is sourceforge
git fetch origin d7d387eaa70ad9ea1a2ebf2b8e9aa4c1f986f5bf && git cherry-pick d7d387eaa70ad9ea1a2ebf2b8e9aa4c1f986f5bf
TagsNo tags attached.

Activities

wmayer

2014-05-03 16:46

administrator   ~0004617

> git fetch origin d7d387eaa70ad9ea1a2ebf2b8e9aa4c1f986f5bf
Doesn't work. It gives the errors:

> fatal: Couldn't find remote ref d7d387eaa70ad9ea1a2ebf2b8e9aa4c1f986f5bf
> fatal: The remote end hung up unexpectedly

Are you sure about the hash value? Can I simply merge the branch "tanderson-part-checkGeometry" instead?

tanderson69

2014-05-03 16:53

developer   ~0004618

whoops. That hash was from another branch here. Sorry.

fixed:
//assuming origin is sourceforge
git fetch origin 4d225f771fb2011bb81f2d4ec9e255697e3bc400 && git cherry-pick 4d225f771fb2011bb81f2d4ec9e255697e3bc400

But, yes in this case you could merge it. My master here isn't up to date. so you will probably end up with a merge commit, which is why I went with the cherry pick.

Thanks.

wmayer

2014-05-03 17:20

administrator   ~0004619

The hash is correct now but "git fetch origin ..." still gives the same error. So, I checked older pull requests and there it was only a "git cherry-pick ..." to run and this indeed does the trick. Maybe it's because I did a git pull before?

Issue History

Date Modified Username Field Change
2014-05-03 16:18 tanderson69 New Issue
2014-05-03 16:18 tanderson69 Status new => assigned
2014-05-03 16:18 tanderson69 Assigned To => wmayer
2014-05-03 16:46 wmayer Note Added: 0004617
2014-05-03 16:53 tanderson69 Note Added: 0004618
2014-05-03 17:20 wmayer Note Added: 0004619
2014-05-03 17:21 wmayer Status assigned => closed
2014-05-03 17:21 wmayer Resolution open => fixed
2014-05-03 17:21 wmayer Fixed in Version => 0.14