View Issue Details

IDProjectCategoryView StatusLast Update
0001518SketcherFeaturepublic2017-05-23 04:42
ReporternormandcAssigned Toabdullah 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.16 
Summary0001518: Sketcher - keep geometry tools active until right-click or ESC is hit
DescriptionIf one needs to sketch multiple similar geometries like point arc, circle or single line, he/she has to reactivate the command every time.

This feature request proposes that all sketcher geometry tools remain active until the user either does a mouse right-click or hits the ESC key, terminating the command.

This would keep UI consistency with tools such as Polyline and Trim, which already behave that way.
TagsNo tags attached.

Activities

normandc

2014-04-26 17:26

manager   ~0004576

Relevant forum discussion: http://forum.freecadweb.org/viewtopic.php?f=8&t=6412

yorik

2014-04-26 21:09

administrator   ~0004580

My idea would be a command that relaunches the last used command. You can then bind this command to an easy shortcut key (Enter?) and have a pretty efficient workflow...

But I don't know how easy it would be for a command to know the last command used before it.

yorik

2014-12-31 18:31

administrator   ~0005476

more discussion http://forum.freecadweb.org/viewtopic.php?f=3&t=9148

Pauvres_honteux

2015-01-01 14:38

reporter   ~0005477

Last edited: 2015-01-01 14:46

View 3 revisions

I'd argue for double clicking -> the function/command/operator runs until it's clicked again or escape is pressed or another function/command/operator is clicked.

E.G. draw intersecting lines (rectangel?), then fillet the corners or just trim them. All in all two double click for function/command/operator activation.

Why not make this behavior the default for all functions/commands/operators in the whole programme?

On top of that I'd like to propose this issue as partly relevant: http://www.freecadweb.org/tracker/view.php?id=1416.

normandc

2015-01-01 16:00

manager   ~0005478

Double-clicking to activate a command is not consistent with the rest of the UI.

abdullah

2015-05-22 05:35

manager   ~0006154

I am assigning the feature request to myself as I seem to have found a solution:
http://forum.freecadweb.org/viewtopic.php?f=10&t=10992&start=30

The discussion about this implementation continues here:
http://forum.freecadweb.org/viewtopic.php?f=10&t=11051&p=88863#p88863

Pauvres_honteux

2015-05-24 07:53

reporter   ~0006156

Hi abdullah, on reading your suggestion to utilize RMB for terminating a running command I started thinking; will that not prohibit future use of RMB for anything else, under a running command?

Just for fun, I had a look at the end of this comprehensive issue list and found this: http://www.freecadweb.org/tracker/view.php?id=483
One could use RMB for dragging while in a running command, without ending it. That is; LMB for creation, RMB for moving without deforming. And use RMB for popping up a list of other useful commands related to what one is doing at that very moment, without ending the creation command.

Wouldn't it be nice to have RMB free for future escapades so to say?

How about ending a command by 2xRMB with the pointer in a "blank" area on the screen?
Or RMB+drag the pointer to the left? I use this my self in Firefox with "mouse gestures" to close tabs. It's superfast since it doesn't matter where the cursor is on the screen and I don't need to find and hit an icon.

normandc

2015-05-24 09:31

manager   ~0006157

Read this feature request's description again: using the RMB was *my* suggestion. And it's not a random suggestion: Polyline, Fillet and Trim can *already* be terminated with a single RMB click. Doing the same thing here is consistent with the existing UI: your suggestions _are not_. I will also add that this kind of behavior is common in other CAD programs.

normandc

2017-05-22 20:35

manager   ~0009089

@Kunda1, please explain the rationale behind adding a relationship between this closed issue and 0001416. I don't see any.

Kunda1

2017-05-23 04:42

manager   ~0009097

@normandc I don't recall exactly the rationale. Apologies. I've removed the relationship. Thanks for your attention.

Related Changesets

FreeCAD: master 0bd38013

2015-05-26 16:47:33

Abdullah Tahiri


Committer: wmayer Details Diff
Sketcher: UI Improvement Smart button for constraints and geometry toogle/creation
==================================================================================

Geometry button:
- if no object selected, the legacy toggle icon has a new functionality, switch to/from creating in construction mode
- if object selected, it has the legacy functionality
- the button can be clicked during "continuos creation mode" to switch from creating to/from creating in construction mode

Constraint button:
- The button is not selectable if nothing is selected (it would be impossible to determine the effect)
- When constraints are selected, the button toggles the constraints to/from Driving.
- When geometry is selected, the button switches from/to reference mode, the change is apparent from the color of the constraint icons.

Continuous creation mode:
- Default changed so that it is active unless you change it in settings

Updated terminology
Affected Issues
0001518
mod - src/Mod/Sketcher/Gui/CMakeLists.txt Diff File
mod - src/Mod/Sketcher/Gui/CommandAlterGeometry.cpp Diff File
mod - src/Mod/Sketcher/Gui/CommandConstraints.cpp Diff File
mod - src/Mod/Sketcher/Gui/CommandCreateGeo.cpp Diff File
add - src/Mod/Sketcher/Gui/GeometryCreationMode.h Diff File
mod - src/Mod/Sketcher/Gui/Workbench.cpp Diff File

FreeCAD: master 3b1873f1

2015-05-27 15:50:27

Abdullah Tahiri


Committer: wmayer Details Diff
Sketcher Improvement: Always enable geometry creation
==============================================================================

Now you can switch from one tool to the next just by clicking on the next tool
Affected Issues
0001518
mod - src/Mod/Sketcher/Gui/CommandCreateGeo.cpp Diff File
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2014-04-26 17:26 normandc New Issue
2014-04-26 17:26 normandc Note Added: 0004576
2014-04-26 21:09 yorik Note Added: 0004580
2014-04-30 22:31 yorik Target Version 0.14 =>
2014-05-03 14:23 wmayer Project FreeCAD => Sketcher
2014-12-31 18:31 yorik Note Added: 0005476
2015-01-01 14:38 Pauvres_honteux Note Added: 0005477
2015-01-01 14:45 Pauvres_honteux Note Edited: 0005477 View Revisions
2015-01-01 14:46 Pauvres_honteux Note Edited: 0005477 View Revisions
2015-01-01 16:00 normandc Note Added: 0005478
2015-05-22 05:28 abdullah Assigned To => abdullah
2015-05-22 05:28 abdullah Status new => assigned
2015-05-22 05:35 abdullah Note Added: 0006154
2015-05-24 07:53 Pauvres_honteux Note Added: 0006156
2015-05-24 09:31 normandc Note Added: 0006157
2015-05-31 15:44 wmayer Changeset attached => FreeCAD Master master 0bd38013
2015-05-31 15:44 wmayer Changeset attached => FreeCAD Master master 3b1873f1
2015-05-31 15:45 wmayer Status assigned => closed
2015-05-31 15:45 wmayer Resolution open => fixed
2015-05-31 15:45 wmayer Fixed in Version => 0.16
2017-05-22 13:43 Kunda1 Relationship added related to 0001416
2017-05-22 20:35 normandc Note Added: 0009089
2017-05-23 04:40 Kunda1 Relationship deleted related to 0001416
2017-05-23 04:42 Kunda1 Note Added: 0009097