View Issue Details

IDProjectCategoryView StatusLast Update
0000015FreeCADFeaturepublic2009-11-30 16:45
ReporterJriegelAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000015: Support PCH with cmake for Visual Studio
Description
I have tested building the sources with pre-compiled headers (PCH) enabled
and the generated project files out of cmake which doesn't support PCH at
the moment.

I have built the complete sources for release mode in Visual Studio.

With PCH: 8m20s
Without PCH: 22m10s

This means it needs nearly three times longer without PCH than with. I
think this not acceptable.
TagsNo tags attached.

Activities

Jriegel

2009-09-28 15:38

administrator   ~0000016

OK,
when the basic stuff in 0.9 is runing with cMake we can try to switch the
PCH on again, thought its not really supported by cMake yet.

Jriegel

2009-09-28 15:38

administrator   ~0000017

Werner:

Could already speed up the build process by 0000023:0000020% by removing the Qt4All.h
includes in header files and using the actually needed headers.

In FreeCAD/Gui there is still a huge potential to speed it up because many
.cpp files include unneeded headers.

wmayer

2009-11-30 16:45

administrator   ~0000042

PCH support for Visual Studio is implemented now. At the moment FreeCADBase, FreeCADApp and FreeCADGui use the PCH stuff which reduces the build time dramatically.

Further modules may follow if needed. Nevertheless this issue can be regarded as solved.

Issue History

Date Modified Username Field Change
2009-09-28 15:37 Jriegel New Issue
2009-09-28 15:38 Jriegel Note Added: 0000016
2009-09-28 15:38 Jriegel Note Added: 0000017
2009-09-28 15:50 Jriegel Status new => assigned
2009-09-28 15:50 Jriegel Assigned To => Jriegel
2009-11-30 16:45 wmayer Note Added: 0000042
2009-11-30 16:45 wmayer Status assigned => closed
2009-11-30 16:45 wmayer Resolution open => fixed
2009-11-30 16:45 wmayer Description Updated