View Issue Details

IDProjectCategoryView StatusLast Update
0001478FreeCADFeaturepublic2017-08-22 16:32
ReporterspongmanAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Versiontrunk 
Target VersionFixed in Version 
Summary0001478: trim edge fails to maintain constraints
DescriptionOS: Windows
Platform: 64-bit
Version: 0.14.3310 (Git)
Branch: master
Hash: cd03973a9bd853a8553f1142403bb48259e4dd3e
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
SoQt version: 1.6.0a
OCC version: 6.6.0
Steps To Reproduce- load 'trim bug.fcstd'
- edit 'Sketch'
- note: it's fully constrained
- note: horizontal distance constraints 37 & 38
- Part Design -> Trim Edge the horizontal line segment at (0,18,0)

the horizontal distance constraints have been deleted and the sketch is therefore unconstrained.
TagsSolver, trim

Relationships

related to 0001576 closed Sketcher Slow performance using trim tool (due to Solver

Activities

spongman

2014-03-17 16:47

reporter  

trim bug.FCStd (Attachment missing)

jmaustpc

2015-01-07 13:29

manager   ~0005547

I can't see why you think this is a bug?

You can't do as you have said because you can't trim any thing at 0,18,0 ...the top horizontal line is at (whatever, "16 point something", whatever). If I understand you correctly, you want to trim the top horizontal line in the sketch, this would then make the horizontal constrains invalid so they are automatically removed, so of course the sketch would become not fully constrained.

Have you discussed this on the Help forum?

In general please discuss matters on the Help forum first, so it can be determined if it is a bug or user error etc... before you create mantis tickets. There are a lot more eyes on the forum. :-)

Kunda1

2017-01-19 19:45

administrator   ~0007886

Forum thread to continue discussion: https://forum.freecadweb.org/viewtopic.php?f=10&t=20060

normandc

2017-01-25 03:05

manager   ~0007973

I consider normal that when an element is trimmed, any constraint that was applied to it should be deleted. For example: a line that has an equal length constraint with another line. If one of the lines is trimmed, the equality constraint should be automatically deleted.

But the specific case detailed in this report is different: Constraint37 and Constraint38 are not applied to the line to be trimmed, but on the vertical lines. In the attached capture "FC_trim_bug_1478_01.png", see how the sketch looks like when I delete some constraints so I can detach the top horizontal line. Thus in my opinion, the two 5mm constraints should not be deleted when the upper horizontal line is trimmed.

normandc

2017-01-25 03:05

manager  

FC_trim_bug_1478_01.png (Attachment missing)

Kunda1

2017-05-11 14:26

administrator   ~0008959

@spongman can you reup the attachment. It was lost in the recent backup restore.

normandc

2017-05-11 22:49

manager   ~0008966

Reuploaded image

FC_trim_bug_1478_01-2.png (26,503 bytes)
FC_trim_bug_1478_01-2.png (26,503 bytes)

Kunda1

2017-07-08 14:42

administrator   ~0009681

@normandc do you have trim_bug.FCStd file you can upload ?
@spongman ping

normandc

2017-07-08 17:17

manager   ~0009690

@Kunda1 I don't. I don't keep these files around.

Kunda1

2017-08-22 16:32

administrator   ~0009992

Closing as no activity from OP and example file is missing

Issue History

Date Modified Username Field Change
2014-03-17 16:47 spongman New Issue
2014-03-17 16:47 spongman File Added: trim bug.FCStd
2015-01-06 23:28 wmayer Category Bug => Feature
2015-01-07 13:29 jmaustpc Note Added: 0005547
2017-01-10 13:45 Kunda1 Tag Attached: #tobeclosed
2017-01-19 19:45 Kunda1 Note Added: 0007886
2017-01-19 19:46 Kunda1 Tag Attached: #pending
2017-01-25 03:05 normandc Note Added: 0007973
2017-01-25 03:05 normandc File Added: FC_trim_bug_1478_01.png
2017-01-25 03:47 Kunda1 Status new => feedback
2017-05-10 12:05 Kunda1 Tag Attached: Solver
2017-05-10 12:05 Kunda1 Tag Attached: trim
2017-05-11 14:25 Kunda1 Relationship added related to 0001576
2017-05-11 14:26 Kunda1 Note Added: 0008959
2017-05-11 22:49 normandc File Added: FC_trim_bug_1478_01-2.png
2017-05-11 22:49 normandc Note Added: 0008966
2017-07-08 14:42 Kunda1 Note Added: 0009681
2017-07-08 17:17 normandc Note Added: 0009690
2017-08-22 16:31 Kunda1 Tag Detached: #pending
2017-08-22 16:31 Kunda1 Tag Detached: #tobeclosed
2017-08-22 16:32 Kunda1 Status feedback => closed
2017-08-22 16:32 Kunda1 Resolution open => unable to reproduce
2017-08-22 16:32 Kunda1 Note Added: 0009992