View Issue Details

IDProjectCategoryView StatusLast Update
0001471ArchFeaturepublic2014-07-20 21:30
ReporteryorikAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.15Fixed in Version0.15 
Summary0001471: Arch - Panel object
Description1) a special arch object to represent a panel component (renamed from wikihouse, since many other techniques use this). It must have:

- a base profile
- a thickness property
- a number of plywood sheets to use
- an inscription (id number to be engraved) with position

2) a view object that shows the base profile with engraving

3) a SVG template that represents a plywood sheet

4) possibility to output to DXF
TagsNo tags attached.

Activities

yorik

2014-04-06 16:18

administrator   ~0004536

http://www.wikihouse.cc/

yorik

2014-07-20 21:30

administrator   ~0004820

Basically implemented. Engraving stuff is still not included, since I have not much idea yet on how it should behave.

Related Changesets

FreeCAD: master 6c8c69df

2014-07-20 18:19:51

yorik

Details Diff
Arch: small fix in panel Affected Issues
0001471
mod - src/Mod/Arch/ArchPanel.py Diff File

FreeCAD: master 4414da22

2014-07-20 18:28:43

yorik

Details Diff
Arch: Updated preferences page for panels Affected Issues
0001471
mod - src/Mod/Arch/ArchCommands.py Diff File
mod - src/Mod/Arch/Arch_rc.py Diff File
mod - src/Mod/Arch/Resources/ui/archprefs-defaults.ui Diff File

FreeCAD: master a0bb761d

2014-07-20 18:32:06

yorik

Details Diff
Arch: added panel to cmakelist Affected Issues
0001471
mod - src/Mod/Arch/CMakeLists.txt Diff File

Issue History

Date Modified Username Field Change
2014-03-11 01:25 yorik New Issue
2014-03-11 01:25 yorik Status new => assigned
2014-03-11 01:25 yorik Assigned To => yorik
2014-03-11 01:26 yorik Project FreeCAD => Arch
2014-04-01 02:00 yorik Summary Arch - WikiHouse object => Arch - Panel object
2014-04-01 02:00 yorik Description Updated View Revisions
2014-04-06 16:18 yorik Note Added: 0004536
2014-07-06 15:26 yorik Target Version => 0.15
2014-07-20 21:28 yorik Changeset attached => FreeCAD Master master a0bb761d
2014-07-20 21:29 yorik Changeset attached => FreeCAD Master master 4414da22
2014-07-20 21:29 yorik Changeset attached => FreeCAD Master master 6c8c69df
2014-07-20 21:30 yorik Note Added: 0004820
2014-07-20 21:30 yorik Status assigned => closed
2014-07-20 21:30 yorik Resolution open => fixed
2014-07-20 21:30 yorik Fixed in Version => 0.15