View Issue Details

IDProjectCategoryView StatusLast Update
0001464SketcherFeaturepublic2014-09-18 16:50
ReporterbejantAssigned Toabdullah 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.15 
Summary0001464: Feature Request for Easier Way to Find Conflicting Constraints
DescriptionFrom the following forum thread:
http://forum.freecadweb.org/viewtopic.php?f=8&t=5955

Sketcher reports conflicting constraints by generating a list of these in the Solver Messages area at the top of the Combo View window. When the user scrolls down to the Constraints portion of the Combo View window the Solver Messages window is consequently scrolled up past the top of the Combo View window so the list of conflicting constraints becomes unreadable. This is worse when the Report View and/or Python Console windows are enabled at the bottom of the FreeCAD window because the vertical size of the Combo View window is further reduced.

1. When conflicting constraints occur, highlight them in the Constraints window and in the 3D window. Maybe when Solver reports redundant constraints in orange text, highlight the corresponding constraints in orange in the Constraints window and in the 3D window. Ditto for conflicting constraints but in red.

2. Create a feature where the user can right-click on a constraint in the constraints window and have an option the zoom in to that constraint in the 3D window.

3. Create a feature whereby the user can opt to make the Solver window stay at the top of the Combo View window when scrolling down. Maybe another little button next to the expand / collapse button (it looks like a chevron) at the top right?
TagsNo tags attached.

Relationships

related to 0001643 closedabdullah Sketcher: Button to remove all redundant constraints. 

Activities

abdullah

2014-09-18 13:37

manager   ~0005124

Fixed in current master as of today (will appear in the PPA tomorrow).

Instead of automatically removing the constraints, it selects the conflicting/redundant constraints, then you press supr if you are happy with the selection.

Issue History

Date Modified Username Field Change
2014-03-07 17:25 bejant New Issue
2014-08-24 09:25 wmayer Relationship added related to 0001643
2014-09-02 13:48 abdullah Assigned To => abdullah
2014-09-02 13:48 abdullah Status new => assigned
2014-09-18 13:37 abdullah Note Added: 0005124
2014-09-18 13:37 abdullah Status assigned => resolved
2014-09-18 13:37 abdullah Fixed in Version => 0.15
2014-09-18 13:37 abdullah Resolution open => fixed
2014-09-18 16:50 wmayer Status resolved => closed