View Issue Details

IDProjectCategoryView StatusLast Update
0001460GCS[Sketcher] Bugpublic2018-06-09 09:14
ReporterKjell_ElsterAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntelOSWindowsOS Version7
Product Version0.13 
Target VersionFixed in Version 
Summary0001460: Changing size sometimes cause overconstrained model
DescriptionI have a sketch of an IKEA Ivar shelf.
When I try to change the size, length or width, by a small amount things changes as expected. When I try a large change one of the lines changes direction and constraint errors are reported.

You can get to the "large result" by doing it in small increments so it's not the static values that are the (obvious) problem but "large" increment.
Steps To Reproduce1. Load the sample file and open the extruded sketch. Not sketch_01!
2. Change the x-width from 160 to 170. It works nicely.
3. Undo
4. Change the x-width from 160 to 260! Lots of constraint errors.
Additional InformationI also expected this sketch to be closed so the extrusion would have had a top and a bottom, not just sides.
TagsSolver

Relationships

related to 0000754 assignedabdullah Sketcher doesn't report that a fully constrained sketch may have multiple (finite) solutions 

Activities

Kjell_Elster

2014-03-03 22:58

reporter  

Hyllplan.FCStd (5,728 bytes)

normandc

2014-03-04 01:19

manager   ~0004371

>I also expected this sketch to be closed so the extrusion would have had a top and a bottom, not just sides.

Have you not noticed the "Create solid" checkbox when you created the Extrude?

In any case if you want to create solids from sketches, use Part Design Pad, not Part Extrude.

Kjell_Elster

2014-03-04 08:28

reporter   ~0004372

No I haven't noticed it [Create Solid], but I was looking something like it.
My experience is limited to Alibre, and only a little of it.

How to choose a way to work is a mystery to me.
Why one should choose one <what ever you call it> over something else.

tanderson69

2014-03-04 17:19

developer   ~0004382

Kjell_Elster,
The bug tracker is not a good place to get experience with freecad. Your best bet is to post your questions/problems on the forum and let some of the veterans help you determine if/what is a bug. Thanks and good luck.

Kjell_Elster

2014-03-04 17:42

reporter   ~0004383

Just ignore the "additional information". I do think I have described an error.

Kjell_Elster

2014-03-04 23:12

reporter   ~0004384

The added relationship seems correct.
The sketch is indeed under constrained. There are multiple solutions to the set of constraints I had given. The sketcher reports fully constrained.

normandc

2014-03-05 01:14

manager   ~0004385

Sorry, I forgot to add that I could duplicate the problem on latest master branch. AFAIK this is indeed a bug because the small line segments switch sides.

One workaround: if you delete Constraint33 (160 mm) and replace it with a horizontal distance constraint that spans the whole width of the profile rather than just the horizontal line, you will notice that the error does not repeat.

As tanderson69 said, the rest is a discussion for the forum.

OS: Ubuntu 12.04.4 LTS
Platform: 64-bit
Version: 0.14.3252 (Git)
Branch: master
Hash: 246c895d448f845e967145528321075849a87de0
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0

Kunda1

2017-04-28 16:14

administrator   ~0008807

@normandc is this issue still persistent?

abdullah

2017-12-12 15:04

manager   ~0010587

@Kunda1

I can reproduce with the current PPA

OS: Ubuntu 16.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12772 (Git)
Build type: None
Branch: master
Hash: c8c9b76f43d2c78c4afb65b756f3f07d626aac85
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0

It is a combination of the solver limitation (flipping) and poor constraint selection.

abdullah

2018-06-09 09:14

manager   ~0011379


This one has finally been fixed with the merge of the redundant detection.

Now, when opening the sketch it reports redundant constraints. After deleting those you can set the 160 dimension to whatever value without any constraint issue.

Issue History

Date Modified Username Field Change
2014-03-03 22:58 Kjell_Elster New Issue
2014-03-03 22:58 Kjell_Elster File Added: Hyllplan.FCStd
2014-03-04 01:19 normandc Note Added: 0004371
2014-03-04 08:28 Kjell_Elster Note Added: 0004372
2014-03-04 17:19 tanderson69 Note Added: 0004382
2014-03-04 17:42 Kjell_Elster Note Added: 0004383
2014-03-04 18:32 wmayer Relationship added related to 0000754
2014-03-04 23:12 Kjell_Elster Note Added: 0004384
2014-03-05 01:14 normandc Note Added: 0004385
2014-03-05 08:52 wmayer Assigned To => logari81
2014-03-05 08:52 wmayer Status new => assigned
2017-04-02 08:56 kkremitzki Status assigned => new
2017-04-02 08:56 kkremitzki Assigned To logari81 =>
2017-04-28 16:14 Kunda1 Note Added: 0008807
2017-12-12 15:02 abdullah Tag Attached: Solver
2017-12-12 15:04 abdullah Note Added: 0010587
2017-12-13 15:20 Kunda1 Project Sketcher => GCS
2018-06-09 09:14 abdullah Assigned To => abdullah
2018-06-09 09:14 abdullah Status new => closed
2018-06-09 09:14 abdullah Resolution open => fixed
2018-06-09 09:14 abdullah Note Added: 0011379