View Issue Details

IDProjectCategoryView StatusLast Update
0001450FreeCADBugpublic2015-07-02 12:49
Reportertanderson69Assigned Totanderson69 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSKubuntuOS Version 13.10
Product Versiontrunk 
Target VersionFixed in Version0.16 
Summary0001450: model refine corrupts solid with spherical edges.
DescriptionBRepLib_FuseEdges corrupts topology with spherical edges.
Steps To Reproducehttp://forum.freecadweb.org/viewtopic.php?f=10&t=2389&start=100#p47482
Additional InformationI think we can work around this problem. Somebody can assign this bug too me or give me the permissions to do it.
TagsNo tags attached.

Activities

tanderson69

2014-02-28 22:07

developer   ~0004335

fix is on the sourceforge branch tanderson-merge-partCheckGeometry

git cherry-pick 2f5d8230f933388517e63c15fee9091e98921a1b

wmayer

2014-03-01 12:16

administrator   ~0004338

git show 7d853e3

tanderson69

2014-03-03 02:17

developer   ~0004358

the breplib_fuseedge bug affects goes beyond spherical edges. see http://forum.freecadweb.org/viewtopic.php?f=10&t=2389&start=100#p47653 for an example.

modified code to avoid all geom_conics for edges.
//assuming origin is sourceforge
git fetch origin cb3b129af877c83b4717d2cee44befe6d0cb58be && git cherry-pick cb3b129af877c83b4717d2cee44befe6d0cb58be

shoogen

2014-03-03 08:52

developer   ~0004360

tanderson:
by using "cherry-pick --ff" you get a fast forward merge if possible.

wmayer

2014-03-03 09:34

administrator   ~0004361

git show 4f6b64f

shoogen

2014-12-11 23:54

developer   ~0005369

Last edited: 2014-12-11 23:56

View 2 revisions

// TODO: change this version after occ fix. Freecad Mantis 1450
#if OCC_VERSION_HEX <= 0x070000

AFAIK the problem is not scheduled for 7.0.0
http://tracker.dev.opencascade.org/view.php?id=24692

tanderson69

2014-12-12 13:46

developer   ~0005370

I put the directive there as more of a place holder. We can just increase the number or comment out directive completely for now.

shoogen

2014-12-12 17:58

developer   ~0005371

I'd suggest to increase the number to something large like 0x7f0000
to indicate that the fix is not yet available

tanderson69

2015-07-01 18:51

developer   ~0006239

looking at the code for "OCC version: 6.8.0.oce-0.17-dev": calling BrepLib_FuseEdges::Perform directly has a different execution path than calling it indirectly through BrepLib_FuseEdges::Faces. Removing the Perform call gets desired results.

Related Changesets

FreeCAD: master fe4ab358

2015-01-08 08:56:09

shoogen


Committer: yorik Details Diff
issue 0001450 Affected Issues
0001450
mod - src/Mod/Part/App/modelRefine.cpp Diff File

Issue History

Date Modified Username Field Change
2014-02-27 18:42 tanderson69 New Issue
2014-02-27 22:43 wmayer Assigned To => tanderson69
2014-02-27 22:43 wmayer Status new => assigned
2014-02-28 22:07 tanderson69 Note Added: 0004335
2014-03-01 12:16 wmayer Note Added: 0004338
2014-03-01 12:16 wmayer Status assigned => closed
2014-03-01 12:16 wmayer Resolution open => fixed
2014-03-01 12:16 wmayer Fixed in Version => 0.14
2014-03-03 02:17 tanderson69 Note Added: 0004358
2014-03-03 02:17 tanderson69 Status closed => feedback
2014-03-03 02:17 tanderson69 Resolution fixed => reopened
2014-03-03 08:52 shoogen Note Added: 0004360
2014-03-03 09:34 wmayer Note Added: 0004361
2014-03-03 09:35 wmayer Status feedback => closed
2014-03-03 09:35 wmayer Resolution reopened => fixed
2014-12-11 23:54 shoogen Note Added: 0005369
2014-12-11 23:54 shoogen Status closed => feedback
2014-12-11 23:54 shoogen Resolution fixed => reopened
2014-12-11 23:56 shoogen Note Edited: 0005369 View Revisions
2014-12-12 13:46 tanderson69 Note Added: 0005370
2014-12-12 13:46 tanderson69 Status feedback => assigned
2014-12-12 17:58 shoogen Note Added: 0005371
2015-01-10 14:40 yorik Changeset attached => FreeCAD Master master fe4ab358
2015-07-01 18:51 tanderson69 Note Added: 0006239
2015-07-02 12:49 wmayer Status assigned => closed
2015-07-02 12:49 wmayer Resolution reopened => fixed
2015-07-02 12:49 wmayer Fixed in Version 0.14 => 0.16