View Issue Details

IDProjectCategoryView StatusLast Update
0001419FreeCADBugpublic2015-01-17 15:13
ReporterthemightyhulkAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformASUS UltrabookOSWindowsOS Version8.1.
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001419: FreeCAD crash on sweep/loft
DescriptionI am running FreeCAD version 0.13 on my ASUS Ultrabook (sufficient RAM and 2 GB NVIDIA graphics card) under Windows 8.1.

I quickly have gotten the hang of the program and very much love using it. However, this simply isn't entirely possible with the currently installed version since the program keeps crashing eventually and consistently while trying to design various objects.
Steps To ReproduceCreate three different sketches with each one circle (all circles have identical values) that are positioned some distance apart across the z-axis.

Rotate the "center circle" 90 degrees so it is 'standing up' in relation to the two others.

Select the three sketches/circles and use 'utility to loft'.


Attention <-- FreeCAD first loses it's basic wireframe (ground level) when creating the second sketch/circle, then crashes when selecting and using 'utility to loft' on the three selected circles.
Additional InformationTrying to create a bent 'pipe' out of three circle objects located within three different sketches using 'utility to loft'.
TagsNo tags attached.

Relationships

has duplicate 0001392 closedwmayer PartDesign When I use the sweep tool, the computer crashes. 
related to 0001764 closed FreeCAD Cannot sweep a circle section along a curved edge as solid 
related to 0001926 acknowledgedshoogen Part Crash when creating sweep (fix pending on the upstream release of OCC 7.5) 

Activities

shoogen

2014-02-17 21:52

developer   ~0004233

can you please check if your graphics card driver was certified for your version of MS Windows?

themightyhulk

2014-02-19 09:25

reporter   ~0004237

Hi and thanks for your swift response.

I just tried to update my NVIDIA driver for the graphics card to the latest version (my old version was installed end of October 2013).

Rebooted hereafter and tried fooling around with the program once again. This time the program crashed after a cylinder was created and then separated into two with the cross-sections command.

The crash report in Windows 8.1. stated the following...

An unhandled win32 exception occured in FreeCAD.exe [5948].

No idea as to what that means but here goes.


Note: My personal impression is that something withing FreeCAD independently from other external problems makes the application crash when certain commands are performed. At various occasions and with various commands that is and not only limited to the initial problem reported.

Awaiting your reply.

themightyhulk

2014-03-10 10:51

reporter   ~0004403

Hi,

just wondering what the state of this bug report is right now?

Has there been any progress on the issue? Or is there work being done in relation to solving the problem?

Any update is most appreciated.

Thanks.

wmayer

2014-03-10 12:44

administrator   ~0004404

I don't think so. But there are two things you can check:
* look under %APPDATA%\FreeCAD if you can find a crash.dmp file
* run FreeCAD with the parameter "--write-log" and repeat the crash. Under %APPDATA%\FreeCAD you should find a file FreeCAD.log.

Then it might be worth to try one of the 0.14 pre-releases to see if the problem persists.

themightyhulk

2014-03-27 14:27

reporter   ~0004496

Hi and thanks for your response...

I have been looking into the AppData folder under PC --> C: drive --> Users --> Nameofpc --> AppData --> Local --> freecad --> freecad

...but there are only three items there called .freecad (folder) plus assistant.qch.4.5 and freecad.qhc (files).

In the folder there are furthermore two files called _bi.cfs, deletable and segments.

Nowhere can I find the crash.dmp file, neither if I search for it on the whole hard drive.

Could you elaborate on the last two points out of the three that you mentioned in your last post (running the parameter and what you meant in relation to using the 0.14 release)?

Thank you.

wmayer

2014-03-27 14:51

administrator   ~0004497

C:\Users\Nameofpc\AppData\Local\freecad\freecad is NOT the same as %APPDATA%\FreeCAD. %APPDATA% is in environment variable and points to C:\Users\Nameofpc\AppData\Roaming so you have to look under C:\Users\Nameofpc\AppData\Roaming\FreeCAD

> Nowhere can I find the crash.dmp file, neither if I search for it on the whole hard drive.

This means that in 0.13 we did not have this feature implemented. But you can try one of the 0.14 snapshots then.

And if you run FreeCAD with the option above you must find the FreeCAD.log file also under C:\Users\Nameofpc\AppData\Roaming\FreeCAD

themightyhulk

2014-04-04 15:41

reporter   ~0004528

Last edited: 2014-04-04 15:45

View 5 revisions

Hi again,

okay. Thanks for the info.

But if I understand you right you are saying two things here.

1. The crash.dmp file is first created in and a feature of FreeCAD 0.14

and...

2. you recommend installing one of the versions from this site...

http://sourceforge.net/projects/free-cad/files/FreeCAD%20Windows/FreeCAD%200.14%20unstable/

However the documentation says about those versions the following...


Development Versions

If you want to install FreeCAD with more in-development features, and are willing to accept that these versions have a higher chance of bugs and crashes, then you can check the official FreeCAD Files page to download 64 bit, older, or unstable releases.


Thus I would install another version (beta on top) that has an even higher likelihood of bugs and crashing than the present one, just to recreate the same problem stated in this thread and to make the program crash and create a crash.dmp file.

Is this correctly understood?

Because if so I really can't see the improvement nor the greater good of all of that.

Thank you.

wmayer

2014-04-05 09:20

administrator   ~0004529

> 1. The crash.dmp file is first created in and a feature of FreeCAD 0.14
Yes. First I wasn't sure when it was introduced but obviously it was not there in 0.13.

> 2. you recommend installing one of the versions from this site...
When using the latest version of 0.14 you have all required features to help to troubleshoot the issue.

A development version usually offers new features which might not be tested so well. So, there is higher risk to get a crash because the user uses the new feature in a way the developer never thought of.

On the other hand the development version contains many bug fixes which have never been added to the stable version for this or that reason.

But anyway you can also have both versions installed parallel to see directly if something works in 0.14 that didn't work in 0.13. So, you don't have to decide for the one or the other.

Last but not least, a good amount of crashes is because the CAD kernel (a 3rd party library) causes them which is often not possible to handle them from our side.

wmayer

2014-04-05 09:28

administrator   ~0004530

Btw, would it be possible to upload the fcstd file containing the three sketches?

themightyhulk

2014-04-30 19:54

reporter  

circles_test_freecad_sketch.FCStd (Attachment missing)

themightyhulk

2014-04-30 19:54

reporter  

circles_test_freecad_sketch.FCStd1 (Attachment missing)

themightyhulk

2014-04-30 19:55

reporter   ~0004597

Sure thing!

Here they are. There were two. No idea as to why but here they are both uploaded.

Let me know how things proceed and if you have gotten to a conclusion and which one if so when you had a look at the issue.

Thanks again.

wmayer

2014-05-03 16:35

administrator   ~0004616

Your description lacks of some information and doesn't really fit to the uploaded project file. In your initial post you talk about a "center circle" and "two others" so that I assume you had three circles. But the attached file has four circles.

To continue I removed Sketch003. Then it's not clear how you rotated the center circle (Sketch002). I used rotation axis (0,1,0) and 90 degree.

Also it's not clear when running the loft of which order they are. You see this in the right part of the loft panel. So, I used: Sketch, Sketch002, Sketch001.

The result is invalid because it has self-intersections but it does NOT crash.

Tested with 0.13.1828

So, if my way differs from yours then please describe your steps as close as possible.

themightyhulk

2014-05-05 16:08

reporter  

circles_test_freecad_sketch_revamped.FCStd (Attachment missing)

themightyhulk

2014-05-05 16:09

reporter  

freecad_crash1_avi.avi (Attachment missing)

themightyhulk

2014-05-05 16:10

reporter  

freecad_crash2_avi.avi (Attachment missing)

themightyhulk

2014-05-05 16:16

reporter   ~0004627

Trust me..., it DOES crash as described.

I guess I added the fourth circle later on and just forgot about it. However, I attached three files once and again so you can have a look for yourself.

The first two are avi's which show screen-recordings of two slightly different attempts to use 'utility to sweep' (apologies as I mentioned 'utility to loft' for some odd reason in my initial description) and yes, they do crash both as you can see in the videos.

The third file is a revamped freecad version. Oddly I can now rotate the two circles on the outer side and move the center circle without problems to the position I want to. This wasn't the case last time. The grid is still not visible apart from in the edit view of the sketch mode.

So use this file on a Windows 8.1. machine and I assure you it WILL crash each and every time.

Waiting for your reply...

wmayer

2014-05-05 17:10

administrator   ~0004628

Great! Thanks for providing this video. Now I am able to confirm this crash. I'll check by what it is caused...

wmayer

2014-05-05 20:45

administrator   ~0004630

First of all, using the sweep command doesn't make any sense here. You should really use the loft command.

For the sweep you need two (or more) profiles and a path (also called trajectory) which usually goes through the profiles. And the path cannot be a profile at the same time. Also note, the path cannot be selected inside the sweep panel but you have to select one or more adjacent edges in the 3d view. But even when selecting the path this way you'll get a crash.

So this means the bug can be split into two parts.
1) a check to make sure that the path is not used as profile, too (FreeCAD bug)
2) a crash inside the algorithmic part (OpenCascade bug)

The part 1) that we can fix is fixed with "git show 94f10f5". The second part is something we can't fix.

However, in 0.14 we lately set some special compiler flags so that some major issues (like segmentation faults) are converted into C++ exceptions and thus can be handled by the application without crashing it. So, this means the sweep still fails but it doesn't crash FreeCAD any more.

themightyhulk

2014-05-06 16:26

reporter   ~0004633

I got it...!

Both the utility to loft is working if I use two circles that are placed directly opposite each other and some distance apart. That is if they aren't suppose to bend but just create a single pipe.

In relation to the utility to sweep I previously had crashes as far as I remember. However this time it DID work. I just followed your steps including the path/trajectory. And this time the three parts with the path DO create a bent pipe. All three sections from left to center to right circle. Only issue remaining is a small curl or ripple in the bottom of the center section/circle. Any ideas as to why that part ripples...?

However in regards to the crash I now know when and why it happens. It was due to my attempt to use the three circles with utility to loft all while I missed the part with the trajectory. Just applying the utility to loft filter without the trajectory on those three circles, when two of them were on the exact same axis some distance apart from each other all while the third circle was centered in between the two standing 90 degrees upright, would cause the program to crash.

As I understand from your answer this is now causing an error report in the 0.14 version instead of making the whole program crash but still doesn't apply any visible change to the objects. Which makes sense since it shouldn't be possible to apply utility to sweep on several objects without having a trajectory for it to follow.

So the only real 'problem' and cause for the crash was due to a false application of the filter utility to sweep.

Just to give you some feedback on this one.

Thanks for your time and help. Also the one that you put into this free application. I'll be continuing to fool around with it in the near future... ;-)

Cheers mate!

themightyhulk

2014-05-06 16:27

reporter  

circles_test_freecad_sketch_revamped_and_solved.FCStd (Attachment missing)

themightyhulk

2014-05-06 16:28

reporter   ~0004634

Added the file with the solution and final outcome btw!

shoogen

2014-05-08 09:47

developer   ~0004643

should we close this ticket?
http://tracker.dev.opencascade.org/view.php?id=24909

wmayer

2014-05-08 16:54

administrator   ~0004646

Let it open as a reminder that I have to make the sweep panel a bit user friendlier.

wmayer

2014-05-13 12:38

administrator   ~0004667

git show 0874bfa implements path selection in sweep panel.

Related Changesets

FreeCAD: master 94f10f5d

2014-05-05 22:24:16

wmayer

Details Diff
+ issue 0001419: FreeCAD crash on Windows 8.1. Affected Issues
0001419
mod - src/Mod/Part/Gui/TaskSweep.cpp Diff File

Issue History

Date Modified Username Field Change
2014-02-17 17:19 themightyhulk New Issue
2014-02-17 21:52 shoogen Note Added: 0004233
2014-02-19 09:25 themightyhulk Note Added: 0004237
2014-03-10 10:51 themightyhulk Note Added: 0004403
2014-03-10 12:44 wmayer Note Added: 0004404
2014-03-27 14:27 themightyhulk Note Added: 0004496
2014-03-27 14:51 wmayer Note Added: 0004497
2014-04-04 15:41 themightyhulk Note Added: 0004528
2014-04-04 15:42 themightyhulk Note Edited: 0004528 View Revisions
2014-04-04 15:43 themightyhulk Note Edited: 0004528 View Revisions
2014-04-04 15:44 themightyhulk Note Edited: 0004528 View Revisions
2014-04-04 15:45 themightyhulk Note Edited: 0004528 View Revisions
2014-04-05 09:20 wmayer Note Added: 0004529
2014-04-05 09:28 wmayer Note Added: 0004530
2014-04-05 09:29 wmayer Status new => feedback
2014-04-30 19:53 themightyhulk Tag Attached: file format
2014-04-30 19:53 themightyhulk Tag Detached: file format
2014-04-30 19:54 themightyhulk File Added: circles_test_freecad_sketch.FCStd
2014-04-30 19:54 themightyhulk File Added: circles_test_freecad_sketch.FCStd1
2014-04-30 19:55 themightyhulk Note Added: 0004597
2014-04-30 19:55 themightyhulk Status feedback => new
2014-05-03 16:35 wmayer Note Added: 0004616
2014-05-05 16:08 themightyhulk File Added: circles_test_freecad_sketch_revamped.FCStd
2014-05-05 16:09 themightyhulk File Added: freecad_crash1_avi.avi
2014-05-05 16:10 themightyhulk File Added: freecad_crash2_avi.avi
2014-05-05 16:16 themightyhulk Note Added: 0004627
2014-05-05 17:10 wmayer Note Added: 0004628
2014-05-05 17:10 wmayer Assigned To => wmayer
2014-05-05 17:10 wmayer Status new => confirmed
2014-05-05 20:45 wmayer Note Added: 0004630
2014-05-05 20:45 wmayer Status confirmed => resolved
2014-05-05 20:45 wmayer Fixed in Version => 0.14
2014-05-05 20:45 wmayer Resolution open => fixed
2014-05-05 20:48 wmayer Changeset attached => FreeCAD Master master 94f10f5d
2014-05-06 16:26 themightyhulk Note Added: 0004633
2014-05-06 16:26 themightyhulk Status resolved => feedback
2014-05-06 16:26 themightyhulk Resolution fixed => reopened
2014-05-06 16:27 themightyhulk File Added: circles_test_freecad_sketch_revamped_and_solved.FCStd
2014-05-06 16:28 themightyhulk Note Added: 0004634
2014-05-06 16:28 themightyhulk Status feedback => assigned
2014-05-07 14:09 shoogen Summary FreeCAD crash on Windows 8.1. => FreeCAD crash on sweep/loft
2014-05-08 09:47 shoogen Note Added: 0004643
2014-05-08 16:54 wmayer Note Added: 0004646
2014-05-12 15:11 wmayer Relationship added has duplicate 0001392
2014-05-12 18:17 shoogen Priority urgent => normal
2014-05-13 12:38 wmayer Note Added: 0004667
2014-05-13 12:38 wmayer Status assigned => closed
2014-05-13 12:38 wmayer Resolution reopened => fixed
2014-09-24 13:14 shoogen Relationship added related to 0001764
2015-01-17 15:13 shoogen Relationship added related to 0001926