View Issue Details

IDProjectCategoryView StatusLast Update
0000014FreeCADFeaturepublic2010-01-12 18:44
ReporterJriegelAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000014: Sketch object
DescriptionAn object which is dedicated to 2D CAD data.
Its derived from Part object and have additional like a
grid in the view. The local koordinates set up a plane where the 2D data
live in the 3D space.
TagsNo tags attached.
FreeCAD Information

Relationships

parent of 0000021 closedJriegel Reimplementation of Sketch solver 

Activities

Jriegel

2009-09-28 15:36

administrator   ~0000015

Yorik:

I think a grid is a very good idea, but are you sure it is necessary to
have a second coordinate set? I think 2D data are, in an app like FreeCAD,
just there as a starter point for building 3D from it, right? So, 2D shapes
should be freely moveable and "drawable" in the 3D space...

Or are you thinking of a kind of "temporary workplane" that follows you?
This would be cool... like, for example, your mouse is on top of an
existing face, and the work plane becomes the face. This would make many
operations easier... 2D works should only care about 2D coordinates, and
FreeCAD would place all this in the 3D space nicely.

Other interesting thing, that workplane could have cool helpers, like a
grid, but also things like alignment axis, etc...

I am thinking that such a workplane could be an easier space for
experimenting with constrain solving too.

One thing I wonder: would all 2D data belong to such an object? Or maybe
it should be considered a helper, only present when you draw. Because a
very interesting thing, in my opinion, is that everything you draw with
Part objects, is already 3D-ready... Once you draw shapes, you only need to
extrude and you have 3d solids. This is very easy...

Jriegel

2010-01-12 18:44

administrator   ~0000146

implemented as Part2DObject

Issue History

Date Modified Username Field Change
2009-09-28 15:35 Jriegel New Issue
2009-09-28 15:36 Jriegel Note Added: 0000015
2009-09-28 15:50 Jriegel Status new => assigned
2009-09-28 15:50 Jriegel Assigned To => Jriegel
2009-09-28 15:55 Jriegel Relationship added parent of 0000021
2010-01-12 18:44 Jriegel Note Added: 0000146
2010-01-12 18:44 Jriegel Status assigned => closed
2010-01-12 18:44 Jriegel Resolution open => fixed