View Issue Details

IDProjectCategoryView StatusLast Update
0001375FreeCADBugpublic2017-03-27 08:25
Reporterulrich1a Assigned Towmayer  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows 7 32 bitOS Version
Product Versiontrunk 
Target VersionFixed in Version 
Summary0001375: FreeCAD does not support of pivy and shiboken in Libpack8.x
DescriptionCompiling FreeCAD after PySide-Migration still works with Libpack8.x. But calling any Python-Workbench gives problems. There are missing the needed build settings in the file cMake/UseLibPack8x.cmake. See also this post: http://forum.freecadweb.org/viewtopic.php?f=10&t=5303&start=80#p43747
Steps To ReproduceBuild FreeCAD 32 bit on Windows 7 with Libpack8.2.
Calling the Draft-Workbench gives errors.
TagsNo tags attached.
FreeCAD Information

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master c7e41c61

2014-02-09 18:59:35

Jriegel

Details Diff
PySide switch for LibPack >= 8.2 default on in the vanilla sourc

This means that you need 8.2 or higher or you have to switch of FREECAD_LIBPACK_USEPYSIDE!
Affected Issues
0001375
mod - CMakeLists.txt Diff File
mod - cMake/UseLibPack8x.cmake Diff File

FreeCAD: master 8b610aff

2014-02-10 10:52:18

wmayer

Details Diff
+ fixes 0001375: FreeCAD does not support of pivy and shiboken in Libpack8.x Affected Issues
0001375
mod - cMake/UseLibPack8x.cmake Diff File

FreeCAD: master 00608325

2014-02-10 11:23:01

wmayer

Details Diff
+ undo changes of 8b610aff on issue 0001375 because this was done in c7e41c Affected Issues
0001375
mod - cMake/UseLibPack8x.cmake Diff File

Issue History

Date Modified Username Field Change
2014-01-30 21:07 ulrich1a New Issue
2014-02-10 10:20 wmayer Changeset attached => FreeCAD Master master 8b610aff
2014-02-10 10:20 wmayer Assigned To => wmayer
2014-02-10 10:20 wmayer Status new => closed
2014-02-10 10:20 wmayer Resolution open => fixed
2017-03-27 08:23 Kunda1 Changeset attached => FreeCAD master 00608325
2017-03-27 08:25 Kunda1 Changeset attached => FreeCAD master c7e41c61