View Issue Details

IDProjectCategoryView StatusLast Update
0001344PartDesignBugpublic2014-03-09 10:23
Reporterrymdhund Assigned Towmayer  
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Platformamd64OSDebianOS VersionWheezy
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001344: Freecad crashes when i make a sketch on a face
DescriptionIn PartDesign when i try to create a sketch on a selected face it crashes with error:

FreeCAD: SoCoordinateElement.cpp:169: const SbVec3f& SoCoordinateElement::get3(int) const: Assertion `index >= 0 && index < this->numCoords' failed.

It doesn't happen every time, but at least half of the times.

I'm running the latest git (88f1c2c).
Steps To ReproduceCreate new document
Go to part design
Create box
Select the face
Click create sketch
Additional Information#0 0x00007f038eb191e5 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f038eb1c398 in abort () from /lib/x86_64-linux-gnu/libc.so.6
0000002 0x00007f038eb12272 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
0000003 0x00007f038eb12322 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
0000004 0x00007f0394cd7146 in SoCoordinateElement::get3(int) const () from /usr/lib/libCoin.so.60
0000005 0x00007f0394ed5c7f in SoLineSet::generatePrimitives(SoAction*) () from /usr/lib/libCoin.so.60
0000006 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000007 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000008 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000009 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000010 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000011 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000012 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000013 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000014 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000015 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000016 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000017 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000018 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000019 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000020 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000021 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000022 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000023 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000024 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000025 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000026 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000027 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000028 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000029 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000030 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000031 0x00007f0394e88c57 in SoNode::rayPickS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000032 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000033 0x00007f0394c7bfdb in SoPickAction::beginTraversal(SoNode*) () from /usr/lib/libCoin.so.60
0000034 0x00007f0394c7f7b6 in SoRayPickAction::beginTraversal(SoNode*) () from /usr/lib/libCoin.so.60
0000035 0x00007f0394c70fa2 in SoAction::apply(SoNode*) () from /usr/lib/libCoin.so.60
0000036 0x00007f0394c7b1df in SoHandleEventActionP::doPick(SoRayPickAction*) () from /usr/lib/libCoin.so.60
0000037 0x00007f0394c7b311 in SoHandleEventAction::getPickedPointList() () from /usr/lib/libCoin.so.60
0000038 0x00007f03975c57da in Gui::SoFCUnifiedSelection::getPickedPoint(SoHandleEventAction*) const ()
   from /xxx/freecad/lib/libFreeCADGui.so
#39 0x00007f03975c621c in Gui::SoFCUnifiedSelection::handleEvent(SoHandleEventAction*) () from /xxx/freecad/lib/libFreeCADGui.so
#40 0x00007f0394e88db7 in SoNode::handleEventS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000041 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000042 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000043 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000044 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000045 0x00007f0394e88db7 in SoNode::handleEventS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000046 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000047 0x00007f0394db304c in SoChildList::traverse(SoAction*, int, int) () from /usr/lib/libCoin.so.60
0000048 0x00007f0394e7e85d in SoGroup::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000049 0x00007f0394e9ab2f in SoSeparator::doAction(SoAction*) () from /usr/lib/libCoin.so.60
0000050 0x00007f0394e88db7 in SoNode::handleEventS(SoAction*, SoNode*) () from /usr/lib/libCoin.so.60
0000051 0x00007f0394c70765 in SoAction::traverse(SoNode*) () from /usr/lib/libCoin.so.60
0000052 0x00007f0394c7b12a in SoHandleEventAction::beginTraversal(SoNode*) () from /usr/lib/libCoin.so.60
0000053 0x00007f0394c70fa2 in SoAction::apply(SoNode*) () from /usr/lib/libCoin.so.60
0000054 0x00007f0394e405d9 in SoEventManager::actuallyProcessEvent(SoEvent const*) () from /usr/lib/libCoin.so.60
0000055 0x00007f039473eecc in SoQtRenderArea::processSoEvent(SoEvent const*) () from /usr/lib/libSoQt4.so.20
0000056 0x00007f039476962b in SoQtViewer::processSoEvent(SoEvent const*) () from /usr/lib/libSoQt4.so.20
0000057 0x00007f0397647aa9 in Gui::View3DInventorViewer::processSoEventBase(SoEvent const*) () from /xxx/freecad/lib/libFreeCADGui.so
0000058 0x00007f039762fc45 in Gui::NavigationStyle::processSoEvent(SoEvent const*) () from /xxx/freecad/lib/libFreeCADGui.so
0000059 0x00007f03976347ff in Gui::CADNavigationStyle::processSoEvent(SoEvent const*) () from /xxx/freecad/lib/libFreeCADGui.so
0000060 0x00007f039762fb8e in Gui::NavigationStyle::processEvent(SoEvent const*) () from /xxx/freecad/lib/libFreeCADGui.so
0000061 0x00007f0397647a75 in Gui::View3DInventorViewer::processSoEvent(SoEvent const*) () from /xxx/freecad/lib/libFreeCADGui.so
0000062 0x00007f0394741832 in SoQtRenderArea::processEvent(QEvent*) () from /usr/lib/libSoQt4.so.20
0000063 0x00007f0397647563 in Gui::View3DInventorViewer::processEvent(QEvent*) () from /xxx/freecad/lib/libFreeCADGui.so
0000064 0x00007f039473b9c5 in SoQtGLWidgetP::eventFilter(QObject*, QEvent*) () from /usr/lib/libSoQt4.so.20
0000065 0x00007f0390a76cc6 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000066 0x00007f039152e6dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000067 0x00007f03915333eb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0001423 closedwmayer Crash on draw on face 

Activities

wmayer

2014-01-03 16:40

administrator   ~0004017

Very odd! I guess what's happening is that 'numCoords' is 0 but SoCoordinateElement::get3() wants the value for the index at 0. However, I have no clue why this is happening on your machine.

Related Changesets

FreeCAD: master 8e711fc3

2014-03-06 09:33:35

wmayer

Details Diff
+ fixes 0001423: Crash on draw on face Affected Issues
0001344, 0001423
mod - src/Mod/Sketcher/Gui/ViewProviderSketch.cpp Diff File

Issue History

Date Modified Username Field Change
2014-01-03 13:47 rymdhund New Issue
2014-01-03 16:40 wmayer Note Added: 0004017
2014-03-09 10:23 wmayer Changeset attached => FreeCAD Master master 8e711fc3
2014-03-09 10:23 wmayer Status new => closed
2014-03-09 10:23 wmayer Assigned To => wmayer
2014-03-09 10:23 wmayer Resolution open => fixed
2014-03-09 10:23 wmayer Fixed in Version => 0.14
2014-03-09 10:23 wmayer Relationship added duplicate of 0001423