View Issue Details

IDProjectCategoryView StatusLast Update
0001323FreeCADBugpublic2016-05-05 20:00
ReporterNormDAssigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWin XP ProOS VersionSP3
Product Version0.13 
Target VersionFixed in Version0.16 
Summary0001323: Imported .step parts disappear after save/reopen
DescriptionI am building a 3D model of a PCB board. I created the basic board then created models for each part that I wanted to place on the board. I then exported each part as a .step file, imported it into the board part and placed it. So far, so good. Everything looks great. I then found that when I saved the file (as a normal .FCStd file) and reopened it, some of the parts would disappear. Which parts disappeared seems random and changes on every save/reopen. By clicking on each pad in the list of pads on the left of the display I found that the disappeared parts are still there, but are invisible. I could see this because when I double-clicked the pad a transform tool would appear where the part was supposed to be. Nothing I did to toggle visibility or appearance made the part re-appear. All of the disappeared parts were correct and visible before the save/reopen.
Additional InformationFor the file provided, please see Pads 30, 34, 35, 37 and Pocket 002, 004, 005
TagsNo tags attached.

Relationships

related to 0001211 closedwmayer ... cannot be written to BRep file ... Error on saving a model 

Activities

NormD

2013-12-02 12:36

reporter  

New Board Combined.FCStd (Attachment missing)

NormD

2013-12-02 19:28

reporter   ~0003919

Last edited: 2013-12-02 19:29

View 2 revisions

I did a little more exploring. I found that a .FCStd file is a .zip file, so I unzipped it. The invisible parts all have .brp files with 0 bytes except one. Pad77 is PartShape65 which does contain data. When I checked Document.xml and GuiDocument.xml the parameters for Pad77 seemed similar to the other parameters.

I just realized that the file I unzipped may be different from the one I uploaded. I assume the problem is the same.

NormD

2013-12-09 17:16

reporter   ~0003929

I did some more experimenting. If I save the file multiple times, each time different imported parts will be missing. After some number of saves, I sometimes get a complete file with no missing parts.

NormD

2013-12-09 19:28

reporter   ~0003930

I tried this using V0.14-2370 and the problem still occurs

wmayer

2014-03-04 11:40

administrator   ~0004380

Are the any error messages in the report window?

wmayer

2016-05-05 20:00

administrator   ~0007048

Might be related to 0001211 which is fixed.

Issue History

Date Modified Username Field Change
2013-12-02 12:36 NormD New Issue
2013-12-02 12:36 NormD File Added: New Board Combined.FCStd
2013-12-02 19:28 NormD Note Added: 0003919
2013-12-02 19:29 NormD Note Edited: 0003919 View Revisions
2013-12-09 17:16 NormD Note Added: 0003929
2013-12-09 19:28 NormD Note Added: 0003930
2014-03-04 11:40 wmayer Note Added: 0004380
2014-03-04 11:40 wmayer Status new => feedback
2016-05-05 20:00 wmayer Relationship added related to 0001211
2016-05-05 20:00 wmayer Note Added: 0007048
2016-05-05 20:00 wmayer Status feedback => closed
2016-05-05 20:00 wmayer Resolution open => fixed
2016-05-05 20:00 wmayer Fixed in Version => 0.16