View Issue Details

IDProjectCategoryView StatusLast Update
0001260SketcherBugpublic2017-07-11 20:08
Reporterewatch Assigned ToKunda1  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.13 
Target VersionFixed in Version 
Summary0001260: Solver can't handle changing of dimension constraints in depending sketches
DescriptionI have seen this and similar behaviour a lot, usually when using symmetry constraints and arcs. Worst if together.

How to reproduce:

* Open Sigma Pava.FCStd (SS 01)
* Edit "Sketch 1"
* Change datum of vertical dimension constraint from 27 to 28 (SS 02)
* You can already see now that something went wrong, even though the change was extremely minor (SS 03)
* Close sketch
* Edit "Sketch 2"
* Wait (SS 04, solver time shown seems correct)
* Select some line from the sketch (SS 05; Note that this screen shot was actually taken *after* 06, as I used "undo" to get a screen shot of the line I had deleted. Note how after the "undo" action the sketch is now suddenly over-constrained even though there is no change from before)
* Delete the line
* Wait (~ 30 seconds on my system)
* Marvel at the modern art that FreeCAD has created (SS 06, solver time shown is completely wrong)



Additional InformationThose issues are likely to be related:
* 0000754 (Since arcs can very easily have two solutions: "a" and "360-a"
* 0000750 (The 6 seconds shown in last screen shot are actually 30)

OS: Windows 7
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Hash: a836759ebd91404954a778ff8885e152611576e1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1
TagsNo tags attached.
FreeCAD Information

Relationships

related to 0000754 assignedabdullah GCS Sketcher doesn't report that a fully constrained sketch may have multiple (finite) solutions 
related to 0000750 closedlogari81 Sketcher Endless loop in sketch solver 

Activities

yorik

2013-11-04 13:41

administrator  

Sigma+Pava.FCStd (38,730 bytes)

yorik

2013-11-04 13:41

administrator  

Issue+01.png (142,738 bytes)
Issue+01.png (142,738 bytes)

yorik

2013-11-04 13:42

administrator  

Issue+02.png (186,916 bytes)
Issue+02.png (186,916 bytes)

yorik

2013-11-04 13:42

administrator  

Issue+03.png (162,822 bytes)
Issue+03.png (162,822 bytes)

yorik

2013-11-04 13:42

administrator  

Issue+04.png (153,778 bytes)
Issue+04.png (153,778 bytes)

yorik

2013-11-04 13:42

administrator  

Issue+05.png (166,697 bytes)
Issue+05.png (166,697 bytes)

yorik

2013-11-04 13:43

administrator  

Issue+06.png (179,201 bytes)
Issue+06.png (179,201 bytes)

bejant

2014-05-04 03:10

reporter   ~0004623

Last edited: 2014-05-05 19:26

View 4 revisions

Note to ewatch:
I have had similar experiences with what is shown in Issue+06.png, but there are also several other issues going on here.

There is a certain amount of time Sketcher Solver uses to compute the solution to the Sketch, and there is also a very different time elapsed (not by Solver) to display the results in the 3D window. Sketcher Solver does not report the processing time elapsed in displaying the revised model.

Editing Sketch1 and changing the Vertical Distance Constraint from 27 to 28 breaks Sketch2 because of the known Link to External Geometry / numbering issue.

==============
EDIT 2014-05-05: Using newer FreeCAD builds I am unable to reproduce the problem any more. Build info is posted below.

bejant

2014-05-05 18:52

reporter  

20140504au.jpg (27,685 bytes)
20140504au.jpg (27,685 bytes)

bejant

2014-05-05 18:55

reporter  

20140505au.jpg (42,352 bytes)
20140505au.jpg (42,352 bytes)

bejant

2014-05-05 18:56

reporter  

20140505au_Mantis_1260_28mm.fcstd (44,100 bytes)

bejant

2014-05-05 19:22

reporter   ~0004629

Last edited: 2014-05-05 19:28

View 2 revisions

I've had time to look into this in more depth and with the recent FreeCAD daily build am unable to reproduce this problem. More detailed notes follow:

=================

"How to reproduce:
* Open Sigma Pava.FCStd (SS 01)
* Edit "Sketch 1"

Result: Works OK for me.

================
"* Change datum of vertical dimension constraint from 27 to 28 (SS 02)
* You can already see now that something went wrong,"

Result: the exclamation point in red symbol is displayed next to "Sketch2" in the tree view, indicating an error.

================
"* Close sketch
* Edit "Sketch 2"

Open Sketch2 to edit, then zoom in on the magenta Link to External Geometry line at the top. Doing this shows that the Link to External Geometry segment is not used as a reference buy any constraints, and instead a Sketcher line segment is used, as evidenced in image "Issue+04.png". This can also be seen in the attached image "20140504au".

Initially I thought this was a modeling error, but closing Sketch2 without changing anything in Sketch2, saving the .fcstd file, and reopening the model in FreeCAD again "fixes" the model. The red exclamation point symbol no longer appears, and the constraint can be changed from 27mm to 28mm, or 30mm as shown in the attached image 20140505a_Mantis_1260. The model updates correctly and without error. I saved my FreeCAD file at this point; it is attached as "20140505au_Mantis_1260_28mm.fcstd"

Confirmed yesterday 2014-05-04 using:
OS: Ubuntu 12.04.4 LTS
Platform: 32-bit
Version: 0.14.3512 (Git)
Branch: master
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0

Reconfirmed today 2014-05-05 using:
OS: Ubuntu 12.04.4 LTS
Platform: 32-bit
Version: 0.14.3538 (Git)
Branch: master
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.7.0

================

"* Select some line from the sketch ..."

Selected the same arc, deleted it, did an undo.
Result: Solver reports Fully constraind sketch.
No conflicts or over-constraints.
Done with the file OP uploaded and done with the file I uploaded today.

========================

"* Delete the line
... <SNIP> ...
* Marvel at the modern art that FreeCAD has created."

Result: unable to reproduce this beavior with the build I used yesterday or today.

==================

"solver time shown is completely wrong"

Note to ewatch: Solver only reports the time used to solve the model, not the time spent processing the file for graphics display, as previously mentioned.

yorik

2016-03-06 02:43

administrator   ~0006881

I can't reproduce this problem anymore. Is it still an issue?

bejant

2016-03-06 13:42

reporter   ~0006885

Opening Sigma+Pava.FCStd and first running the ForceRecompute macro shows there is an error in Sketch 2. Sketcher Solver reports that it is Over-constrained.

Next I opened Sketch 1 and changed the Vertical Distance Constraint from 27 to 28 mm, and when FreeCAD updated after I closed Sketch 1, Sketch 2 was OK.

I think the problem is in the model and not in FreeCAD itself.

All 3 of my auto check and refine preferences are off.

OS: Ubuntu 14.04.4 LTS
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.16.6551 (Git)
Build type: None
Branch: master
Hash: 74a43f23b3dcf9a95a3d691b9373bb0ecf8ea0f2
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-01-22 14:32

administrator   ~0007909

both @yorik and @bejant report that they can't reproduce.
tagged #pending and #tobeclosed

Kunda1

2017-01-31 13:06

administrator   ~0008122

Resolving as 'unable to reproduce' as per above ^

Issue History

Date Modified Username Field Change
2013-10-01 17:34 ewatch New Issue
2013-10-01 17:34 ewatch File Added: Sigma Pava.FCStd
2013-10-01 17:35 ewatch File Added: Issue 01.png
2013-10-01 17:35 ewatch File Added: Issue 02.png
2013-10-01 17:36 ewatch File Added: Issue 03.png
2013-10-01 17:36 ewatch File Added: Issue 04.png
2013-10-01 17:36 ewatch File Added: Issue 05.png
2013-10-01 17:36 ewatch File Added: Issue 06.png
2013-11-04 13:41 yorik File Deleted: Sigma Pava.FCStd
2013-11-04 13:41 yorik File Deleted: Issue 01.png
2013-11-04 13:41 yorik File Deleted: Issue 02.png
2013-11-04 13:41 yorik File Deleted: Issue 03.png
2013-11-04 13:41 yorik File Deleted: Issue 04.png
2013-11-04 13:41 yorik File Deleted: Issue 05.png
2013-11-04 13:41 yorik File Deleted: Issue 06.png
2013-11-04 13:41 yorik File Added: Sigma+Pava.FCStd
2013-11-04 13:41 yorik File Added: Issue+01.png
2013-11-04 13:42 yorik File Added: Issue+02.png
2013-11-04 13:42 yorik File Added: Issue+03.png
2013-11-04 13:42 yorik File Added: Issue+04.png
2013-11-04 13:42 yorik File Added: Issue+05.png
2013-11-04 13:43 yorik File Added: Issue+06.png
2014-05-04 03:10 bejant Note Added: 0004623
2014-05-04 14:56 bejant Note Edited: 0004623 View Revisions
2014-05-05 03:18 bejant Note Edited: 0004623 View Revisions
2014-05-05 18:52 bejant File Added: 20140504au.jpg
2014-05-05 18:55 bejant File Added: 20140505au.jpg
2014-05-05 18:56 bejant File Added: 20140505au_Mantis_1260_28mm.fcstd
2014-05-05 19:22 bejant Note Added: 0004629
2014-05-05 19:26 bejant Note Edited: 0004623 View Revisions
2014-05-05 19:28 bejant Note Edited: 0004629 View Revisions
2016-03-06 02:43 yorik Note Added: 0006881
2016-03-06 02:43 yorik Status new => feedback
2016-03-06 13:42 bejant Note Added: 0006885
2017-01-22 14:29 Kunda1 Relationship added related to 0000754
2017-01-22 14:30 Kunda1 Relationship added related to 0000750
2017-01-22 14:30 Kunda1 Tag Attached: #pending
2017-01-22 14:32 Kunda1 Note Added: 0007909
2017-01-22 14:32 Kunda1 Tag Attached: #tobeclosed
2017-01-22 14:33 Kunda1 Description Updated View Revisions
2017-01-31 13:06 Kunda1 Note Added: 0008122
2017-01-31 13:06 Kunda1 Status feedback => resolved
2017-01-31 13:06 Kunda1 Resolution open => unable to reproduce
2017-01-31 13:06 Kunda1 Assigned To => Kunda1
2017-02-03 12:42 yorik Status resolved => closed
2017-07-11 20:08 Kunda1 Tag Detached: #pending
2017-07-11 20:08 Kunda1 Tag Detached: #tobeclosed