View Issue Details

IDProjectCategoryView StatusLast Update
0001242FreeCADBugpublic2013-11-10 19:22
Reporterulrich1aAssigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001242: Draft Dimensions due not observe Dimension Precision on FreeCAD Windows
DescriptionIn the Windows-Version of FreeCAD the Draft-Dimensions are pretty useless, as the Dimension length is always truncated to an integer, regardless of the setting in the preferences.
An override could be a workaround, but overrides are not transferred to a drawing page. The last point is also valid for the linux-version.
Additional InformationTested with FreeCAD 0.13 stable and FreeCAD Version: 0.14.2497 (Git) on Windows 32 bit.
TagsNo tags attached.

Relationships

child of 0001241 closedyorik Draft FreeCAD Windows 32 bit crashes at adding Draft Dimension with Fontsize preset in preferences 

Activities

yorik

2013-09-13 15:14

administrator   ~0003571

Okay I'll fix the override not appearing on the drawing page
For the other problem, I need more info... Unfortunately I have no windows installation to test. Are all dimensions shown as integer values? It is strange, nobody ever reported that... Changing the "Dimension precision level" value in Draft preferences has no effect?

ulrich1a

2013-09-13 17:41

reporter   ~0003574

I did an additional test with FreeCAD 0.13 on Windows XP at home. There is always an integer shown as long as the Draft preferences are not saved. The draft dimension preferences show a default precision of 2 in the preferences. If I do not confirm this setting by ok, then I still get integers.
But changing and saving the precision level indeed gives me now dimension numbers with decimals.
I will test again next week on Windows 7.

yorik

2013-09-13 17:55

administrator   ~0003575

Yes that is normal... You must save/apply the preferences.
Then probably it is the default value that is wrong, I'll fix that.

bejant

2013-09-17 00:20

reporter   ~0003590

I'm unable to recreate ulrich1a's problem, even if I change Edit -> Preferences -> Draft (from the left side of the window) -> General Settings tab -> Dimensions Precision Level and do not hit the Apply button at all and instead hit the OK button, the dimension precision is saved.

Link to video showing what I did:
https://www.dropbox.com/s/1vp1a2y8cgsyb4j/20130916c%20Dimension%20Precision.avi

OS: Windows XP
Platform: 32-bit
Version: 0.14.2370 (Git)
Branch: master
Hash: a836759ebd91404954a778ff8885e152611576e1
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

ulrich1a

2013-09-17 12:35

reporter   ~0003592

I did a little bit of investigation. The problem is related to https://sourceforge.net/apps/mantisbt/free-cad/view.php?id=1241. I could not set the Dimension Precisions Level. Every time a visited the Draft Preferences and klicked OK, I could not add a Dimension without a crash of FreeCAD. This seems to be related to Windows 7. The same binaries worked well under Wine!
FreeCAD git 2512 under Windows 7 crashed at adding a Dimension, when the Draft Preferences where set with pushing the ok-button.

I could solve this for me under Windows 7. I installed the osifont, and copied it also to a path, I could enter in FreeCAD in the Draft Preferences. I than put "osifont" as the default in the Draft Preferences for the standard font and the path to the copied osifont at Default Shape Font File.
I dont know, what of the two things I made, solved the problem. This may be investigated by someone how is more familiar with windows 7.
Now it works like expected.

yorik

2013-11-10 19:22

administrator   ~0003880

The default font is now the internal coin font, which should prevent FreeCAD from crashing.

Issue History

Date Modified Username Field Change
2013-09-13 10:55 ulrich1a New Issue
2013-09-13 15:12 yorik Status new => assigned
2013-09-13 15:12 yorik Assigned To => yorik
2013-09-13 15:14 yorik Note Added: 0003571
2013-09-13 17:41 ulrich1a Note Added: 0003574
2013-09-13 17:55 yorik Note Added: 0003575
2013-09-17 00:20 bejant Note Added: 0003590
2013-09-17 12:35 ulrich1a Note Added: 0003592
2013-11-10 19:21 yorik Relationship added child of 0001241
2013-11-10 19:22 yorik Note Added: 0003880
2013-11-10 19:22 yorik Status assigned => closed
2013-11-10 19:22 yorik Resolution open => fixed
2013-11-10 19:22 yorik Fixed in Version => 0.14