View Issue Details

IDProjectCategoryView StatusLast Update
0001239FreeCADFeaturepublic2013-09-21 10:20
Reporternikospap Assigned Towmayer  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.14 
Summary0001239: Part --> Geometric Primitives --> Regular Prism
DescriptionAdd option for Regular Prisms in Part --> Geometric Primitives

Especially hexagonal prisms.

Metals are sold in hexagonal bars.
Half the screws have hexagonal heads.
Most screw bolts are hexagonal.
Bees make hexagonal cells.
Frames, from fences to helicopter rotors, are made of hexagonal parts.
Marble columns can be seen as prisms.
There are hexagonal rifle barrels.
Additional InformationCurrently, making a prism in Freecad, requires knowledge of basic trigonometry, 5 to 20 minutes time for each prism, and a lot of undo steps, because some methods will work, while others won't.
TagsNo tags attached.
FreeCAD Information

Activities

2013-09-11 06:33

 

prism_001.jpg (Attachment missing)

shoogen

2013-09-13 09:27

developer   ~0003567

Last edited: 2013-09-13 09:27

You can make a (regular) Draft/Polygon and extrude it (Part/Extrude).
It takes less than one minute.

nikospap

2013-09-13 10:17

reporter   ~0003568

It seems you can...

I was using Sketcher.

bejant

2013-09-16 23:40

reporter   ~0003588

Hi Shoogen, IMHO the Sketcher Workbench would be easier and faster for the user if it had "Draw Polygon" and "Draw Ellipse" functions as is currently available in the Draft Workbench.

wmayer

2013-09-21 10:20

administrator   ~0003600

git show 24a3c2c

Issue History

Date Modified Username Field Change
2013-09-11 06:33 nikospap New Issue
2013-09-11 06:33 nikospap File Added: prism_001.jpg
2013-09-13 09:27 shoogen Note Added: 0003567
2013-09-13 09:27 shoogen Note Edited: 0003567
2013-09-13 10:17 nikospap Note Added: 0003568
2013-09-16 23:40 bejant Note Added: 0003588
2013-09-21 10:18 wmayer Status new => assigned
2013-09-21 10:18 wmayer Assigned To => wmayer
2013-09-21 10:20 wmayer Note Added: 0003600
2013-09-21 10:20 wmayer Status assigned => closed
2013-09-21 10:20 wmayer Resolution open => fixed
2013-09-21 10:20 wmayer Fixed in Version => 0.14