View Issue Details

IDProjectCategoryView StatusLast Update
0001237FreeCADBugpublic2015-12-15 13:15
ReporternikospapAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.16 
Summary0001237: the project file is not saved when the " /tmp " directory is full, but the user is not aware of it
DescriptionHow to reproduce:

* Open freecad, create something in it.

* Make sure your partition, where /tmp folder is, is full (no disk space left)

* Save your freecad project in another disk (for example, /home/username)

Now what will happen:
If you pay attention, and can read really really fast, you might be able to see a message appearing, for a very short period of time, in the bottom left corner of freecad. This message, in red letters, will say something like "Couldn't write in folder /tmp/SOMETHING" .

But...
The asterisk ( * ) in the project's tab will be gone,
and a file will be saved in /home/username, ( 7kb instead of 30+kb )

The problem:
If the user misses the red letter message, he will be under the impression that the project was saved properly.
But when he opens that .fcstd file he will realise that there is nothing in it,
and he was just wasting his time.
Additional InformationI am using Freecad version 0.12.5284 under Mageia Linux.

I had similar problems with the newer unstable versions, running in Wine.
TagsNo tags attached.

Activities

wmayer

2013-09-14 10:12

administrator   ~0003578

The messages are also written to the report window which you can activate under the View menu. Then please try again and post the exact error messages. This way we know where in the source code the writing failed.

Unfortunately, when the writing somewhere fails it's not clear what is the reason. So, there can also be other reasons than a full HD. Maybe we can use the C header errno.h to see what happened.

But it's true that at the end the user needs a clear feedback that something went wrong, like a pop-up dialog.

nikospap

2013-09-15 00:52

reporter   ~0003581

This is the error message, in the Report view window
----------------------

Pick center point:
Pick radius:
Shape of 'Box' cannot be written to BRep file '/tmp//fileUOdtEi'
Shape of 'Polygon' cannot be written to BRep file '/tmp//fileUOdtEi'
Shape of 'Sketch' cannot be written to BRep file '/tmp//fileUOdtEi'

----------------------

In this specific case, it must be that the partition is full, because the problem only shows up when the partition is full.

(Note:The partition is not literally full. There is still space left. But it is kept for root use. So that the system won't freeze, loose data, or anything like that, because a user tried to fill the /tmp directory.)

Related Changesets

FreeCAD: master 7d09444d

2015-09-19 18:59:22

wmayer

Details Diff
+ fixes 0001237: the project file is not saved when the /tmp directory is full, but the user is not aware of it Affected Issues
0001237
mod - src/App/Document.cpp Diff File
mod - src/App/DocumentPyImp.cpp Diff File
mod - src/Base/Writer.cpp Diff File
mod - src/Base/Writer.h Diff File
mod - src/Gui/Document.cpp Diff File
mod - src/Mod/Part/App/PropertyTopoShape.cpp Diff File

Issue History

Date Modified Username Field Change
2013-09-11 04:47 nikospap New Issue
2013-09-14 10:12 wmayer Note Added: 0003578
2013-09-15 00:52 nikospap Note Added: 0003581
2015-09-19 16:59 wmayer Changeset attached => FreeCAD Master master 7d09444d
2015-09-19 16:59 wmayer Assigned To => wmayer
2015-09-19 16:59 wmayer Status new => closed
2015-09-19 16:59 wmayer Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16