View Issue Details

IDProjectCategoryView StatusLast Update
0001226SketcherBugpublic2016-03-06 16:48
ReportersirowAssigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.16 
Summary0001226: Font rendering in sketcher workbench on Windows 7
DescriptionOn Windows 7 (64 Bit, SP1), contraints-fonts are rather difficult to read. There seems to be a problem with rendering those fonts on windows (See attached image).

This happens both with FreeCad 0.13 and FreeCad 0.14 (Rev. 2370).

I also tried FreeCad in Kubuntu (dual-boot) to test wether it might be a (hardware) problem on my side. But on linux everthing looks fine.

My guess is there is either an issue with the font that is beeing using on Windows or a problem with the font rendering on windows... :(
Additional InformationExample of correct font size and "resolution":
http://jaanus.tech-thing.org/wp-content/uploads/2013/01/FreeCAD_Sketker.png
TagsNo tags attached.

Activities

2013-08-20 07:22

 

Font.jpg (321,078 bytes)
Font.jpg (321,078 bytes)

bejant

2013-08-21 21:35

reporter   ~0003502

Similar to second note in this Mantis ticket:
http://sourceforge.net/apps/mantisbt/free-cad/view.php?id=1203

yorik

2016-03-06 02:39

administrator   ~0006880

The drawing of fonts in the sketcher has changed a lot since 0.14... Is this still an issue?

bejant

2016-03-06 11:52

reporter   ~0006883

@yorik, the user can change the size of constraint text. Abdullah added this a while ago, so this ticket can be closed. However, the user still can't change the size of Constraint points or line widths in Sketcher, so ticket 1203 is still open (and IMO the relationship to ticket 1203 should be removed).

yorik

2016-03-06 16:47

administrator   ~0006887

Okay, so I'll close this ticket, and indeed the relationship doesn't need to exist, I'll remove it too.

Issue History

Date Modified Username Field Change
2013-08-20 07:22 sirow New Issue
2013-08-20 07:22 sirow File Added: Font.jpg
2013-08-21 21:35 bejant Note Added: 0003502
2016-03-06 02:39 yorik Note Added: 0006880
2016-03-06 02:39 yorik Relationship added related to 0001203
2016-03-06 02:39 yorik Status new => feedback
2016-03-06 11:52 bejant Note Added: 0006883
2016-03-06 16:47 yorik Note Added: 0006887
2016-03-06 16:47 yorik Relationship deleted related to 0001203
2016-03-06 16:48 yorik Status feedback => closed
2016-03-06 16:48 yorik Resolution open => fixed
2016-03-06 16:48 yorik Fixed in Version => 0.16