View Issue Details

IDProjectCategoryView StatusLast Update
0001219FreeCADBugpublic2013-12-20 21:23
ReporteroghamtheboldAssigned Toyorik 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindows 7OS Version64-bit
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001219: Zero width rectangle (i.e. 2 vertical points) odd behaviour + crash
DescriptionSee steps to reproduce.
Steps To Reproduce(a) Create zero width rectangle (i.e. using 2 vertical points).

Note: This creates an inverted rectangle with width set to height.

(b) Undo.

(c) Repeat step (a)

Crash always.

Additional InformationMaybe a 0 width rectangle is not allowed - but is the default to create a square (using the height instead of the specified width)?

Obviously using 2 vertical points is something only the uninitiated would try - while 'learning' - which I am / did do.
TagsNo tags attached.

Activities

yorik

2013-08-16 18:37

administrator   ~0003483

Hm I can't reproduce this, for me trying to create a zero-width rectangle gives the default square, but doesn't crash... What is your version of FreeCAD? (paste here the contents of the help->About freecad dialog)

oghamthebold

2013-08-17 15:20

reporter   ~0003486

Thanks - in Mantis (i.e. the bug tracker) - click 'View Advanced' to see; FreeCad build version and steps to reproduce

yorik

2013-08-17 15:27

administrator   ~0003487

Hah thanks.. nobody fills these fields, I never think to look at them
Anyway I still cannot reproduce this crash.. I might have made some changes since version 0.13 that fixed the problem, but I can't remember. Can I ask you to try a 0.14 version from https://sourceforge.net/projects/free-cad/files/FreeCAD%20Windows/ ?

yorik

2013-12-20 21:23

administrator   ~0003959

Closing this because there is no more feedback...

Issue History

Date Modified Username Field Change
2013-08-16 11:08 oghamthebold New Issue
2013-08-16 18:37 yorik Note Added: 0003483
2013-08-16 18:37 yorik Status new => assigned
2013-08-16 18:37 yorik Assigned To => yorik
2013-08-16 18:37 yorik Status assigned => feedback
2013-08-17 15:20 oghamthebold Note Added: 0003486
2013-08-17 15:27 yorik Note Added: 0003487
2013-12-20 21:23 yorik Note Added: 0003959
2013-12-20 21:23 yorik Status feedback => closed
2013-12-20 21:23 yorik Resolution open => fixed
2013-12-20 21:23 yorik Fixed in Version => 0.14