View Issue Details

IDProjectCategoryView StatusLast Update
0001210FreeCADBugpublic2014-02-26 15:03
ReportervdhproductsAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0001210: DLL load failed
DescriptionWhem I installed FreeCAD_0.14.2370_x86_RC_setup.msi I can't open the workbench "COMPLETE" or any other workbench.

The error message is "DLL load failed".

FreeCAD_0.13.1828_x86_setup.msi works well on same system.
Additional InformationUsing FreeCAD_0.14.2370_x86_RC_setup.msi setup.
Running on Windows XP SP3
TagsNo tags attached.

Relationships

has duplicate 0001446 closedwmayer STEP export fails under Windows 

Activities

wmayer

2013-08-12 10:47

administrator   ~0003450

Start v0.13 and check your macro path. Which directory does it point to?

vdhproducts

2013-08-12 11:00

reporter   ~0003451

C:/Program Files/FreeCAD0.13/Macro

wmayer

2013-08-13 11:16

administrator   ~0003456

And you cannot even load the Mesh workbench?

vdhproducts

2013-08-13 11:45

reporter   ~0003457

Yes, I can load the arch, draft,image, mesh design, points and ship.
When I try to make a line in the draft Workbench. It gives the following error:

Running the Python command 'Draft Line' failed.

The rest of the workbenches give the error "DLL load failed" when I try to open them.

2013-08-13 12:33

 

Dynamic module not intialized properly.PNG (Attachment missing)

vdhproducts

2013-08-13 12:35

reporter   ~0003458

In version FreeCAD_0.14.2192_x86_setup.msi there is another error message.

Dynamic module not initialized properly.

On another windows 7 system freecad 0.14 is working just fine. On my windows XP SP3 system there seems to be a problem.

wmayer

2013-08-13 16:21

administrator   ~0003460

Very likely a certain DLL is missing to load the OpenCascade DLLs. Therefore you should use the tool dependency walker (www.dependencywalker.com).

In the installation directory copy e.g. Part.pyd into the bin directory (where you see all the TK*.dll files). Drag and drop (the copied) Part.pyd to the dependency walker.

On the left side check the dependencies for a missing file.

vdhproducts

2013-08-14 04:53

reporter   ~0003462

According to the dependencywalker the following dll's are missing.(see attachment)

WER.dll (missing on system)
IESHIMS.dll (missing on system)
MSVCR90.dll (this one is present)

In which directories is freecad searching for these files, so I can install the dll files there?

2013-08-14 04:53

 

Missing DLLs.PNG (Attachment missing)

vdhproducts

2013-08-14 06:55

reporter   ~0003464

After I installed the wer.dll, IESHIMS.dll and MSVR90.dll dependencywalker want more(see missing dll2.png and missing dll3.png)

There is no end. What can I do?

Or is it just not possible to run freecad 0.14 on a windows XP SP3 system?

2013-08-14 06:56

 

Missing dll 2.PNG (Attachment missing)

2013-08-14 07:02

 

Missingdll3.PNG (Attachment missing)

wmayer

2013-08-14 07:09

administrator   ~0003465

Unfortunately, the dependency walker gives a couple of false positive like the WER.dll or IESHIMS.dll which can be ignored. Can you maybe upload a screen shot of the tree view?

Another point that should be taken into consideration:
For version 0.14 a newer OpenCascade version is used compared to 0.13. These two OpenCascade versions are binary incompatible to each other and if for any reason a DLL of one version finds a DLL of the other version it depends on in the system path it won't load.

From time to time I have seen Windows systems where application libraries have been copied to C:\Windows\system or C:\Windows\system32. In such a case any application that needs a different version won't work any more because it always searches in these two paths before looking into the PATH environment variable (which can be customized by an application). This is how Windows works and there is no way to change the search order.

So, the only fix is to remove application libraries from C:\Windows\system or C:\Windows\system32 because as the name says they are reserved for system libraries only. In your case check if you can find any TK*.dll in one of the above directories and remove them.

2013-08-14 07:27

 

Tree ieshimsdll and werdll.PNG (Attachment missing)

2013-08-14 07:27

 

Tree MSVCR90dll.PNG (Attachment missing)

vdhproducts

2013-08-14 07:30

reporter   ~0003466

I removed all the dll's that I'd installed this morning.
In the attechment(see png's) you can see the tree view of the three missing dll's.

There are no TK*.dll files in the system/system32 directories.

Any suggestions?

wmayer

2013-09-03 13:11

administrator   ~0003543

Another thing you can try out:
In the sub-directories of Mod you will find files with the extension .pyd. Move all of them (unless that of PartDesign) to the bin directory.

cctalk

2013-09-04 17:38

reporter   ~0003551

Last edited: 2013-09-04 17:39

"On another windows 7 system freecad 0.14 is working just fine."
 I have the same message om my Windows 7 x64 when I'm trying to open any step file.
The program starts and can open .FCStd files, but can not export them into .step file neither open step file. The program is FreeCAD_0.14.2370_x86_RC_setup.msi

vdhproducts

2013-09-05 05:07

reporter   ~0003552

After moving all the .pyd files (except for partdesign.pyd), Freecad 0.14 started. Unfortunately I can't open/import any step files. The following error(report view) appears when importing a step file:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
<type 'exceptions.ImportError'>: DLL load failed: Kan opgegeven module niet vinden.
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>

vdhproducts

2013-09-05 05:24

reporter   ~0003553

Now I installed the previous version FreeCAD_0.14.2192_x86_setup.msi.

In this version the open/import is working when I moved the pyd files to the bin directory. Something is different between the 2192 and the 2370_RC build.

wmayer

2013-09-21 17:29

administrator   ~0003614

I installed WinXP + SP3 + vc_redist (9.0.21022.8) as virtual system. For me FreeCAD_0.13.1828_x86_setup.msi and FreeCAD_0.14.2370_x86_RC_setup.msi are both working on this system. For 0.14.2370 I cannot load the FEM module due to a missing DLL but everything else works.

So, IMO it's not the installer but something on your system is wrong.

vdhproducts

2013-09-23 05:07

reporter   ~0003625

In my new system with windows 8(HP 3.2GHz cpu, 8GB memory, 64 bits), I installed FreeCAD_0.14.2192_x86_setup. This works just fine. Even importing and opening STEP files.

FreeCAD_0.14.2370_x86_RC_setup.msi is still giving the dll load error, when importing or opening STEP models. Same as note above from cctalk (003551)

This is a new clean system. Even when moving the .pyd (except partdesign.pyd) files to the bin directory there is no difference.

wmayer

2013-09-23 05:41

administrator   ~0003627

Do you have installed vc_redist (version 9.0.21022.8 or later)?

wmayer

2013-09-23 06:00

administrator   ~0003628

Ah, wait! In your initial post you said "I can't open the workbench "COMPLETE" or any other workbench." Is this still true that you cannot load them?

I have overlooked what cctalk was writing: "The program starts and can open .FCStd files, but can not export them into .step file neither open step file."
Yes, I can confirm this too now. The file Import.pyd is missing!

vdhproducts

2013-09-23 06:57

reporter   ~0003630

No, that's no problem anymore with the new system.

Is it possible to sent me the import.pyd? Or a new build (maybe including the text string to shape feature(not compiled in this version))?

2013-09-23 07:43

 

Import.pyd (Attachment missing)

wmayer

2013-09-23 07:45

administrator   ~0003632

Copy the file to Mod\Import.

vdhproducts

2013-09-23 07:53

reporter   ~0003633

It is working!

Thank you for helping me out.

wmayer

2013-09-24 10:59

administrator   ~0003645

It's working now.

Issue History

Date Modified Username Field Change
2013-08-12 06:53 vdhproducts New Issue
2013-08-12 10:47 wmayer Note Added: 0003450
2013-08-12 11:00 vdhproducts Note Added: 0003451
2013-08-13 11:16 wmayer Note Added: 0003456
2013-08-13 11:45 vdhproducts Note Added: 0003457
2013-08-13 12:33 vdhproducts File Added: Dynamic module not intialized properly.PNG
2013-08-13 12:35 vdhproducts Note Added: 0003458
2013-08-13 16:21 wmayer Note Added: 0003460
2013-08-14 04:53 vdhproducts Note Added: 0003462
2013-08-14 04:53 vdhproducts File Added: Missing DLLs.PNG
2013-08-14 06:55 vdhproducts Note Added: 0003464
2013-08-14 06:56 vdhproducts File Added: Missing dll 2.PNG
2013-08-14 07:02 vdhproducts File Added: Missingdll3.PNG
2013-08-14 07:09 wmayer Note Added: 0003465
2013-08-14 07:27 vdhproducts File Added: Tree ieshimsdll and werdll.PNG
2013-08-14 07:27 vdhproducts File Added: Tree MSVCR90dll.PNG
2013-08-14 07:30 vdhproducts Note Added: 0003466
2013-09-03 13:11 wmayer Note Added: 0003543
2013-09-04 17:38 cctalk Note Added: 0003551
2013-09-04 17:39 cctalk Note Edited: 0003551
2013-09-05 05:07 vdhproducts Note Added: 0003552
2013-09-05 05:24 vdhproducts Note Added: 0003553
2013-09-21 17:29 wmayer Note Added: 0003614
2013-09-23 05:07 vdhproducts Note Added: 0003625
2013-09-23 05:41 wmayer Note Added: 0003627
2013-09-23 06:00 wmayer Note Added: 0003628
2013-09-23 06:57 vdhproducts Note Added: 0003630
2013-09-23 07:43 wmayer File Added: Import.pyd
2013-09-23 07:45 wmayer Note Added: 0003632
2013-09-23 07:53 vdhproducts Note Added: 0003633
2013-09-24 10:59 wmayer Note Added: 0003645
2013-09-24 10:59 wmayer Status new => closed
2013-09-24 10:59 wmayer Resolution open => fixed
2013-09-24 10:59 wmayer Fixed in Version => 0.14
2014-02-26 15:03 wmayer Relationship added has duplicate 0001446