View Issue Details

IDProjectCategoryView StatusLast Update
0001206FreeCADFeaturepublic2013-09-21 11:19
Reporteroldestfox Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version0.13 
Target VersionFixed in Version 
Summary0001206: Sketcher select tool (hand with pointing finger)
DescriptionMake the select bi-directional. i.e. If moved from right to left it will select all objects "fully in" the box. If moved from left to right, it will select all objects "cut" by the box. (or vice-versa) The above would apply in the vertical direction either up or down.
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0000462 closed Sketcher Sketcher: allow box selection 

Activities

bejant

2013-08-17 17:10

reporter   ~0003488

Last edited: 2013-08-19 00:19

In AutoCAD and IntelliCAD products this is called window selection. My humble suggestion is that when selecting objects via a selection window by clicking left-to-right, the edges of the selection window appear as solid lines, and only objects wholly inside the selected window are chosen. When objects are selected via a selection window by clicking right-to-left, the edges of the selection window appear as dotted lines, and objects wholly inside the selection window AND objects that cross the selection window are selected.

EDIT================
Or perhaps make the window behavior changeable by the user
END EDIT======================

Just my two cents worth.

This method of selecting objects is very handy for moving and stretching objects.

bejant

2013-09-15 10:34

reporter   ~0003583

This is the same as ticket 0000462:
http://sourceforge.net/apps/mantisbt/free-cad/view.php?id=462

wmayer

2013-09-21 11:19

administrator   ~0003603

Close it because it's a duplicate

Issue History

Date Modified Username Field Change
2013-08-09 14:17 oldestfox New Issue
2013-08-17 17:10 bejant Note Added: 0003488
2013-08-19 00:19 bejant Note Edited: 0003488
2013-09-15 10:34 bejant Note Added: 0003583
2013-09-21 11:18 wmayer Relationship added duplicate of 0000462
2013-09-21 11:19 wmayer Note Added: 0003603
2013-09-21 11:19 wmayer Status new => closed
2013-09-21 11:19 wmayer Resolution open => duplicate