View Issue Details

IDProjectCategoryView StatusLast Update
0001195DraftBugpublic2013-08-09 23:02
ReporternahshonAssigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001195: Open DXF - exception when opening file created with Inkscape
DescriptionFile saved from Inkscape using the "Better DXF Output" filter.
File can be open with other programs: pycam, f-engrave, heekscad.

Additional InformationException message:
opening /home/itai/Hello.dxf...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/itai/FreeCAD-src/build/Mod/Draft/importDXF.py", line 1185, in open
    processdxf(doc,filename)
  File "/home/itai/FreeCAD-src/build/Mod/Draft/importDXF.py", line 787, in processdxf
    drawing = dxfReader.readDXF(filename)
  File "/home/itai/.FreeCAD/dxfReader.py", line 375, in readDXF
    obj.data = objectify(obj.data)
  File "/home/itai/.FreeCAD/dxfImportObjects.py", line 1305, in objectify
    objects.append(type_map[item.type](item))
  File "/home/itai/.FreeCAD/dxfImportObjects.py", line 904, in __init__
    self.flags = obj.get_type(70)[0]
<type 'exceptions.IndexError'>: list index out of range

TagsNo tags attached.

Activities

2013-08-05 19:22

 

Hello.dxf (53,823 bytes)

yorik

2013-08-05 22:19

administrator   ~0003439

Interesting, there seems to be some entity not supported by the dxfparser. I'll have a look at that...

yorik

2013-08-09 23:02

administrator   ~0003445

Ok this is fixed now. You need to delete the file ~/.FreeCAD/dxfImportObjects.py so it will be downloaded again on next run.

Issue History

Date Modified Username Field Change
2013-08-05 19:22 nahshon New Issue
2013-08-05 19:22 nahshon File Added: Hello.dxf
2013-08-05 22:19 yorik Note Added: 0003439
2013-08-05 22:19 yorik Status new => assigned
2013-08-05 22:19 yorik Assigned To => yorik
2013-08-09 23:02 yorik Note Added: 0003445
2013-08-09 23:02 yorik Status assigned => closed
2013-08-09 23:02 yorik Resolution open => fixed
2013-08-09 23:02 yorik Fixed in Version => 0.14
2013-08-09 23:02 yorik Project Sketcher => Draft