View Issue Details

IDProjectCategoryView StatusLast Update
0001185FreeCADBugpublic2013-12-20 20:44
Reporterreprappermc Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0001185: Planer image changes to number graphic when a part design constraint is made after the planar image
Descriptionv0.14, 2295 from the Ubuntu daily builds, build date 2013/07/07

I've been able to consistently reproduce this:

Using the Image workbench, Create a planer image in 3D space function. Pick the image and complete. All if well.

Switch to the Part Design workbench and create a sketch. Add a distance constraint to a segment in the sketch. This will change the planer image to an image of the constraint graphic.
TagsNo tags attached.
FreeCAD Information

Relationships

duplicate of 0000971 closedmrlukeparry FreeCAD Tracing over a background image in Sketcher: image is overwritten by first dimensional constraint text 
related to 0001164 closedyorik Draft Hatching 

Activities

2013-07-16 22:07

 

Screenshot from 2013-07-16 18:07:06.png (Attachment missing)

yorik

2013-08-10 13:45

administrator   ~0003448

Interesting, I've had very similar issues with trying to setup hatch patterns in the draft module... You create one hatch pattern, all works fine. You create a second one, the 2 images get somehow "mixed" together.

Internally I think the constraint text is also a texture image, so the problem look pretty much the same. Probably something to do with the way coin3d stores textures...

normandc

2013-08-16 00:06

manager   ~0003473

This bug is a duplicate of 0000971.

wmayer

2013-10-13 14:45

administrator   ~0003744

The problem was that the generation of a texture id, its binding and the release was commented out. Having several datum labels was working so it was unclear if the code was needed. Activating the code solved this issue:

glGenTextures(1, &myTexture);
glBindTexture(GL_TEXTURE_2D, myTexture);
...
glDeleteTextures(1, &myTexture);

wmayer

2013-10-13 14:45

administrator   ~0003745

git show 629e764

yorik

2013-10-13 17:26

administrator   ~0003747

Excellent find! That must be the same problem that affects the hatches textures in draft...

Issue History

Date Modified Username Field Change
2013-07-16 22:07 reprappermc New Issue
2013-07-16 22:07 reprappermc File Added: Screenshot from 2013-07-16 18:07:06.png
2013-07-17 10:57 wmayer Status new => confirmed
2013-08-10 13:45 yorik Note Added: 0003448
2013-08-16 00:06 normandc Note Added: 0003473
2013-08-16 00:07 normandc Relationship added duplicate of 0000971
2013-10-13 14:38 wmayer Status confirmed => assigned
2013-10-13 14:38 wmayer Assigned To => wmayer
2013-10-13 14:45 wmayer Note Added: 0003744
2013-10-13 14:45 wmayer Note Added: 0003745
2013-10-13 14:45 wmayer Status assigned => closed
2013-10-13 14:45 wmayer Resolution open => fixed
2013-10-13 14:45 wmayer Fixed in Version => 0.14
2013-10-13 17:26 yorik Note Added: 0003747
2013-12-20 20:44 yorik Relationship added related to 0001164