View Issue Details

IDProjectCategoryView StatusLast Update
0001172FreeCADBugpublic2014-03-10 23:26
Reporterrocketship Assigned Towmayer  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001172: Installation should set Python path
DescriptionInstaller should either set correct Python path or place FreeCAD libraries within the existing Python path. When using FreeCAD libraries in Python outside of FreeCAD, they should automatically be found with "import FreeCAD".

One of the sample scripts suggests manually setting the path to the FreeCAD libs at the beginning of the script, but this breaks cross-platform because the path is different.

This should be invisible to the end user. Thanks!
TagsNo tags attached.
FreeCAD Information

Activities

There are no notes attached to this issue.

Related Changesets

FreeCAD: master 7176c0d9

2014-03-10 23:09:36

wmayer

Details Diff
+ minor fixes on x86 installer, new x64 installer Affected Issues
0001172
mod - src/WindowsInstaller/FreeCAD_WindowsInstaller.nsi Diff File
add - src/WindowsInstaller/FreeCAD_x64_WindowsInstaller.nsi Diff File

Issue History

Date Modified Username Field Change
2013-07-10 12:07 rocketship New Issue
2014-03-10 23:26 wmayer Changeset attached => FreeCAD Master master 7176c0d9
2014-03-10 23:26 wmayer Status new => closed
2014-03-10 23:26 wmayer Assigned To => wmayer
2014-03-10 23:26 wmayer Resolution open => fixed
2014-03-10 23:26 wmayer Fixed in Version => 0.14