View Issue Details

IDProjectCategoryView StatusLast Update
0001158DraftBugpublic2013-12-20 21:24
ReporterfkluweAssigned Toyorik 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001158: Import of 3D-dxf files failes
DescriptionImporting of dxf-files containing polygons in 3D freezes/crashes freecad. Import of the same files works just fine in heekscad which is supposed to be built on the same CAD-kernel.
An example file is attached to this report.
TagsNo tags attached.

Activities

2013-06-27 05:41

 

NupasNapa_Forebody_final.dxf (1,138,044 bytes)

wmayer

2013-06-27 08:33

administrator   ~0003266

What is your FreeCAD version and OS? Under Windows with the latest development version and the 0.13.1828 I have no crash.

wmayer

2013-06-27 08:46

administrator   ~0003268

I tested the DXF file with the latest HeeksCAD version. There it needs 13 sec to load the file while in FreeCAD we need only 4 sec.

There is a DXF importer for OpenCascade but this is not part of the open-source version. In FreeCAD we use a Python library and HeeksCAD must use a C++ library but I don't know if Dan Heeks has implemented or if it's a 3rd party library. I didn't find the source code in his SVN tree.

yorik

2013-06-27 10:44

administrator   ~0003270

For me it also imports without any crash. And as far as I can tell the import is complete, no part is missing...

About the heeksCAD dxf importer, yes, I believe it was made by Dan Heeks from scratch. It was one of the best candidates I had to make a C++ importer for FreeCAD, because the code is very simple ( https://github.com/Heeks/heekscad/blob/master/src/HDxf.cpp ) so it's easier to maintain and most other dxf libs are old and not maintained anymore.

Anyway, fkluwe, can you check if any error message appears on the output or python windows?

fkluwe

2013-06-27 11:14

reporter   ~0003271

I tried to open the file on the following system:

OS: Windows XP
Platform: 32-bit
Version: 0.14.2123 (Git)
Branch: master
Hash: ea943e0d7c01325f3adb459bdbad881f80f46217
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.5.1

FreeCad is thinking about the file for several minutes and then quits without any further comments. Maybe a memory issue? (3.4GB RAM)

fkluwe

2013-07-08 06:33

reporter   ~0003353

As freecad is quiting without any error messages it is difficult for me to provide any further information. Are there any log-files written by freecad which migh tbe helpful?

2013-07-08 06:43

 

fkluwe

2013-07-08 06:44

reporter   ~0003354

I've made a screenshot just before FreeCad silently quits, showing the excessive usage of memory by the program (attached file)

yorik

2013-07-08 11:27

administrator   ~0003355

Can you try opening another dxf file? Just to make sure the importer works at all...

Can you also start FreeCAD with logging enabled? For this, you must edit the desktop shortcut of FreeCAD, and change the executable name from "FreeCAD" to "FreeCAD -l". Then, run FreeCAD, and make it crash by opening the dxf file. After that you will have a log file (FreeCAD.log) in your FreeCAD user folder (I think C:/Docs and settings/your_user/Documents/FreeCAD but I'm not sure, you might have to search for a FreeCAD folder). Then upload the log file here, it might contain clues.

yorik

2013-12-20 21:24

administrator   ~0003960

Closing this because there is no more feedback

Issue History

Date Modified Username Field Change
2013-06-27 05:41 fkluwe New Issue
2013-06-27 05:41 fkluwe File Added: NupasNapa_Forebody_final.dxf
2013-06-27 08:33 wmayer Note Added: 0003266
2013-06-27 08:33 wmayer Assigned To => yorik
2013-06-27 08:33 wmayer Status new => feedback
2013-06-27 08:46 wmayer Note Added: 0003268
2013-06-27 10:44 yorik Note Added: 0003270
2013-06-27 11:14 fkluwe Note Added: 0003271
2013-07-05 22:11 yorik Project FreeCAD => Draft
2013-07-08 06:33 fkluwe Note Added: 0003353
2013-07-08 06:43 fkluwe File Added: Memory-Utilization-FreeCad.png
2013-07-08 06:44 fkluwe Note Added: 0003354
2013-07-08 11:27 yorik Note Added: 0003355
2013-12-20 21:24 yorik Note Added: 0003960
2013-12-20 21:24 yorik Status feedback => closed
2013-12-20 21:24 yorik Resolution open => fixed
2013-12-20 21:24 yorik Fixed in Version => 0.14