View Issue Details

IDProjectCategoryView StatusLast Update
0001157FreeCADBugpublic2013-06-27 14:16
Reporterfester2251Assigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001157: Export to BREP does not work in Ubuntu
DescriptionI am running FreeCAD 0.13 rev 1830 (git) under Ubuntu 12.04.2 LTS.

There is a persistant problem involving OpenCASCADE, and it appears the path to solving it requires exporting my drawing to BREP.

My Ubuntu version of FreeCAD does not export to BREP. FreeCAD goes through all the motions, but creates no new files with the extension BREP.
Additional InformationAnother user has told me the Export to BREP function works on his Windows system.
TagsNo tags attached.

Activities

fester2251

2013-06-22 19:00

reporter   ~0003237

The corrected current version of FreeCAD being used is:0.13.1830-1ppa1~precise2.

Jriegel

2013-06-26 09:11

administrator   ~0003240

Do you have a non ASCII character in your file path?
OCC can not handle such paths....

normandc

2013-06-26 23:29

manager   ~0003262

Two things to consider:

1) Did you click on the object to export first? If no shape is selected, Import will not work. In prior versions there was no error message, there is one now but I don't remember if it was introduced in v0.13.1830.

2) on Gnome and Unity, due to a bug you need to type the extension manually. Did you append .brep to your file?

I'm not using the stable version anymore but I remember exporting breps without a hitch on Ubuntu 12.04 with FreeCAD v0.13.1830.

I just checked and it is working on FreeCAD v0.14.2203 (package freecad-0.13+git20130625...) from the freecad-daily PPA repository.

normandc

2013-06-26 23:37

manager   ~0003263

I just downgraded my FreeCAD version to v0.13.1830 on Ubuntu 12.04.2 LTS 64-Bit.

I confirm BREP export is working as intended, by either method:

1) From File --> Export menu
2) From Part --> CAD Export menu

As I said, the ".brep" extension needs to be typed in manually.

fester2251

2013-06-26 23:56

reporter   ~0003264

Do you have a non ASCII character in your file path?

No.


1) Did you click on the object to export first?

Yes.

2.) you need to type the extension manually.

No. I did not do that. Having added .BREP as an extension, it now works.

Thanks Everybody!!

wmayer

2013-06-27 14:15

administrator   ~0003273

I have replaced the system wide file dialog with that from Qt. Now the file extensions appear again and you don't need to set the file extension manually any more. It is added automatically.

Issue History

Date Modified Username Field Change
2013-06-22 18:56 fester2251 New Issue
2013-06-22 19:00 fester2251 Note Added: 0003237
2013-06-26 09:11 Jriegel Note Added: 0003240
2013-06-26 09:11 Jriegel Status new => feedback
2013-06-26 23:29 normandc Note Added: 0003262
2013-06-26 23:37 normandc Note Added: 0003263
2013-06-26 23:56 fester2251 Note Added: 0003264
2013-06-27 14:15 wmayer Note Added: 0003273
2013-06-27 14:16 wmayer Status feedback => assigned
2013-06-27 14:16 wmayer Assigned To => wmayer
2013-06-27 14:16 wmayer Status assigned => closed
2013-06-27 14:16 wmayer Resolution open => fixed
2013-06-27 14:16 wmayer Fixed in Version => 0.14