View Issue Details

IDProjectCategoryView StatusLast Update
0001155FreeCADBugpublic2013-10-22 08:17
ReportermatuschdAssigned Towmayer 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001155: FreeCAD crashed while creating a loft of two ellipses
DescriptionWhen creating a loft of the ellipses co71 and co72 in the attached file, FreeCAD crashes.
This could be reproduced with KiCAD 0.13 on MacOS and Linux (Ubuntu). It also happens with 0.14RC on Windows


Reproduce:
 - Open file
 - Go to "Part"
 - Select "Utility to loft"
 - Select co71 and co72 to "Loft"
 - Press "OK"
TagsNo tags attached.

Activities

2013-06-19 17:58

 

crash-co71-co72.FCStd (Attachment missing)

wmayer

2013-06-20 09:19

administrator   ~0003233

Last edited: 2013-06-20 09:20

This is caused by a bug inside the OpenCascade source code which we cannot fix. All what we can do is using a mechanism that convert SIGSEGV signals into C++ exceptions which then can be handled by FreeCAD.

This means that the loft still doesn't work (OpenCadcade needs to fix this) but at least FreeCAD doesn't crash any more.

This works for Windows (MSVC) and Linux v0.14. I don't know if it works under Mac OS X.

git show 5b46a86

Issue History

Date Modified Username Field Change
2013-06-19 17:58 matuschd New Issue
2013-06-19 17:58 matuschd File Added: crash-co71-co72.FCStd
2013-06-20 09:19 wmayer Note Added: 0003233
2013-06-20 09:20 wmayer Note Edited: 0003233
2013-06-20 09:20 wmayer Status new => resolved
2013-06-20 09:20 wmayer Fixed in Version => 0.14
2013-06-20 09:20 wmayer Resolution open => fixed
2013-06-20 09:20 wmayer Assigned To => wmayer
2013-10-22 08:17 wmayer Status resolved => closed