View Issue Details

IDProjectCategoryView StatusLast Update
0001140DraftBugpublic2013-09-09 06:59
ReporterpfirsztAssigned Toyorik 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001140: FreeCAD crashes when deleting element in drafter
DescriptionOpen attached file
Select None005 from the tree
Hit Delete key
FreeCAD crashes
Additional Information<type 'exceptions.NameError'>
<type 'exceptions.NameError'>
<type 'exceptions.ZeroDivisionError'>
<type 'exceptions.ZeroDivisionError'>
Unhandled Base::Exception caught in GUIApplication::notify.
The error message is: 'NoneType' object has no attribute 'Vertexes'
Unhandled Base::Exception caught in GUIApplication::notify.
The error message is: 'NoneType' object has no attribute 'Vertexes'

Program received signal SIGSEGV, Segmentation fault.
0x0000003f15b856c1 in QRasterPaintEngine::brushOriginChanged() ()
   from /lib64/libQtGui.so.4
(gdb) bt
#0 0x0000003f15b856c1 in QRasterPaintEngine::brushOriginChanged() ()
   from /lib64/libQtGui.so.4
#1 0x0000003f15a0ff33 in QWidgetPrivate::paintBackground(QPainter*, QRegion const&, int) const () from /lib64/libQtGui.so.4
0000002 0x0000003f15a15a5a in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) ()
   from /lib64/libQtGui.so.4
0000003 0x0000003f15bdfd8d in QWidgetBackingStore::sync() ()
   from /lib64/libQtGui.so.4
0000004 0x0000003f15a0a5f0 in QWidgetPrivate::syncBackingStore() ()
   from /lib64/libQtGui.so.4
0000005 0x0000003f15a1a3a4 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
0000006 0x0000003f15dddf2b in QMainWindow::event(QEvent*) ()
   from /lib64/libQtGui.so.4
0000007 0x00000037a222923b in Gui::MainWindow::event(QEvent*) ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
0000008 0x0000003f159ca5cc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /lib64/libQtGui.so.4
0000009 0x0000003f159cea4a in QApplication::notify(QObject*, QEvent*) ()
   from /lib64/libQtGui.so.4
0000010 0x00000037a204f05f in Gui::GUIApplication::notify(QObject*, QEvent*) ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
0000011 0x0000003f1537793e in QCoreApplication::notifyInternal(QObject*, QEvent*)
---Type <return> to continue, or q <return> to quit---
    () from /lib64/libQtCore.so.4
0000012 0x0000003f1537b3f1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQtCore.so.4
0000013 0x0000003f153a5df3 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtCore.so.4
0000014 0x0000003f00a47a55 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
0000015 0x0000003f00a47d88 in g_main_context_iterate.isra.24 ()
   from /lib64/libglib-2.0.so.0
0000016 0x0000003f00a47e44 in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
0000017 0x0000003f153a5f86 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000018 0x0000003f15a6a73e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
0000019 0x0000003f153765ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000020 0x0000003f15376878 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000021 0x0000003f1537b708 in QCoreApplication::exec() ()
   from /lib64/libQtCore.so.4
0000022 0x00000037a204c483 in Gui::Application::runApplication() ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
---Type <return> to continue, or q <return> to quit---
0000023 0x0000000000404253 in main ()
TagsNo tags attached.

Relationships

has duplicate 0001227 closed FreeCAD FreeCAD crash with segfault Linux 

Activities

2013-05-26 15:44

 

s4-uchwyt_1.fcstd (84,594 bytes)

gimmebottles

2013-06-12 05:11

reporter   ~0003197

Also affects the latest version from Ubuntu PPA (0.14), reproducable with the file uploaded and also experienced in own projects.

yorik

2013-06-14 12:44

administrator   ~0003203

I can't reproduce this... I can delete any object without problems. Anyone else experiencing this?

wmayer

2013-06-15 11:42

administrator   ~0003206

It would be good to know the Qt version.

gimmebottles

2013-06-16 14:47

reporter   ~0003225

Last edited: 2013-06-16 14:50

The crash seems to be caused by libQtGui.so, which is version 4.8.4. I'm running 64 bit Ubuntu 13.04, I compiled FreeCAD myself, Git rev. 2184

pfirszt

2013-06-26 19:42

reporter   ~0003259

you might be right:
bash-4.2$ locate libQtGui.so
/usr/lib64/libQtGui.so
/usr/lib64/libQtGui.so.4
/usr/lib64/libQtGui.so.4.8
/usr/lib64/libQtGui.so.4.8.4

maurerpe

2013-07-20 13:45

reporter   ~0003418

I am also having this problem. I often have issues deleting objects from files that I have modelled. The s4-uchwyt_1.fcstd file attached by pfirszt exhibits the issues that I am seeing.

It seems that the order that parts are deleted affects the issue. If I start FreeCAD and delete None005 (either with the del key or from edit->delete, most of my testing uses the del key) FreeCAD crashes with a segfault every time. However, if I continually delete the top item, I can delete everything in the file.

Deleting the following items immediately after opening the file causes a segfault (click on object in layers & attributes panel, hit del key):
None
None002
None003
None004
None005

If I delete BackPlate first, then I can delete None and then None003 and None004, but not None002. Deleting BackPlate then None003, without deleting
None in between causes a segfault.

Also, the order other actions matters for example:
Start FreeCAD with s4-uchwyt_1.fcstd, Click on BSpline003 in layers & attributes tab, Hit del key -> Works
Start FreeCAD with s4-uchwyt_1.fcstd, Click on BSpline004 in layers & attributes tab, Click on BSpline003 in layers & attributes tab, Hit del key -> Segfault
Start FreeCAD with s4-uchwyt_1.fcstd, Click on BSpline004 in viewport, Click on BSpline003 in layers & attributes tab, Hit del key -> Segfault
Start FreeCAD with s4-uchwyt_1.fcstd, Click on BSpline004 in veiwport, Click on BSpline003 in viewport, Hit del key -> Works
All of those are repeatable on my machine.

Gentoo Linux on AMD64
FreeCAD https://github.com/FreeCAD/FreeCAD_sf_master.git, pulled July 12
qt 4.8.4
qtqui 4.8.4
gcc 4.6.3
python 2.7.5
coin 3.1.3
SoQt 1.5.0
OCC 6.6.0 (However, I noticed this with earlier versions of OCC, such as 6.5.0)

Let me know if you need any other information.

yorik

2013-07-20 15:07

administrator   ~0003419

There is definitely something strange there, I can't reproduce any of this... I can delete any of the elements, in any order, without crash. The only difference I see between my system and your specs is that I use opencascade oce edition... All the rest is the same. Can anyone else test the attached file?

louwersj

2013-09-03 15:22

reporter   ~0003545

I have a issue which looks like this... when deleting objects FreeCad crashes under Ubuntu. I have the feeling it is somehow related to the order of objects being removed. Also the objects are not shown in the object list however they are still in the 3D view.

I just downloaded the latest version of FreeCad and upgraded Ubuntu to the latest version.


//--------------------
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring

Linux linux-main 3.8.0-29-generic 0000042-Ubuntu SMP Tue Aug 13 23:12:18 UTC 2013 i686 i686 i686 GNU/Linux
//--------------------

Regards,
Johan Louwers

louwersj

2013-09-04 11:44

reporter   ~0003547

I did a check with the attached file and deleted the mentioned None005 object and experienced the same... the application crashes. Meaning, I can confirm this issue and can confirm it can be reproduced.

Regards,
Johan Louwers.

louwersj

2013-09-04 12:13

reporter   ~0003548

please note the following actions I have done which resulted in the below logile.

1) open freeacad from the commandline with freecad -l
2) set workbench to complete
3) open file s4-uchwyt_1.fcstd
4) select None005
5) hit "Delete" button

Those steps result in the application crashing and the below logfile is generated:

Msg: FreeCAD 0.12, Libs: 0.12R5382
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

Log: Time = Wed Sep 4 16:09:57 2013
Log: AppDataSkipVendor = true
Log: AppHomePath = /usr/lib/freecad/
Log: AppIcon = freecad
Log: BinPath = /usr/lib/freecad/bin/
Log: BuildRepositoryURL = https://free-cad.svn.sourceforge.net/svnroot/free-cad/branches/Version-0-12
Log: BuildRevision = 5382
Log: BuildRevisionDate = 2012/01/03 13:40:14
Log: BuildVersionMajor = 0
Log: BuildVersionMinor = 12
Log: ConsoleBanner = © Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##


Log: Debug = 0
Log: DocPath = /usr/lib/freecad/doc/
Log: ExeName = FreeCAD
Log: ExeVendor = FreeCAD
Log: ExeVersion = 0.12
Log: LoggingFile = 1
Log: LoggingFileName = /home/louwersj/.FreeCAD/FreeCAD.log
Log: MaintainerUrl = http://apps.sourceforge.net/mediawiki/free-cad/index.php?title=Main_Page
Log: PATH = /usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
Log: PYTHONPATH =
Log: PythonSearchPath = :/usr/bin/../lib/python2.7/:/usr/bin/../lib/python2.7/plat-i386-linux-gnu:/usr/bin/../lib/python2.7/lib-tk:/usr/bin/../lib/python2.7/lib-old:/usr/bin/../lib/python2.7/lib-dynload
Log: RunMode = Gui
Log: SplashAlignment = Bottom|Left
Log: SplashPicture = freecadsplash
Log: SplashTextColor = #ffffff
Log: StartWorkbench = StartWorkbench
Log: SystemParameter = /home/louwersj/.FreeCAD/system.cfg
Log: UserAppData = /home/louwersj/.FreeCAD/
Log: UserHomePath = /home/louwersj
Log: UserParameter = /home/louwersj/.FreeCAD/user.cfg
Log: Verbose =
Log: Create Application
Log: Init: starting App::FreeCADInit.py
Log: Init: Searching for modules...
Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
Log: Init: Initializing /usr/lib/freecad/Mod/Fem... done
Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
Log: Using /usr/lib/freecad/Mod as module path!
Log: System path after init:
Log: /usr/lib/freecad/bin
Log: /usr/lib/freecad/Mod/Sketcher
Log: /usr/lib/freecad/Mod/MeshPart
Log: /usr/lib/freecad/Mod/ReverseEngineering
Log: /usr/lib/freecad/Mod/Image
Log: /usr/lib/freecad/Mod/Fem
Log: /usr/lib/freecad/Mod/Robot
Log: /usr/lib/freecad/Mod/Mesh
Log: /usr/lib/freecad/Mod/PartDesign
Log: /usr/lib/freecad/Mod/Raytracing
Log: /usr/lib/freecad/Mod/Points
Log: /usr/lib/freecad/Mod/Draft
Log: /usr/lib/freecad/Mod/Test
Log: /usr/lib/freecad/Mod/Import
Log: /usr/lib/freecad/Mod/Part
Log: /usr/lib/freecad/Mod/Inspection
Log: /usr/lib/freecad/Mod/Drawing
Log: /usr/lib/freecad/Mod/Complete
Log: /usr/lib/lightdm/lightdm
Log: /usr/local/sbin
Log: /usr/local/bin
Log: /usr/sbin
Log: /usr/bin
Log: /sbin
Log: /bin
Log: /usr/games
Log: /usr/local/games
Log: Init: App::FreeCADInit.py done
Log: Init: Creating Gui::Application and QApplication
Log: OpenGL version 2.1 or higher is present
Log: Init: Running FreeCADGuiInit.py start script...
Log: Init: Searching modules...
Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
Log: Init: Initializing /usr/lib/freecad/Mod/Fem... done
Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
Log: Init: Loading FreeCAD GUI
Log: Init: Running FreeCADGuiInit.py start script... done
Log: Init: Activating default workbench StartWorkbench
Log: Init: Showing main window
Log: Main window restored
Log: Show main window
Log: Toolbars restored
Log: Init: Entering event loop
Log: Init: Processing command line files
Log: Loading Part module... done
Log: Loading GUI of Part module... done
Log: Loading Mesh module... done
Log: Loading GUI of Mesh module... done
Log: Loading GUI of MeshPart module... done
Log: Loading Points module... done
Log: Loading GUI of Points module... done
Log: Loading GUI of Drawing module... done
Log: Loading Raytracing module... done
Log: Loading GUI of Raytracing module... done
Log: Loading Sketcher module... done
Log: Loading GUI of Sketcher module... done
Log: Loading GUI of PartDesign module... done
Log: Loading GUI of Image module... done
Log: Loading Draft GUI...
Log: Loading Image module... done
Log: Loading Drawing module... done
Log: Loading GUI of Complete module... done
Log: Loading PartDesign module... done
Log: Loading Complete module... done
Log: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Toggle visibility" under id 218
Log: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Chamfer..." under id 330
Log: Active view is Unnamed : 1
  • (at 0xa6ce760)
    Log: Active document is s4_uchwyt_1 (at 0xa308c00)
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Wrn: PropertyPythonObject::fromString: invalid load key, '"'.
    Log: X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 31 (X_GrabKeyboard)
      Resource id: 0x0
    Log: ViewProvider update time: 0.001000 s
    Log: Shape tria info: Faces:0 Edges:8 Nodes:30 Triangles:0 IdxVec:30
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:8 Nodes:32 Triangles:0 IdxVec:32
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:12 Triangles:0 IdxVec:11
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.001000 s
    Log: Shape tria info: Faces:1 Edges:1 Nodes:37 Triangles:34 IdxVec:38
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:13 Triangles:0 IdxVec:12
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:13 Triangles:0 IdxVec:12
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:11 Triangles:0 IdxVec:10
    Wrn: PropertyPythonObject::fromString: invalid load key, 'n'.
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:13 Triangles:0 IdxVec:12
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:13 Triangles:0 IdxVec:12
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:1 Edges:1 Nodes:37 Triangles:34 IdxVec:38
    Log: ViewProvider update time: 0.001000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:15 Triangles:0 IdxVec:14
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:15 Triangles:0 IdxVec:14
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:4 Triangles:0 IdxVec:3
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:13 Triangles:0 IdxVec:12
    Log: ViewProvider update time: 0.000000 s
    Log: Shape tria info: Faces:0 Edges:1 Nodes:16 Triangles:0 IdxVec:15
    Log: Active view is s4-uchwyt_1 : 1
  • (at 0xa6ce760)
    Log: Active view is s4-uchwyt_1 : 1
  • (at 0xa6ce760)
    Log: Sel : Rmv Selection "s4_uchwyt_1.None005.(null)"
    Log: QWidget::repaint: Recursive repaint detected
    Err: Illegal storage access...Err:
  • yorik

    2013-09-04 12:33

    administrator   ~0003549

    Hm you are using version 0.12, which is very old now... If you are willing to help debugging this further, could you try with a recent version (check our daily PPA)?

    bejant

    2013-09-05 14:23

    reporter   ~0003554

    I have no problems; download file, FreeCAD opens, change to Complete Workbench, select None005 from hierarchy tree, hit [Del] key = successful delete with no crash. Can undo and delete again. But I'm using
    OS: Windows XP
    Platform: 32-bit
    Version: 0.14.2370 (Git)
    Branch: master
    Hash: a836759ebd91404954a778ff8885e152611576e1
    Python version: 2.6.2
    Qt version: 4.5.2
    Coin version: 3.1.0
    SoQt version: 1.4.1
    OCC version: 6.5.1

    louwersj

    2013-09-06 07:28

    reporter   ~0003557

    @yorikvanhavre, I will download the latest version and reproduce it with the exact same steps so we have something to compare during the debug. Give me some time as I have to find a timeslot to do so somewhere today (I hope).

    Regards,
    Johan Louwers.

    stefanpeter

    2013-09-07 11:20

    reporter   ~0003559

    Here is a log file from Ubuntu 13.04 amd64.

    Free-cad was 0.13.1830-1ppa1~raring1 from https://launchpad.net/~freecad-maintainers/+archive/freecad-stable

    ?Msg: FreeCAD 0.13, Libs: 0.13R1830 (Git)
    © Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
      ##### #### ### ####
      # # # # # #
      # ## #### #### # # # # #
      #### # # # # # # # ##### # #
      # # #### #### # # # # #
      # # # # # # # # # ## ## ##
      # # #### #### ### # # #### ## ## ##

    Log: Time = Sat Sep 7 14:54:40 2013
    Log: AppDataSkipVendor = true
    Log: AppHomePath = /usr/lib/freecad/
    Log: AppIcon = freecad
    Log: BinPath = /usr/lib/freecad/bin/
    Log: BuildRepositoryURL = ssh://wmayer@free-cad.git.sourceforge.net/gitroot/free-cad/free-cad
    Log: BuildRevision = 1830 (Git)
    Log: BuildRevisionBranch = releases/FreeCAD-0-13
    Log: BuildRevisionDate = 2013/02/02 18:09:17
    Log: BuildRevisionHash = ec7636d7aaf2612e9b43cff5d6a424037d53e505
    Log: BuildVersionMajor = 0
    Log: BuildVersionMinor = 13
    Log: CopyrightInfo = © Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
      ##### #### ### ####
      # # # # # #
      # ## #### #### # # # # #
      #### # # # # # # # ##### # #
      # # #### #### # # # # #
      # # # # # # # # # ## ## ##
      # # #### #### ### # # #### ## ## ##


    Log: Debug = 0
    Log: DocPath = /usr/lib/freecad/doc/
    Log: ExeName = FreeCAD
    Log: ExeVendor = FreeCAD
    Log: ExeVersion = 0.13
    Log: LoggingFile = 1
    Log: LoggingFileName = /home/stefan/.FreeCAD/FreeCAD.log
    Log: MaintainerUrl = http://apps.sourceforge.net/mediawiki/free-cad/index.php?title=Main_Page
    Log: PATH = /opt/mingw/usr/bin:/home/stefan/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
    Log: PYTHONPATH =
    Log: PythonSearchPath = :/usr/bin/../lib/python2.7/:/usr/bin/../lib/python2.7/plat-x86_64-linux-gnu:/usr/bin/../lib/python2.7/lib-tk:/usr/bin/../lib/python2.7/lib-old:/usr/bin/../lib/python2.7/lib-dynload
    Log: RunMode = Gui
    Log: SplashAlignment = Bottom|Left
    Log: SplashInfoColor = #c8c8c8
    Log: SplashScreen = freecadsplash
    Log: SplashTextColor = #ffffff
    Log: StartWorkbench = StartWorkbench
    Log: SystemParameter = /home/stefan/.FreeCAD/system.cfg
    Log: UserAppData = /home/stefan/.FreeCAD/
    Log: UserHomePath = /home/stefan
    Log: UserParameter = /home/stefan/.FreeCAD/user.cfg
    Log: Verbose =
    Log: Create Application
    Log: Init: starting App::FreeCADInit.py
    Log: Init: Searching for modules...
    Log: Init: Initializing /usr/lib/freecad/Mod/Machining_Distortion... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
    Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
    Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Ship(Init.py not found)... ignore
    Log: Init: Initializing /usr/lib/freecad/Mod/Plot(Init.py not found)... ignore
    Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
    Log: Init: Initializing /usr/lib/freecad/Mod/OpenSCAD... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Fem... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Start... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Assembly... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Web... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Arch... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Idf... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
    Log: Using /usr/lib/freecad/Mod as module path!
    Log: System path after init:
    Log: /usr/lib/freecad/bin
    Log: /usr/lib/freecad/Mod/Machining_Distortion
    Log: /usr/lib/freecad/Mod/Sketcher
    Log: /usr/lib/freecad/Mod/ReverseEngineering
    Log: /usr/lib/freecad/Mod/Image
    Log: /usr/lib/freecad/Mod/PartDesign
    Log: /usr/lib/freecad/Mod/Ship
    Log: /usr/lib/freecad/Mod/Plot
    Log: /usr/lib/freecad/Mod/MeshPart
    Log: /usr/lib/freecad/Mod/OpenSCAD
    Log: /usr/lib/freecad/Mod/Fem
    Log: /usr/lib/freecad/Mod/Start
    Log: /usr/lib/freecad/Mod/Points
    Log: /usr/lib/freecad/Mod/Draft
    Log: /usr/lib/freecad/Mod/Test
    Log: /usr/lib/freecad/Mod/Import
    Log: /usr/lib/freecad/Mod/Assembly
    Log: /usr/lib/freecad/Mod/Complete
    Log: /usr/lib/freecad/Mod/Web
    Log: /usr/lib/freecad/Mod/Raytracing
    Log: /usr/lib/freecad/Mod/Mesh
    Log: /usr/lib/freecad/Mod/Arch
    Log: /usr/lib/freecad/Mod/Robot
    Log: /usr/lib/freecad/Mod/Part
    Log: /usr/lib/freecad/Mod/Idf
    Log: /usr/lib/freecad/Mod/Inspection
    Log: /usr/lib/freecad/Mod/Drawing
    Log: /opt/mingw/usr/bin
    Log: /home/stefan/bin
    Log: /usr/lib/lightdm/lightdm
    Log: /usr/local/sbin
    Log: /usr/local/bin
    Log: /usr/sbin
    Log: /usr/bin
    Log: /sbin
    Log: /bin
    Log: /usr/games
    Log: /usr/local/games
    Log: Init: App::FreeCADInit.py done
    Log: Init: Creating Gui::Application and QApplication
    Log: OpenGL version 3.0 or higher is present
    Log: Init: Running FreeCADGuiInit.py start script...
    Log: Init: Searching modules...
    Log: Init: Initializing /usr/lib/freecad/Mod/Machining_Distortion... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
    Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
    Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Ship... done
    Msg: matplotlib not found, Plot module will be disabled
    Log: Init: Initializing /usr/lib/freecad/Mod/Plot... done
    Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
    Log: Init: Initializing /usr/lib/freecad/Mod/OpenSCAD... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Fem... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Start... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Assembly... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Web... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
    Log: Loading Part module... done
    Msg: pycollada not found, collada support will be disabled.
    Log: Init: Initializing /usr/lib/freecad/Mod/Arch... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Idf(InitGui.py not found)... ignore
    Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
    Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
    Log: Init: Loading FreeCAD GUI
    Log: Init: Running FreeCADGuiInit.py start script... done
    Log: Init: Activating default workbench StartWorkbench
    Log: Loading GUI of Web module... done
    Log: Loading GUI of Start module... done
    Log: Loading Start module... done
    Log: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Toggle visibility" under id 222
    Log: Init: Showing main window
    Log: Main window restored
    Log: Show main window
    Log: Toolbars restored
    Log: Couldn't connect to spacenav daemon
    Log: Init: Entering event loop
    Log: Init: Processing command line files
    Log: Active view is Unnamed : 1
  • (at 0x335c3a0)
    Log: Active document is Unnamed (at 0x46d8250)
    Log: QNetworkReplyImplPrivate::error: Internal problem, this method must only be called once.
    Log: Sel : Clear selection
    Log: No active document
    Log: Active view is Start page (at 0x438edf0)
    Log: Active view is Unnamed : 1
  • (at 0x44d3300)
    Log: Active document is s4_uchwyt_1 (at 0x5cf5740)
    Log: Loading Sketcher module... done
    Log: Loading GUI of Part module... done
    Log: Loading GUI of Sketcher module... done
    Log: Loading PartDesign module... done
    Log: Loading GUI of PartDesign module... done
    Log: Active view is s4-uchwyt_1 : 1
  • (at 0x44d3300)
    Log: Sel : Rmv Selection "s4_uchwyt_1.None005.(null)"
    Log: QWidget::repaint: Recursive repaint detected
  • yorik

    2013-09-07 14:24

    administrator   ~0003560

    This appears to be a QT problem:
    http://forum.freecadweb.org/viewtopic.php?f=3&t=4536&p=35447

    wmayer

    2013-09-08 11:28

    administrator   ~0003561

    git 813fa0c uses a work around which fixes the problem on Ubuntu 12.10. Please checkout the changes and check if this fixes the problem on your systems, too.

    maurerpe

    2013-09-08 23:10

    reporter   ~0003562

    First, I used by build from July 12, to very it the issue still existed on my machine. It did. (Not a big suprise, I run into this bug often).

    Then, I built the latest from https://github.com/FreeCAD/FreeCAD_sf_master.git including:

    commit ed54b59cf11e8b4c63b986382055f69d195a8c56
    Author: wmayer <wmayer@users.sourceforge.net>
    Date: Sun Sep 8 15:25:51 2013 +0200

        0001140: FreeCAD crashes when deleting element in drafter

    (I had to comment out the Materials module to get it to build.) This version fixed the bug. I repeated ALL of the cases from my previous comment that had segfaulted and all of the worked this time: no segfaults. I opened two my own freecad files that had exhibited similar issues in the past and deleted random things and got no segfaults.

    I await the results of similar tests from others having the issue, but I consider this bug fixed. Good work! This was a tricky one!

    gimmebottles

    2013-09-09 03:55

    reporter   ~0003563

    I can confirm that the buf seems to be solved, I built from the git sources and I can't no longer reproduce the bug. Good work!

    Issue History

    Date Modified Username Field Change
    2013-05-26 15:44 pfirszt New Issue
    2013-05-26 15:44 pfirszt File Added: s4-uchwyt_1.fcstd
    2013-06-12 05:11 gimmebottles Note Added: 0003197
    2013-06-14 12:44 yorik Note Added: 0003203
    2013-06-14 12:44 yorik Status new => feedback
    2013-06-14 12:45 yorik Status feedback => assigned
    2013-06-14 12:45 yorik Assigned To => yorik
    2013-06-14 12:45 yorik Status assigned => feedback
    2013-06-15 11:42 wmayer Note Added: 0003206
    2013-06-16 14:47 gimmebottles Note Added: 0003225
    2013-06-16 14:50 gimmebottles Note Edited: 0003225
    2013-06-26 19:42 pfirszt Note Added: 0003259
    2013-07-05 22:11 yorik Project FreeCAD => Draft
    2013-07-20 13:45 maurerpe Note Added: 0003418
    2013-07-20 15:07 yorik Note Added: 0003419
    2013-09-03 15:22 louwersj Note Added: 0003545
    2013-09-04 11:44 louwersj Note Added: 0003547
    2013-09-04 12:13 louwersj Note Added: 0003548
    2013-09-04 12:33 yorik Note Added: 0003549
    2013-09-05 14:23 bejant Note Added: 0003554
    2013-09-06 07:28 louwersj Note Added: 0003557
    2013-09-07 11:20 stefanpeter Note Added: 0003559
    2013-09-07 14:24 yorik Note Added: 0003560
    2013-09-08 11:28 wmayer Note Added: 0003561
    2013-09-08 23:10 maurerpe Note Added: 0003562
    2013-09-09 03:55 gimmebottles Note Added: 0003563
    2013-09-09 06:59 wmayer Status feedback => closed
    2013-09-09 06:59 wmayer Resolution open => fixed
    2013-09-09 06:59 wmayer Fixed in Version => 0.14
    2013-09-09 13:37 wmayer Relationship added has duplicate 0001227