View Issue Details

IDProjectCategoryView StatusLast Update
0001139FreeCADBugpublic2014-05-20 17:48
ReporterpfirsztAssigned Tojrheinlaender 
PrioritynormalSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001139: FreeCAD crashes when changing placement of sketch.
DescriptionAs above + the sketch is used to create pad. There are 4 holes int he pad created with LinearPattern. After the transformation linearpattern is no longer in the main pad area and that crashes FreeCad.

Reproduce (not always): use placement to rotate Z to 0 on "Back Plate Sketch" in the attached file
Additional Information[Thread 0x7fff8e03a700 (LWP 5987) exited]
Transformed shape does not intersect support Pocket: Removed
Transformed shape does not intersect support Pocket: Removed

Program received signal SIGSEGV, Segmentation fault.
0x00000037a16bb5c0 in App::DocumentObject::getNameInDocument() const ()
   from /usr/lib64/freecad/lib/libFreeCADApp.so
(gdb) bt
#0 0x00000037a16bb5c0 in App::DocumentObject::getNameInDocument() const ()
   from /usr/lib64/freecad/lib/libFreeCADApp.so
#1 0x00007fff75a719cd in PartDesignGui::TaskDlgLinearPatternParameters::accept() () from /usr/lib64/freecad/Mod/PartDesign/PartDesignGui.so
0000002 0x00000037a21c8bf1 in Gui::TaskView::TaskView::accept() ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
0000003 0x0000003f1538cd6f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
0000004 0x0000003f1538cd6f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib64/libQtCore.so.4
0000005 0x0000003f1602f062 in QAbstractButton::clicked(bool) ()
   from /lib64/libQtGui.so.4
0000006 0x0000003f15d83c8e in QAbstractButtonPrivate::emitClicked() ()
   from /lib64/libQtGui.so.4
0000007 0x0000003f15d84290 in QAbstractButtonPrivate::click() ()
   from /lib64/libQtGui.so.4
0000008 0x0000003f15d844fc in QAbstractButton::mouseReleaseEvent(QMouseEvent*) ()
   from /lib64/libQtGui.so.4
0000009 0x0000003f15a19f49 in QWidget::event(QEvent*) () from /lib64/libQtGui.so.4
0000010 0x0000003f159ca5cc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /lib64/libQtGui.so.4
0000011 0x0000003f159cf2ab in QApplication::notify(QObject*, QEvent*) ()
   from /lib64/libQtGui.so.4
0000012 0x00000037a204f05f in Gui::GUIApplication::notify(QObject*, QEvent*) ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
0000013 0x0000003f1537793e in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /lib64/libQtCore.so.4
0000014 0x0000003f159cb40b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /lib64/libQtGui.so.4
0000015 0x0000003f15a45b74 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /lib64/libQtGui.so.4
0000016 0x0000003f15a44901 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /lib64/libQtGui.so.4
0000017 0x0000003f15a6aa5c in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQtGui.so.4
0000018 0x0000003f00a47a55 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
0000019 0x0000003f00a47d88 in g_main_context_iterate.isra.24 ()
   from /lib64/libglib-2.0.so.0
0000020 0x0000003f00a47e44 in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
0000021 0x0000003f153a5f86 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000022 0x0000003f15a6a73e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtGui.so.4
0000023 0x0000003f153765ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000024 0x0000003f15376878 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
0000025 0x0000003f1537b708 in QCoreApplication::exec() ()
   from /lib64/libQtCore.so.4
0000026 0x00000037a204c483 in Gui::Application::runApplication() ()
   from /usr/lib64/freecad/lib/libFreeCADGui.so
0000027 0x0000000000404253 in main ()
TagsNo tags attached.

Activities

2013-05-26 06:32

 

s4-uchwyt.fcstd (Attachment missing)

jrheinlaender

2013-07-22 14:48

developer   ~0003421

Could you please detail "As above + the sketch is used to create pad". What is meant with "above"?

"After the transformation linearpattern is no longer in the main pad area and that crashes FreeCad."
I couldn't reproduce that. After changing the placement of the Back Plate Sketch the holes move along nicely staying in the correct relative position

jrheinlaender

2013-07-22 14:50

developer   ~0003422

But I did notice that double-clicking on the LinearPatterns which are subordinate to the MultiTransform will crash FC after closing the edit dialog. IMHO the solution is to hide these subordinate LinearPatterns so that they are not visible for selection.

jrheinlaender

2013-07-28 17:36

developer   ~0003432

Please give more information on how to reproduce the crash

pfirszt

2013-07-31 19:46

reporter   ~0003435

I wasn't precise enough. "As above" was about the name of the bug report.
I'll try to reproduce the bug and provide detailed step-by-step instruction.

pfirszt

2013-07-31 20:05

reporter   ~0003436

This is a recording of a short gdb session:

http://firszt.eu/FreeCAD/FreeCAD_crash.webm

For some reason I couldn't upload it to sourceforge.

Let m know if that's enough (it might not be clear when I use double-click)

jrheinlaender

2013-08-01 04:19

developer   ~0003437

See my comment above:

But I did notice that double-clicking on the LinearPatterns which are subordinate to the MultiTransform will crash FC after closing the edit dialog. IMHO the solution is to hide these subordinate LinearPatterns so that they are not visible for selection.

You should modify the sub-features of a MultiTransform through the MultiTransform dialog, not directly.

There is a discussion about hiding the subfeatures in the tree altogether, see
http://forum.freecadweb.org/viewtopic.php?f=10&t=2951&p=34019#p34019

wmayer

2014-05-20 17:48

administrator   ~0004709

Look at the change sets.

Related Changesets

FreeCAD: master aaeba38e

2014-03-31 14:42:55

wmayer

Details Diff
+ Fix crash when editing the linear pattern feature, suppress some warnings in release mode Affected Issues
0001139
mod - src/App/Document.cpp Diff File
mod - src/Mod/PartDesign/App/FeatureTransformed.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp Diff File

FreeCAD: master e47b8599

2014-03-31 16:35:22

wmayer

Details Diff
+ fix possible crashes in mirror and polar pattern feature Affected Issues
0001139
mod - src/Mod/PartDesign/App/FeatureTransformed.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskLinearPatternParameters.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskMirroredParameters.cpp Diff File
mod - src/Mod/PartDesign/Gui/TaskPolarPatternParameters.cpp Diff File

Issue History

Date Modified Username Field Change
2013-05-26 06:32 pfirszt New Issue
2013-05-26 06:32 pfirszt File Added: s4-uchwyt.fcstd
2013-05-29 16:15 wmayer Status new => assigned
2013-05-29 16:15 wmayer Assigned To => jrheinlaender
2013-07-22 14:48 jrheinlaender Note Added: 0003421
2013-07-22 14:50 jrheinlaender Note Added: 0003422
2013-07-28 17:36 jrheinlaender Note Added: 0003432
2013-07-28 17:36 jrheinlaender Status assigned => feedback
2013-07-31 19:46 pfirszt Note Added: 0003435
2013-07-31 20:05 pfirszt Note Added: 0003436
2013-08-01 04:19 jrheinlaender Note Added: 0003437
2014-05-20 17:46 wmayer Changeset attached => FreeCAD Master master aaeba38e
2014-05-20 17:48 wmayer Changeset attached => FreeCAD Master master e47b8599
2014-05-20 17:48 wmayer Note Added: 0004709
2014-05-20 17:48 wmayer Status feedback => closed
2014-05-20 17:48 wmayer Resolution open => fixed
2014-05-20 17:48 wmayer Fixed in Version => 0.14