View Issue Details

IDProjectCategoryView StatusLast Update
0001138FreeCADBugpublic2013-06-17 11:10
Reporterpeepsalot Assigned Toyorik  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.14 
Summary0001138: DeprecationWarning: Use 'TypeId' instead
DescriptionSteps to reproduce:
1) Import an STL file into current document.
2) Select the STL object in the document
3) See a line after line of "DeprecationWarning: Use 'TypeId' instead" in Report View for as long as the object is selected.

This does not crash freecad, but for some reason this causes Ubuntu 13.04 to think that FreeCAD has crashed, creating an annoying crash report window, and starting another instance of FreeCAD when you click to report the error. As far as I know the crash report doesn't do anything since its from a PPA.
Additional InformationOS: Ubuntu 13.04
Platform: 64-bit
Version: 0.14.2127 (Git)
Branch: master
Hash: b45c1dbb8462b7dc1f3bb0130cb642987d2b9ce1
Python version: 2.7.4
Qt version: 4.8.4
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.
FreeCAD Information

Activities

wmayer

2013-05-25 13:39

administrator   ~0003180

I doubt that this happens for an STL file (and for me it doesn't!).

This message is intended to replace the Python code in the Draft (and/or Arch) module because "Type" is only used there. The change is necessary because in the Sketch the property "Type" is used in a different context and thus could cause problems with Draft objects.

But I don't see why this should affect Ubuntu in a way that it thinks that FreeCAD has crashed. IMO that's a bug in Ubuntu and not in FreeCAD.

wmayer

2013-05-25 13:44

administrator   ~0003181

Hey, Yorik can you please check the Draft (and/or Arch) sources where you use the property "Type" (it's from BaseClassPy) where you get the C++ class name, e.g. "Part::Feature"? "Type" is marked as deprecated and you should use "TypeId" now. This is because for a more consistent naming (to the C++ method) and because "Type" is used in the Sketcher in a different context.

ariel-co

2013-05-28 02:13

reporter   ~0003183

Hi, I just got this same message and Apport dialog _once_ from build 2128, with exactly the same OS and lib versions as peepsalot. I haven't lost control of FreeCAD either.

In my case,
* the Report view only says "Unknown OCC exception"
* it happened just once, and I wasn't changing anything (I was either selecting a part or rotating the view)
* I didn't import anything,and my doc consists of padded sketches, polygons, planes, ellipses, etc. I've never touched the Arch module and I'm not sure whether the Draft workbench has any relation to the "parametric geometric primitives".

yorik

2013-06-14 12:16

administrator   ~0003202

Ok I think I changed all the remaining Type attributes in Draft & Arch (commit 6a88bcd)

I think the message have no relation with the problems you guys describe here, and hopefully the Deprecation warning will not appear anymore.

I'll leave this bug report open a little more in case someone still finds problems...

wmayer

2013-06-15 11:38

administrator   ~0003204

Thanks Yorik!

I once had this behaviour too which peepsalot described. When selecting a certain type of object there was raised an Python exception all the time and maybe this caused Ubuntu to open the crash report. But the latter is definitely not a FreeCAD bug.

Anyway, in commit 6a9594d I removed the attribute 'Type' from the call tips.

peepsalot

2013-06-17 01:40

reporter   ~0003228

Just got the latest daily build and verified that this message no longer occurs for me.

yorik

2013-06-17 11:10

administrator   ~0003230

Okay, then let's close this report (one bug less is always welcome :) ). Reopen if needed...

Issue History

Date Modified Username Field Change
2013-05-25 02:17 peepsalot New Issue
2013-05-25 13:39 wmayer Note Added: 0003180
2013-05-25 13:40 wmayer Status new => assigned
2013-05-25 13:40 wmayer Assigned To => yorik
2013-05-25 13:44 wmayer Note Added: 0003181
2013-05-28 02:13 ariel-co Note Added: 0003183
2013-06-14 12:16 yorik Note Added: 0003202
2013-06-14 12:21 yorik Status assigned => feedback
2013-06-15 11:38 wmayer Note Added: 0003204
2013-06-17 01:40 peepsalot Note Added: 0003228
2013-06-17 11:10 yorik Note Added: 0003230
2013-06-17 11:10 yorik Status feedback => closed
2013-06-17 11:10 yorik Resolution open => fixed
2013-06-17 11:10 yorik Fixed in Version => 0.14