View Issue Details

IDProjectCategoryView StatusLast Update
0001100DraftBugpublic2013-12-20 21:22
Reporterdubstar-04Assigned Toyorik 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.13 
Target VersionFixed in Version0.14 
Summary0001100: Draft snapping issue with rectangles
DescriptionOS: Ubuntu 12.10
Platform: 64-bit
Version: 0.13.2049 (Git)
Branch: master
Hash: 602bfe48cf39ad9b8ac02d7085d6439887145bc0
Python version: 2.7.3
Qt version: 4.8.3
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

I am experiencing a number of crashes that seem to be related to the snaps.

step 1: Draw a 100 x 100 rectangle from 0,0
step 2: Fillet the rectangle (10mm)
step 3: draw a line from the centre of the top to the centre of the bottom

on clicking to confirm the centre snap for the second point of the line FreeCAD crashes.

This issue is highly repeatable.
TagsNo tags attached.

Activities

yorik

2013-04-19 14:00

administrator   ~0003077

I can't reproduce this behaviour... for me it all seems to work fine

>>> import Draft
>>> pl = FreeCAD.Placement()
>>> pl.Rotation.Q = (0.0,-0.0,-0.0,1.0)
>>> pl.Base = FreeCAD.Vector(0.0,0.0,0.0)
>>> Draft.makeRectangle(length=100.0,height=100.0,placement=pl,face=False,support=None)
>>> FreeCAD.getDocument("Unnamed").getObject("Rectangle").FilletRadius = 1.00
>>> FreeCAD.getDocument("Unnamed").getObject("Rectangle").FilletRadius = 10.00
>>> import Draft
>>> points=[FreeCAD.Vector(50.0,100.0,0.0),FreeCAD.Vector(50.0,0.0,0.0)]
>>> Draft.makeWire(points,closed=False,face=False,support=FreeCAD.ActiveDocument.getObject("Rectangle"))

Can you try launching freecad from a terminal, and paste here any error message that appears on the crash?

dubstar-04

2013-04-19 15:07

reporter   ~0003078

I launched FreeCAD from terminal however no information is logged.

Is there a command line option to generate verbose logging?

I tried $freecad -v but that just give the version.

Thanks.

yorik

2013-04-19 15:27

administrator   ~0003079

Try "freecad -l" then in your /home/user/.FreeCAD folder you'll find a log file

dubstar-04

2013-04-19 19:22

reporter   ~0003080

I updated to the lastest git and launch FreeCAD from terminal:

OS: Ubuntu 12.10
Platform: 64-bit
Version: 0.13.2055 (Git)
Branch: master
Hash: 3511a807a30cf41909aaf12a1efe1db6c53db577
Python version: 2.7.3
Qt version: 4.8.3
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0


sandal@Office:~$ freecad -l
FreeCAD 0.13, Libs: 0.13R2055 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

matplotlib not found, Plot module will be disabled
pycollada not found, collada support will be disabled.
Draft workbench activated
Pick first point:
Pick opposite point:
Pick first point:
Pick next point:
Segmentation fault (core dumped)

dubstar-04

2013-04-20 17:45

reporter   ~0003088

Here is the full log:

?Msg: FreeCAD 0.13, Libs: 0.13R2055 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

Log: Time = Sat Apr 20 20:43:33 2013
Log: AppDataSkipVendor = true
Log: AppHomePath = /usr/lib/freecad/
Log: AppIcon = freecad
Log: BinPath = /usr/lib/freecad/bin/
Log: BuildRepositoryURL = git://git.code.sf.net/p/free-cad/code
Log: BuildRevision = 2055 (Git)
Log: BuildRevisionBranch = master
Log: BuildRevisionDate = 2013/04/18 13:48:49
Log: BuildRevisionHash = 3511a807a30cf41909aaf12a1efe1db6c53db577
Log: BuildVersionMajor = 0
Log: BuildVersionMinor = 13
Log: CopyrightInfo = © Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2011
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##


Log: Debug = 0
Log: DocPath = /usr/lib/freecad/doc/
Log: ExeName = FreeCAD
Log: ExeVendor = FreeCAD
Log: ExeVersion = 0.13
Log: LoggingFile = 1
Log: LoggingFileName = /home/sandal/.FreeCAD/FreeCAD.log
Log: MaintainerUrl = http://apps.sourceforge.net/mediawiki/free-cad/index.php?title=Main_Page
Log: PATH = /usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
Log: PYTHONPATH =
Log: PythonSearchPath = :/usr/bin/../lib/python2.7/:/usr/bin/../lib/python2.7/plat-linux2:/usr/bin/../lib/python2.7/lib-tk:/usr/bin/../lib/python2.7/lib-old:/usr/bin/../lib/python2.7/lib-dynload
Log: RunMode = Gui
Log: SplashAlignment = Bottom|Left
Log: SplashInfoColor = #c8c8c8
Log: SplashScreen = freecadsplash
Log: SplashTextColor = #ffffff
Log: StartWorkbench = StartWorkbench
Log: SystemParameter = /home/sandal/.FreeCAD/system.cfg
Log: UserAppData = /home/sandal/.FreeCAD/
Log: UserHomePath = /home/sandal
Log: UserParameter = /home/sandal/.FreeCAD/user.cfg
Log: Verbose =
Log: Create Application
Log: Init: starting App::FreeCADInit.py
Log: Init: Searching for modules...
Log: Init: Initializing /usr/lib/freecad/Mod/Machining_Distortion... done
Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
Log: Init: Initializing /usr/lib/freecad/Mod/Ship(Init.py not found)... ignore
Log: Init: Initializing /usr/lib/freecad/Mod/Plot(Init.py not found)... ignore
Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
Log: Init: Initializing /usr/lib/freecad/Mod/OpenSCAD... done
Log: Init: Initializing /usr/lib/freecad/Mod/Start... done
Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
Log: Init: Initializing /usr/lib/freecad/Mod/Assembly... done
Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
Log: Init: Initializing /usr/lib/freecad/Mod/Web... done
Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
Log: Init: Initializing /usr/lib/freecad/Mod/Arch... done
Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
Log: Init: Initializing /usr/lib/freecad/Mod/Idf... done
Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
Log: Using /usr/lib/freecad/Mod as module path!
Log: System path after init:
Log: /usr/lib/freecad/bin
Log: /usr/lib/freecad/Mod/Machining_Distortion
Log: /usr/lib/freecad/Mod/Sketcher
Log: /usr/lib/freecad/Mod/ReverseEngineering
Log: /usr/lib/freecad/Mod/Image
Log: /usr/lib/freecad/Mod/PartDesign
Log: /usr/lib/freecad/Mod/Ship
Log: /usr/lib/freecad/Mod/Plot
Log: /usr/lib/freecad/Mod/MeshPart
Log: /usr/lib/freecad/Mod/OpenSCAD
Log: /usr/lib/freecad/Mod/Start
Log: /usr/lib/freecad/Mod/Draft
Log: /usr/lib/freecad/Mod/Test
Log: /usr/lib/freecad/Mod/Import
Log: /usr/lib/freecad/Mod/Assembly
Log: /usr/lib/freecad/Mod/Complete
Log: /usr/lib/freecad/Mod/Web
Log: /usr/lib/freecad/Mod/Raytracing
Log: /usr/lib/freecad/Mod/Mesh
Log: /usr/lib/freecad/Mod/Part
Log: /usr/lib/freecad/Mod/Arch
Log: /usr/lib/freecad/Mod/Robot
Log: /usr/lib/freecad/Mod/Points
Log: /usr/lib/freecad/Mod/Idf
Log: /usr/lib/freecad/Mod/Inspection
Log: /usr/lib/freecad/Mod/Drawing
Log: /usr/lib/lightdm/lightdm
Log: /usr/local/sbin
Log: /usr/local/bin
Log: /usr/sbin
Log: /usr/bin
Log: /sbin
Log: /bin
Log: /usr/games
Log: /usr/local/games
Log: Init: App::FreeCADInit.py done
Log: Init: Creating Gui::Application and QApplication
Log: OpenGL version 3.0 or higher is present
Log: Init: Running FreeCADGuiInit.py start script...
Log: Init: Searching modules...
Log: Init: Initializing /usr/lib/freecad/Mod/Machining_Distortion... done
Log: Init: Initializing /usr/lib/freecad/Mod/Sketcher... done
Log: Init: Initializing /usr/lib/freecad/Mod/ReverseEngineering... done
Log: Init: Initializing /usr/lib/freecad/Mod/Image... done
Log: Init: Initializing /usr/lib/freecad/Mod/PartDesign... done
Log: Init: Initializing /usr/lib/freecad/Mod/Ship... done
Msg: matplotlib not found, Plot module will be disabled
Log: Init: Initializing /usr/lib/freecad/Mod/Plot... done
Log: Init: Initializing /usr/lib/freecad/Mod/MeshPart... done
Log: Init: Initializing /usr/lib/freecad/Mod/OpenSCAD... done
Log: Init: Initializing /usr/lib/freecad/Mod/Start... done
Log: Init: Initializing /usr/lib/freecad/Mod/Draft... done
Log: Init: Initializing /usr/lib/freecad/Mod/Test... done
Log: Init: Initializing /usr/lib/freecad/Mod/Import... done
Log: Init: Initializing /usr/lib/freecad/Mod/Assembly... done
Log: Init: Initializing /usr/lib/freecad/Mod/Complete... done
Log: Init: Initializing /usr/lib/freecad/Mod/Web... done
Log: Init: Initializing /usr/lib/freecad/Mod/Raytracing... done
Log: Init: Initializing /usr/lib/freecad/Mod/Mesh... done
Log: Init: Initializing /usr/lib/freecad/Mod/Part... done
Log: Loading Part module... done
Msg: pycollada not found, collada support will be disabled.
Log: Init: Initializing /usr/lib/freecad/Mod/Arch... done
Log: Init: Initializing /usr/lib/freecad/Mod/Robot... done
Log: Init: Initializing /usr/lib/freecad/Mod/Points... done
Log: Init: Initializing /usr/lib/freecad/Mod/Idf(InitGui.py not found)... ignore
Log: Init: Initializing /usr/lib/freecad/Mod/Inspection... done
Log: Init: Initializing /usr/lib/freecad/Mod/Drawing... done
Log: Init: Loading FreeCAD GUI
Log: Init: Running FreeCADGuiInit.py start script... done
Log: Init: Activating default workbench StartWorkbench
Log: Loading GUI of Web module... done
Log: Loading GUI of Start module... done
Log: Loading Start module... done
Log: void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Toggle visibility" under id 222
Log: Init: Showing main window
Log: Main window restored
Log: Show main window
Log: Toolbars restored
Log: Couldn't connect to spacenav daemon
Log: Init: Entering event loop
Log: Init: Processing command line files
Log: Active view is Unnamed : 1
  • (at 0x196a890)
    Log: Active document is Unnamed (at 0x403a450)
    Log: Loading Draft module...done
    Msg: Draft workbench activated
    Msg: Pick first point:
    Msg: Pick opposite point:
    Msg: Log: Loading GUI of Part module... done
    Log: Sel : Clear selection
    Log: Sel : Add Selection "Unnamed.Rectangle.(null)(0.000000,0.000000,0.000000)"
    Msg: Pick first point:
    Msg: Pick next point:
    Log: Sel : Clear selection
    Log: Sel : Add Selection "Unnamed.Rectangle.Edge5(48.028969,100.000000,0.000000)"
    Msg: Log: Sel : Clear selection
    Log: Sel : Add Selection "Unnamed.Line.(null)(0.000000,0.000000,0.000000)"
  • yorik

    2013-07-06 00:21

    administrator   ~0003333

    Is this issue still a problem with a recent version? I was never able to reproduce it...

    yorik

    2013-12-20 21:22

    administrator   ~0003958

    Closing because there is no more feedback on this issue.

    Issue History

    Date Modified Username Field Change
    2013-04-19 10:15 dubstar-04 New Issue
    2013-04-19 14:00 yorik Note Added: 0003077
    2013-04-19 14:02 yorik Status new => assigned
    2013-04-19 14:02 yorik Assigned To => yorik
    2013-04-19 14:17 yorik Status assigned => feedback
    2013-04-19 15:07 dubstar-04 Note Added: 0003078
    2013-04-19 15:27 yorik Note Added: 0003079
    2013-04-19 19:22 dubstar-04 Note Added: 0003080
    2013-04-20 17:45 dubstar-04 Note Added: 0003088
    2013-07-05 22:11 yorik Project FreeCAD => Draft
    2013-07-06 00:21 yorik Note Added: 0003333
    2013-12-20 21:22 yorik Note Added: 0003958
    2013-12-20 21:22 yorik Status feedback => closed
    2013-12-20 21:22 yorik Resolution open => fixed
    2013-12-20 21:22 yorik Fixed in Version => 0.14