View Issue Details

IDProjectCategoryView StatusLast Update
0000011FreeCADBugpublic2009-10-17 21:46
ReporterJriegelAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformBSD/MacOsXOSMacOsXOS Version
Product Version0.8 
Target VersionFixed in Version 
Summary0000011: MacOsX
DescriptionBuild is failing on FreeBSD/Mac OS X when looking for the boost libraries
locate in /opt/local/lib. These libraries have been confirmed to exist.
TagsNo tags attached.

Activities

Jriegel

2009-09-28 10:49

administrator   ~0000013

rosinflux:

Please ignore the .c extension on the Makefile. It's an artifact from when
I was trying to get it to upload in the forums, it was not there on build.

Jriegel

2009-09-28 10:50

administrator   ~0000014

wmayer:

Just an idea: The guy who successfully built the FreeCAD sources had to
rerun autogen.sh in order to fix some libtool issues. Instead of using
libtoolize the tool glibtoolize is used which is called in autogen.sh.

So, just run ./autogen.sh. Maybe you need some .m4 macros from 3rd party
libs like Coin and SoQt.

I have checked your Makefile which seems to be okay. The lib search path
/opt/local/lib is listed where your boost libs are installed. But the
search path doesn't appear when linking FreeCADBase. So, it could really be
a libtool issue.

Issue History

Date Modified Username Field Change
2009-09-28 10:49 Jriegel New Issue
2009-09-28 10:49 Jriegel Status new => assigned
2009-09-28 10:49 Jriegel Assigned To => wmayer
2009-09-28 10:49 Jriegel Note Added: 0000013
2009-09-28 10:50 Jriegel Note Added: 0000014
2009-10-17 21:46 wmayer Status assigned => closed
2009-10-17 21:46 wmayer Resolution open => fixed