View Issue Details

IDProjectCategoryView StatusLast Update
0001041GCS[Sketcher] Featurepublic2018-04-27 21:42
Reporternaught101Assigned Tochrisb 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version0.12 
Target VersionFixed in Version 
Summary0001041: Highlight unconstrained features of a sketch
DescriptionWhen you have a complex sketch with lots of constraints, but with a few degrees of freedom, it is sometime nearly impossible to figure out which parts are not constrained. It would be great if it were possible to somehow highlight vertices or edges that are not constrained, temporarily, so that appropriate constraints can be added.
Tagscolors, constraints, Solver

Relationships

duplicate of 0000704 assignedabdullah Sketcher Fully constrained report based on primitives (Lines, arcs) 
related to 0002069 assignedabdullah Display which parts of a sketch are fully constrained. 

Activities

wmayer

2014-08-14 21:07

administrator   ~0004947

Here is a macro that could be useful: http://forum.freecadweb.org/viewtopic.php?f=22&t=7340

Kunda1

2017-05-02 21:26

administrator   ~0008859

@Abdullah can you weigh in on this ticket?

abdullah

2017-05-03 12:37

manager   ~0008878

The issue with "show me what is fully constraint" or "show me what is not fully constraint" is the same issue.

I discussed with a user that seemed interested in the problem here:
https://forum.freecadweb.org/viewtopic.php?f=10&t=21882&hilit=constraint

I do not have a full solution in my head at the moment, but it sounds feasible. I have been tempted to give it a go several times.

Currently it is not in my priority list. Eventually if nobody does it I will give it a go.

tokiop

2017-06-26 12:29

reporter   ~0009533

Hi ! As a user I looked for this feature multiple times. The progressive highlight described in 0000704 and 0002069 sounds really great and intuitive !

chrisb

2018-04-27 21:42

developer   ~0011214

Duplicate of 0000704 and 0002069

Issue History

Date Modified Username Field Change
2013-03-02 07:10 naught101 New Issue
2013-03-08 20:04 logari81 Relationship added duplicate of 0000704
2013-03-08 20:04 logari81 Status new => assigned
2013-03-08 20:04 logari81 Assigned To => logari81
2013-03-08 20:05 logari81 Project FreeCAD => Sketcher
2014-08-14 21:07 wmayer Note Added: 0004947
2017-04-02 08:56 kkremitzki Assigned To logari81 =>
2017-04-02 08:56 kkremitzki Status assigned => new
2017-05-02 21:26 Kunda1 Note Added: 0008859
2017-05-03 12:37 abdullah Note Added: 0008878
2017-06-26 12:29 tokiop Note Added: 0009533
2017-06-26 12:34 Kunda1 Relationship added related to 0002069
2017-06-26 12:35 Kunda1 Tag Attached: colors
2017-06-26 12:35 Kunda1 Tag Attached: constraints
2017-09-27 12:11 Kunda1 Tag Attached: Solver
2017-12-13 15:20 Kunda1 Project Sketcher => GCS
2018-04-27 21:42 chrisb Assigned To => chrisb
2018-04-27 21:42 chrisb Status new => closed
2018-04-27 21:42 chrisb Resolution open => duplicate
2018-04-27 21:42 chrisb Note Added: 0011214