Base ExampleCommandModel.png Tutorial

Topic
{{{Topic}}}
Level
Intermediate
Time to complete
20 minutes
Author
piffpoof
FreeCAD version
0.14 or above
Example File(s)
[1] example data set #1

[2] example data set #2

[3] example data set #3

[4] example data set #4

[5] example data set #5



Introduction

This tutorial is meant to introduce the reader to the basic workflow of the Part Workbench to make a model. This will be done using the Thickness tool and Boolean operations of the Part workbench,

Tutorial example screen snapshot.jpg

Problem Background

We're going to construct a model of a housing for a lock - like the lock on a door. After looking at the task, we have decided we will make this in 3 pieces:

  • a plate at the back of the lock housing
  • the sides of the lock housing
  • the front plate of the lock housing which will have the aperture through which the key passes

And because this is a Part workbench tutorial, we will use the Part workbench.

Preparation

FreeCAD has numerous facilities and features. To make our work easier in this tutorial, we need to make sure some of them are visible. From the menu bar at the top of the screen select the option View->Views->Combo View. This will produce the Combo View which is a browser with two panes, one above the other. The upper pane has two tabs Model and Tasks - select Model. The lower pane also has two tabs View and Data - select Data.

Viewing Work in Progress

While working through the tutorial, utilise the Standard View icons built into FreeCAD which will allow you to manipulate your viewpoint and so therefore better see what is being done. The icons are: View-zoom-all.svg, View-zoom-selection.svg, View-axometric.svg, View-front.svg, View-top.svg, View-right.svg, View-rear.svg, View-bottom.svg, View-left.svg all of which are described on the page Standard View Menu. Manipulating the viewpoint does not effect any of the objects being constructed. The very nature of 3-dimensional modeling means that often some of the result of an operation will be on an aspect of the model not currently visible. Judicious use of the viewpoint allows the modeler to fully appreciate the model being developed.

Creating the Lock Housing

  1. Switch to the Workbench Part.svg Part workbench.
  2. Click on Document-new.svg to create a new document.
  3. Click on Part Box.svg Cube, a new cube will be created at the origin.
  4. In the Combo View click on the Cube and press Return.
  5. Now enter the text solid lock housing and press Return.
  6. In the bottom pane of the Combo View, click to the left of the Placement, Angle, Axis and Position should become visible.
  7. Click to the left of Position, x, y, and z should become visible.
  8. In the x field, either enter -30 or use the small arrows to the right to decrement the existing value (which will be 0).
  9. In the y field either enter -40 or use the small arrows to the right to decrement the existing value (which will be 0).
  10. In the z field either enter 0 or use the small arrows to the right to increment the existing value (which will be 0).
  11. In the Length field, enter 60.
  12. In the Width field, enter 80.
  13. In the Height field, enter 32.
  14. Click on Part Thickness.svg Part Thickness, a dialogue will appear.
  15. In the Thickness field, enter -2.
  16. In the Mode field, select Skin.
  17. In the Join Type field, select Intersection.
  18. Press Return.
  19. Save your work: select the menu option File->Save, or click the Document-save.svg Save icon; or press Command-S.

Note: you can save your work at any time in FreeCAD, either in the Sketcher or not, by clicking the Save button.

Creating the Lock Housing Lid

  1. Click on Part Box.svg Cube, a new cube will be created at the origin.
  2. In the Combo View click on the Cube and press Return.
  3. Now enter the text lock housing lid and press Return.
  4. In the bottom pane of the Combo View, click to the left of the Placement, Angle, Axis and Position should become visible.
  5. Click to the left of Position, x, y, and z should become visible.
  6. In the x field, either enter -30 or use the small arrows to the right to decrement the existing value (which will be 0).
  7. In the y field either enter -40 or use the small arrows to the right to decrement the existing value (which will be 0).
  8. In the z field either enter 30 or use the small arrows to the right to increment the existing value (which will be 0).
  9. In the Length field, enter 60.
  10. In the Width field, enter 80.
  11. In the Height field, enter 2.
  12. Save your work: select the menu option File->Save, or click the Document-save.svg Save icon; or press Command-S.

Creating the Cutouts

  1. Click on Part Cylinder.svg Cylinder, a new cylinder will be created at the origin.
  2. In the Combo View click on the Cylinder and press Return.
  3. Now enter the text key ashaft aperature and press Return.
  4. In the bottom pane of the Combo View, click to the left of the Placement, Angle, Axis and Position should become visible.
  5. Click to the left of Position, x, y, and z should become visible.
  6. In the x field, either enter 0 or use the small arrows to the right to decrement the existing value (which will be 0).
  7. In the y field either enter 10 or use the small arrows to the right to decrement the existing value (which will be 0).
  8. In the z field either enter 0 or use the small arrows to the right to increment the existing value (which will be 0).
  9. In the Radius field, enter 5.
  10. In the Height field, enter 32.
  11. Click on Part Box.svg Cube, a new cube will be created at the origin.
  12. In the Combo View click on the Cube and press Return.
  13. Now enter the text lock housing lid and press Return.
  14. In the bottom pane of the Combo View, click to the left of the Placement, Angle, Axis and Position should become visible.
  15. Click to the left of Position, x, y, and z should become visible.
  16. In the x field, either enter -1.5 or use the small arrows to the right to decrement the existing value (which will be 0).
  17. In the y field either enter -15 or use the small arrows to the right to decrement the existing value (which will be 0).
  18. In the z field either enter 30 or use the small arrows to the right to increment the existing value (which will be 0).
  19. In the Length field, enter 3.
  20. In the Width field, enter 25.
  21. In the Height field, enter 2.
  22. Save your work: select the menu option File->Save, or click the Document-save.svg Save icon; or press Command-S.

Using Booleans for the Final Model

  1. In the Combo View single-click the empty lock housing in the Combo View to select it
  2. Holding down Command, single-click on the following objects to select them:
    • lock housing lid
  3. Click on Part Union.png Union to fuse the 2 objects into one object. Notice that the resultant is another object called something like 'Fusion'. The objects that were used to form the result are encapsulated within the resulting object. Click to the left of 'Fusion" to view the objects used to form it.
  4. In the Combo View click on the Fusion and press Return.
  5. Now enter the text lock housing with lid and press Return.
  6. Single-click the 'lock housing with lid' in the Combo View to select it
  7. Holding down Command, single-click on 'key shaft aperature' to select it.
  8. Click on Part Cut.svg Cut to cut the second object from the first. Notice that the resultant is another object called something like 'Cut'. The two objects that were used to form the result are encapsulated within the resulting object. Click to the left of 'Cut" to view the 2 objects used to form it.
  9. Single-click the object 'Cut' just created
  10. Holding down Command, single-click on 'key teeth aperature' to select it.
  11. Click on Part Cut.svg Cut to cut the second object from the first. Notice that the resultant is another object called something like 'Cut001'. The two objects that were used to form the result are encapsulated within the resulting object - one being the resultant from the first cut operation.
  12. In the Combo View click on the second Cut resultant and press Return.
  13. Now enter the text lock housing and press Return.
  14. Save your work: select the menu option File->Save, or click the Document-save.svg Save icon; or press Command-S.

Results

The objects we have created now constitute the housing for a lock.

There is an example data set #4 which has the results so far. You can download this and compare it to your own results. Certain things like the positioning of labels on the Sketches may change depending on zoom levels. So your the positioning of your labels may differ but the dimensions and the list of Constraints should be identical.

Further Ideas

  • Create a key to fit this lock (see tutorial XXX)
  • Model some working of real lock inside our lock housing - now that would be complex!

Summary

We used the following tools in this tutorial:

Further Information

To Do On Tutorial

  • 0.16 specific changes
    • View->Views->Combo View becomes View->Panels->Combo View