You might be interested by FreeCAD because you already have some technical drawing experience, for example with software like AutoCAD. Or you already know something about design, or you prefer to draw things before building them. In either cases, FreeCAD features a more traditional workbench, with tools found in most 2D CAD applications: The Draft Workbench.

The Draft Workbench, although it adopts ways of working inherited from the traditional 2D CAD world, is not limited at all to the 2D realm. All its tools work in the whole 3D space and many of the Draft tools, for example Draft Move.png Move or Draft Rotate.png Rotate, are commonly used all over FreeCAD because they are often more intuitive than changing placement parameters manually.

Among the tools offered by the Draft Workbench, you will find traditional drawing tools like Draft Line.png Line, Draft Circle.png Circle, or Draft Wire.png Wire (polyline), modification tools like Draft Move.png Move, Draft Rotate.png Rotate or Draft Offset.png Offset, a working plane/grid system that allows you to define precisely in which plane you are working, and a complete snapping system that makes it very easy to draw and position elements precisely in relation to each other.

To showcase the working and possibilities of the Draft Workbench, we will walk through a simple exercise, the result of which will be this little drawing, showing the floor plan of a small house that contains only a kitchen top (A pretty absurd floor plan, but we can do what we want here, can't we?):

Exercise cabin 01.jpg

  • Switch to the Draft Workbench
  • As in all technical drawing applications, it is wise to set up your environment correctly, it will save you a lot of time. Configure the grid and working plane, Text and Dimension settings to your likings in menu Edit -> Preferences -> Draft. In this exercise, however, we will act as if these preference settings were left to their default values.

Freecad draft options 01.jpg

  • The Draft Workbench also has two special toolbars: One with visual settings, where you can change the current working plane, turn construction mode on/off, set the line color, face color, line weight and text size to be used for new objects, and another one with snap locations. There, you can turn the grid on/of and set/unset individual Snap locations:

Draft toolbars.jpg

  • Let's start by turning construction mode on, which will allow us to draw some guidelines on which we will draw our final geometry.
  • If you wish, set the working plane to XY. If you do this, the working plane won't change, no matter the current view. If not, the working plane will adapt automatically to the current view, and you should take care of staying in top view whenever you want to draw on the XY (ground) plane.
  • Then, select the Draft Rectangle.png Rectangle tool and draw a rectangle, starting at point (0,0,0), of 2 meters by 2 meters (leave the Z at zero). Note that most of the Draft commands can be fully performed from the keyboard, without touching the mouse, using their two-letter shortcut. Our first 2x2m rectangle can be done like this: re 0 Enter 0 Enter 0 Enter 2m Enter 2m Enter 0 Enter.
  • Duplicate that rectangle by 15cm inside, using the Draft Offset.png Offset tool, turning its Copy mode on, and giving it a distance of 15cm:

Exercise cabin 02.jpg

  • We can then draw a couple of vertical lines to define where our doors and windows will be placed, using the Draft Line.png Line tool. The crossing of these lines with our two rectangles will give us useful intersections to snap our walls to. Draw the first line from point (15cm, 1m, 0) to point (15cm, 3m, 0).
  • Duplicate that line 5 times, using the Draft Move.png Move tool with Copy mode turned on. Turn also the Relative mode on, which will allow us to define movements in relative distances, which is eaier than calculate the exact position of each line. Give each new copy any start point, you can leave it at (0,0,0) for example, and the following relative endpoints:
    • line001: x: 10cm
    • line002: x: 120cm
    • line003: x: -55cm, y: -2m
    • line004: x: 80cm
    • line005: x: 15cm

Exercise cabin 03.jpg

  • That is all we need now, so we can switch construction mode off. Check that all the construction geometry has been placed into a "Construction" group, which makes it easy to hide it all at once or even delete it completely later on.
  • Now let's draw our two wall pieces using the Draft Wire.png Wire tool. Make sure the Snap Intersection.png intersection snap is turned on, as we will need to snap to the intersections of our lines and rectangles. Draw two wires as follow, by clicking all the points of their contours. To close them, either click onthe first point again, or press the Close button:

Exercise cabin 04.jpg

  • We can change their default grey color to a nice hatch pattern, by selecting both walls, then setting their Pattern property to Simple, and their Pattern size to your liking, for example 0.005.

Exercise cabin 05.jpg

  • We can now hide the construction geometry by right-clicking the Construction group and choose Hide Selection.
  • Let's now draw the windows and doors. Make sure the Snap Midpoint.png midpoint snap is turned on, and draw six lines as follow:

Exercise cabin 06.jpg

  • We will now change the door line to create an opened door symbol. Start by rotating the line using the Draft Rotate.png Rotate tool. Click the enpoint of the line as rotation center, give it a start angle of 0, and an end angle of -90.
  • Then create the opening arc with the Draft Arc.png Arc tool. Pick the same point as the rotation center we used in the previous step as center, click the other point of the line to give the radius, then the start and end points as follow:

Exercise cabin 07.jpg

  • We can now start placing some furniture. To begin with, let's place a counter by drawing a rectangle from the upper left inner corner, and giving it a width of 170cm and a height of -60cm. In the image below, the Transparency property of the rectangle is set to 80%, to give it a nice furniture look.
  • Then let's add a sink and a cooktop. Drawing these kinds of symbols by hand can be very tedious, and they are usually easy to find on the internet, for example on http://www.cad-blocks.net . In the Downloads section below, for convenience, we separated a sink and a cooktop from this site, and saved them as DXF files.You can download these two files by visiting the links below, and right-clicking the Raw button, then choosing save as.
  • Inserting a DXF file into an opened FreeCAD document can be done either by choosing the File -> Import menu option, or by dragging and dropping the DXF file from your file explorer into the FreeCAD window. The contents of the DXF files might not appear right on the center of your current view, depending on where they were in the DXF file. You can use menu View -> Standard views -> Fit all to zoom out and find the imported objects. Insert the two DXF files, and move them to a suitable location on the tabletop:

Exercise cabin 08.jpg

  • We can now place a couple of dimensions using the Draft Dimension.png Dimension tool. Dimensions are drawn by clicking 3 points: the start point, an end point, and a third point to place the dimension line. To make horizontal or vertical dimensions, even if the two first points are not aligned, press Shift while clicking the second point.
  • You can change the position of a dimension text by double-clicking the dimension in the tree view. A control point will allow you to move the text graphically. In our exercise, the "0.15" texts have been moved away for better clarity.
  • You can change the contents of the dimension text by editing their Override property. In our example, the texts of the door and windows dimensions have been edited to indicate their heights:

Exercise cabin 09.jpg

  • Let's add some description texts using the Draft Text.png Text tool. Click a point to position the text, then enter the lines of text, pressing Enter after each line. To finish, press Enter twice.
  • The indication lines (also called "leaders") that link the texts to the item they are describing are simply done with the Wire tool. Draw wires, starting from the text position, to the place being described. Once that is done, you can add a bullet or arrow at the end of the wires by setting their End Arrow property to True

Exercise cabin 10.jpg

  • Our drawing is now complete! Since there begins to be quite a number of objects there, it would be wise do some cleaning and place everything in a nice structure of groups, to make the file easier to understand to another person:

Exercise cabin 11.jpg

  • We can now print our work by placing it on a Drawing sheet, which we will show further in this manual, or directly export our drawing to other CAD applications, by exporting it to a DXF file. Simply select our "Floor plan" group, select menu File -> Export, and select the Autodesk DXF format. The file can then be opened in any other 2D CAD application such as LibreCAD. You might notice some differences, depending on the configurations of each application.

Exercise cabin 12.jpg

  • The most important thing about the Draft Workbench, however, is that the geometry you create with it can be used as a base or easily extruded into 3D objects, simply by using the Part Extrude.png Part_Extrude tool from the Part Workbench, or, to stay in Draft, the Draft Trimex.png Trimex (Trim/Extend/Extrude) tool, which under the hood performs a Part Extrusion, but does it "the Draft way", that is, allows you to indicate and snap the extrusion length graphically. Experiment extruding our walls as shown below.
  • By pressing the Draft SelectPlane.png working plane button after selecting a face of an object, you are also able to place the working plane anywhere, and therefore draw Draft objects in different planes, for example on top of the walls. These can then be extruded to form other3D solids. Experiment setting the working plane on one of the top faces of the walls, then draw some rectangles up there.

Exercise cabin 13.jpg

  • All kinds of openings can also be done as easily by drawing Draft objects on the faces of walls, then extruding them, then using the boolean tools from the Part Workbench to subtract them from another solid, as we saw in the previous chapter.

Fundamentally, what the Draft Workbench does is provide graphical ways to create basic Part operations. While in Part you will usually position objects by setting their placement property by hand, in Draft you can do it on-screen. There are times when one is better, other times when the other is preferable. Don't forget, you can create custom toolars in one of these workbenches, add the tools from the other, and get the best of both worlds.

Downloads

Read more

Other languages:
English • ‎italiano • ‎русский