Base ExampleCommandModel.png Tutorial

Topic
Programming
Level
Medium programmer
Time to complete
15 minutes
Author
Mario52
FreeCAD version
All
Example File(s)
None


Description

This short tutorial will show you how to install and use FreeCAD Macros.

This tutorial was made on the Windows platform so a small adjustment may be necessary for other systems. It was updated to cover the Macintosh platform.

Python

Python is a programming language which is very simple to use and very fast to learn.

Python files have a file extension of .py while FreeCAD macros (which are also Python files) use the file extension .FCMacro. The Macro facility of FreeCAD can also execute files with the extension .py. Python was invented by Guido Van Rossun

The Macro Menu and Toolbar Icons

record Launch Record stop Stop Record open editor Open Menu macro execute Execute start Debug Macro stop Stop

Location and destination of macros

This section shows you how to locate the folder containing your FreeCAD macros.

1 : click Menu > Macro > Macros (which has the icon Std DlgMacroExecuteDirect.svg and the tool tip "Open a dialog to let you execute a recorded macro")

Dxf Importer Install 01.png

2 : This will open a dialog box

3 : The address of "Macro destination" (C:\Users\your_user_name\AppData\Roaming\FreeCAD\ in the screen snapshot below)

  • Windows: the form is usually drive:\Users\your_user_name\AppData\Roaming\FreeCAD\
  • Ubuntu: the form is usually /home/your_user_name/.FreeCAD
  • Macintosh: the form is usually "/Users/your_user_name/Library/Preferences/FreeCAD"

4 : copy the address of "Macro destination" (here C:\Users\your_user_name\AppData\Roaming\FreeCAD\)

Dxf Importer Install 02.png

5 : View the macro folder by:

  • Windows: paste the address into your browser and confirm
  • Macintosh: locate the folder in the Finder or paste the address into a browser (remember the "file:///" prefix in the browser for a file on disk)
Dxf Importer Install 03.png

6 : Access the files by:

  • Windows: leave open the file explorer
  • Macintosh: either leave a Finder window open, or bookmark the location in your browser, or set up an Alias to point to it, or drag the folder into the SideBar of the Finder so it is there to use from other programs such as text editors etc. (Note: version 0.14 of FreeCAD does not support Aliases but does support the SideBar)
Dxf Importer Install 04.png


Section to read if you are not familiar with Python programming (common mistakes copy/paste).

The indentation errors examples wrong code

The indentation in the python programming is very important and integral part of the code, a space or an inappropriate shift causes an indentation error ex :

<unknown exception traceback><type 'exceptions.IndentationError'>: ('expected an indented block', ('C:/Users/d/AppData/Roaming/FreeCAD/Macro_Apothem_Based_Prism_GUI.FCMacro', 21, 3, 'def priSm(self):\n'))

gives the error returned 'expected an indented block' block indentation expected to line 21, 3, normal after a class p (): must be the next line an indentation at least one space.

1 : In this example, the code was stuck without any indentation and of course does not work! here definitely a programmer error when pasting the code on the page as it would have never known it to work.

the code was stuck without any indentation

2 : the code was correct indentations in the right place.

the code was correct indentations in the right place

3 : we select the code, and we see that the selection is at the edge of the code, the macro must works so good

the macro must works so good

4 : Here additional space is selected (it can happen) then you need to copy the code into a word processor to remove one space all lines

remove one space all lines

5 : Here the code has been copied in a forum window with the Select all button apparently the selection is good

Here the code has been copied in a forum

6 : But the selection pasted into the FreeCAD editor gives a surprise, an indent of four spaces has been added by the system ? the code is not good

But the selection pasted into the FreeCAD editor gives a surprise

7 : You must delete all the extra space that is four spaces on each line, for Windows word processing notepad-plus-plus enables vertical selection with a combination of buttons Alt + Mouse dragging or Menu> Edit> Indent> Decrease the indentation

You must delete all the extra space

8 : Here the selection also take the column numbers which will also give an error

Here the selection also take the column numbers

9 : Perfect code.

Perfect code


Method 1:

Method copy the code in one window and paste in the FreeCAD editor

For example we will copy the macro Part Prism Apothem.svg Macro_Apothem_Based_Prism_GUI

If there are one or more icon (s) download also position your mouse over the icon, click the right mouse button and click "Save image as ..." the icon or icons are placed in the macro directory and one of these icons serve as a shortcut icon to place on the toolbar.

Download icon

After copying your code we will paste the code in FreeCAD editor.

1 : Open FreeCAD and open the editor in FreeCAD

Dxf Importer Install 01.png

2 : The window macros file opens, click Create button

The window macros file opens

3 : A new window opens, enter the macro name (here "Macro_Apothem_Based_Prism_GUI")and click the create Ok button

enter the macro name

4 : The editing window FreeCAD macros is now available and has the name of our future macro.

The editing window FreeCAD macros

5 : Paste your code in the macro editor window and click the little cross to close the window.

close the window

6 : A warning window appears asking for confirmation of save code, click on Yes

PS: For the change silk consideration must save the macro and reopen it and just run it.

A warning window appears asking for confirmation of save code

7 : Repeat the number 1 : , Click on your new macro and button Execute

Click on your new macro and button Execute

8 : The macro runs, complete the fields with your values and click the OK button

The macro runs, complete the fields

9 : The macro returns an error ! we do not have to open document, open a document Document-new.svg and repeat the operation 7 and 8. Some macros open a new document if it does not find one.

The macro returns an error!

10 : Here is your prism

your prism

11 : You can also open your macro in the editor to run or modify, click the Edit button

You can also open your macro in the editor

12: The macro is now in the FreeCAD editor you can run through the menu "Macro Run Macro" or by clicking on the triangle Macro-execute.svg green in the macros toolsbar

The macro is now in the FreeCAD editor

Method 2:

Method macro in a compressed .ZIP file

Download the file compressed here (example) Macro_screw_maker 1.7. (the page Macro_screw_maker)

Free for Windows 7-zip ou L-Zarc ou quickzip

For Linux use this on the terminal

unzip your_file.zip -d your_directory 

you must unzip the zip and copy the file (or all the files and folders) in your macro directory.

Process

1 : Download your file in your local folder here the folder Temp

Download your file in your local folder here the folder Temp

2 : Unzip your file in the folder.

Unzip your file in the folder.

3 : The decompressor finished his work and created a new folder with the unpacked file

The decompressor finished his work and created a new folder with the unpacked file

4 : Enter in the newly created directory, move about the file, click the right mouse button and click on Cut.

Enter in the newly created directory

5 : Return to your browser remained open in the macro location (here C:\Users\your_user_name\AppData\Roaming\FreeCAD\) and close the browser.

Return to your browser remained open

6 : Open FreeCAD click Menu > Macro > Macros or the click the bottom Std DlgMacroExecuteDirect.svg "Open a dialog to let you execute a macro Recorded"

Open FreeCAD

7 : The macros window open , select your macro and click the button Execute

The macros window open

8 : Your macro is executed enter the data and click the Create button

Your macro is executed

9 : Whaouu

Whaouu

Section if the text are not display:

For those who see no information is displayed.

Some macros display information on the screen in general they are displayed in the report view.

FreeCAD use two methods to display the information in the window view report.

1 : Commands

App = FreeCAD
App.Console.PrintMessage ("Hello World ! \n")
App.Console.PrintError ("Hello World ! \n")
App.Console.PrintWarning ("Hello World ! \n") 

or

FreeCAD.Console.PrintMessage ("Hello World ! \n")
FreeCAD.Console.PrintError ("Hello World ! \n")
FreeCAD.Console.PrintWarning ("Hello World ! \n") 

or

print "Hello World !" 

To see the information displayed in the console you should:

1 : Open FreeCAD

Open FreeCAD

2 : Click the View menu and Views

Click the View menu and Views

3 : Check Report View and Python Console

Check Report View and Python Console

4 : the windows are enabled and available commands like "App.Console.PrintMessage" is configured to the "Report View"

Hello World!


2 : command "print" which is a Python command.

It is possible that this command does not display the expected string.

For information to be displayed in the window do this :

1 : Click the Edit menu and then Preferences

Edit menu

2 : In the new window, click General, and select the Output window tab

General

3 : check both boxes:

Case a cocher O.png Redirect internal Python output to Report view

Case a cocher O.png Redirect internal Python errors to Report view

and click the OK button

Redirect internal

4 : the setup is complete you should see all.

the setup is complete

End tutorial good job.

Links

The Macros recipes page

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎русский • ‎svenska