Base ExampleCommandModel.png Tutorial

Topic
Blueprints / Drawings
Level
Beginner
Time to complete
15 minutes
Author
Drei
FreeCAD version
0.16 or above
Example File(s)


Introduction

This tutorial is meant to introduce the reader to the basic workflow of the Drawing Workbench, as well as most of the tools that are available to create blueprints.

Drawing tutorial result.png

Requirements

  • FreeCAD version 0.16 or above
  • The reader has the basic knowledge to use the Part and PartDesign Workbenches
  • The reader has finished the Draft tutorial

Procedure

Preparations

To reduce the time required for this tutorial, it is compulsory to group together similar elements in the Tree View to apply operations at the same time to several elements.

Grouping elements
  1. In the Tree View, right-click on the name of the document. In this case Unnamed.
  2. Select Create group. You can alter the name of the group by double clicking on it from the Tree View.
  3. Select the elements that you wish to add and drag them into the group

Create the following groups:

  • Draft_objects
  • Draft_dimensions
  • Draft_annotations_text

Drawing Templates

Templates are the base for the creation of Drawings, you can use the templates provided or create your own.

  1. Slect the dropdown menu next to Drawing Landscape A3.png New A3 landscape drawing
  2. Select A4 Landscape

We now have a folder called Page in the Tree View. This object will contain everything related to the Drawing.

Projections

Projections are defined as the visual representation of an object on a specific plane, it diplays the properties of the object that are visible from that specific orientation.

Orthographic Projections

These are used in Engineering to specify the properties of an object that will be machined. There are two common standards: Third Angle and First Angle projections.

For this tutorial, these projections aren't used because our objects only have a meaningful representation in the XY plane.

  1. Select the object you wish to project into the drawing.
  2. Select Drawing Orthoviews.png Ortho Views
  3. Select the type of projection you want to use
  4. Selec the view you want to add

In the General and Axonometric tabs you can specify the location, scale and separation of each view.

Other Part Projections

It is possible to create custom views of the object.

  1. Select the object you wish to project into the drawing.
  2. Select Drawing View.png Insert a view
  3. In the Data tab edit the Direction of the Shape View by altering the values for the X, Y, and Z axes. By default, the values are (0, 0, 1)

You can also alter the location, scale and rotation of the View from within the Data tab. The same can be done for the Orthographic Projections.

Draft Projections

The preferred way to add elements created in the Draft Workbench is with a tool contained in the Draft Workbench designed specifically for this. With this procedure, it is possible to import Dimensions, Annotations, Shapestrings and any other element created whithin the Draft Workbench.

  1. Switch to the Draft Workbench
  2. Select the group or elements that you wish to project. In this case Draft_dimensions
  3. Select Draft PutOnSheet.png Drawing
  4. Edit the X and Y coordinates to (140,100)
  5. Set the scale to 0.5

Repeat for each group and set the values to the ones specified above.

Exporting your work

FreeCAD supports the export of SVG and PDF files based on your Drawings

SVG
  1. Select Drawing Save.png Save sheet
  2. Specify the path and name of the exported file
PDF
  1. In the File menu, select Export PDF ...
  2. Specify the path and name of the exported file

We are now finished with the basic workflow for the Drawing Module.

Recommended Reading


Other languages:
Deutsch • ‎English • ‎italiano • ‎русский