Base ExampleCommandModel.png Tutorial

Topic
Drafting
Level
Beginner
Time to complete
20 minutes
Author
Drei
FreeCAD version
0.16 or above
Example File(s)


Introduction

This tutorial is meant to introduce the reader to the basic workflow of the Draft Workbench, which includes the creation of profiles, the use of working planes, and the creation of dimensions, text and annotations. This tutorial uses the notation (X, Y, Z) to denote the coordinates required to define points in an object.

Draft tutorial result.png

Requirements

  • FreeCAD version 0.16 or above
  • The reader know how to use the Data and View tabs to change an element's properties if desired

Procedure

It is compulsory to make sure the Draft Snap toolbar will be available to use in this tutorial.

  1. Start FreeCAD
  2. If you haven't opened a new FreeCAD document (most of the FreeCAD window looks greyed-out), from the pull-down menu click File > New or click the Create A New Document tool Document-new.svg.
  3. Activate the Draft Workbench
  4. Select the Edit menu
  5. Click on Preferences
  6. Go to Draft and select the Grid and snapping tab
  7. Verify that the Show Draft Snap toolbar is active

Note that you can change the visibility of the Grid in this menu, in case you wish to disable it.

Using Planes

Planes are used to restrict the behaviour of the Draft tools to a specific plane, avoiding problems with the location of points and curves in complex workpieces. Planes can reference the axes of the coordinate system (XY, YZ, ...) or they can use a planar surface in the document as its reference.

  1. Select Draft SelectPlane.png Set working plane. It ca be located within the Draft workbench toolbar or inside the Draft menu in the Utilities division.
  2. Selec the XY plane

Creating Profiles

The creation of profiles can be done in several ways. Though it is possible to use simple arcs and lines to do most of the work, FreeCAD includes several tools to speed up the process.

Lines and Arcs
  1. Select Draft Arc.png Arc.
  2. Set the center at (0, 0, 0)
  3. Set the radius to 30 mm
  4. The starting angle is 60.0°
  5. The aperture is 60.0°

Repeat the same procedure for a second arc with a radius of 25 mm, the other properties remain unchanged.

We will now close the profile with a couple of lines.

  1. Select Draft Line.png Line.
  2. Approach the Endpoint of either arc. A white point should appear, alongside this icon Snap Endpoint.png when your cursor approaches the endpoint.
  3. Select the endpoint of the other arc.
  4. Repeat for the other side of the arcs.

We now have several curves that detail a profile, however it is still not recognized as a single entity. It is possible to continue working with the elements intact, though in this case we will fuse them into a single object.

The following actions will alter the way the objects behave, making it hard to edit their properties, so it is best to do any necessary modifications before proceding.

  1. Select an arc and a line while pressing the CTRL key
  2. Click on Draft Upgrade.png Upgrade

This will fuse both objects into a Wire. Repeat until the four elements are fused into a single Wire.


Planes, Rectangles and Circles
  1. Click Draft Rectangle.png Rectangle
  2. Set the first point on (-100, -60, 0)
  3. Set the second point on (140, 90, 0)

The result is a Plane. Its properties can be modified to remove the filling, by changing its Display Mode to Wireframe.

  1. Select Draft Circle.png
  2. Set the center to (0, 0, 0)
  3. Set the radius to 15 mm
Polygons
  1. Select Draft Polygon.png Polygon
  2. The center point is located at (0, 0, 0)
  3. Set the radius to 50 mm
  4. Set the number of sides to 6
Arrays

Arrays are used to replicate an object several times in a direction, a revolution axis or along a path.

  1. Select the Wire that was previously created
  2. Click Draft Array.png Array
  3. In the Data tab of the object, change the Array type from ortho to polar
  4. Change Number Polar from 1 to 3


Adding Dimensions

Dimensions require a constant use of Snapping Constraints to properly select the points that one wishes to dimension. The Snapping toolbar is used to change the possible points that can be selected.

  1. Select Draft Dimension.png Dimension
  2. Select the first point. This can be either an existing element or specified by coordintes. For this tutorial, the first point will alwaysvbe (0, 0, 0)
  3. Select the second point. Approach the midpoint of the top line of the polygon. A white point should appear alongside this icon Snap Midpoint.png
  4. Move the cursor to the desired location of the dimension and click on it.
  5. Change the font size on the View tab to 6 mm

Repeat the process for the arcs and circles.

Annotations and Text

There is a slight difference between the two: it is only possible to use the second one as a profile to perform 3D operations.

Annotations
  1. Select Draft Text.png Text
  2. Select the reference point in the 3D View. In this case, the midoint of the top arc.
  3. Enter your text and press Enter. Repeat for as many lines of text as you wish to input.
  4. Press Enter
Text
  1. Select Draft ShapeString.png ShapeString
  2. Select the reference point in the 3D View. This can be an existing point or the current cursor location.
  3. Enter your text and press Enter
  4. Set the desired font size
  5. Leave tracking at 0 mm
  6. Select the path to the font file that you wish to use

Creating Blueprints

To create blueprints, it is necessary to create a Drawing with the elements that you wish to use. Please read the Drawing tutorial for a detailed description.

We are now finished with the basic workflow for the Draft Module.

Recommended Lectures

  • For a detailed description of the workbench, please see Draft Module
  • To know more about the Snapping controls, see Draft Snap


Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎中文(繁體)‎