This page is a translated version of the page Basic modeling tutorial and the translation is 100% complete.

Base ExampleCommandModel.png Tutoriel

Tutoriel
Introduction to modelling
Niveau
Beginner
Temps d'exécution estimé
15 minutes
Auteur
Version de FreeCAD
Fichier(s) exemple(s)


Ce tutoriel d'introduction à la modélisation vous montrera comment modéliser un fer angle. Une chose à savoir, FreeCAD est modulaire, et comme pour plusieurs autres logiciels de CAO, il y a souvent plus d'une façon de faire les choses. Ici, nous explorerons deux méthodes.

Avant de commencer

Gardez en tête que FreeCAD est toujours à un stade précoce de développement, il est donc possible que vous ne soyez pas aussi productif qu'avec une autre application de CAO, et il est fort probable que vous rencontriez des bogues, ou subissiez des plantages. FreeCAD offre maintenant la possiblité de créer des fichiers de sauvegarde. Le nombre de ces fichiers peut être réglé dans le menu Édition > Préférences, onglet Document. N'hésitez pas à allouer deux ou trois fichiers de sauvegarde jusqu'à ce que vous soyez à l'aise avec FreeCAD.

Sauvegardez régulièrement votre travail, et de temps en temps, sauvegardez-le sous un nom différent afin d'avoir une copie sûre sur laquelle vous rabattre ; enfin, attendez-vous à la possibilité que certaines commandes ne vous donnent pas les résultats escomptés.

Introduction aux techniques de modélisation

La première technique (et celle de base) de la modélisation solide est la géométrie de construction de solides (GCS). Vous construisez votre géométrie à l'aide de formes primitives telles que des cubes, cylindres, sphères et cônes en les combinant, par soustraction d'une forme par une autre, ou par l'intersection de deux formes. Ces outils font partie de l'atelier Pièce. Vous pouvez également appliquer des transformations aux formes, par exemple des congés (arrondis) ou chanfreins à des arêtes. Ces outils sont également dans l'atelier Pièce.

Puis il y a des outils plus avancés. Vous commencez par dessiner une esquisse en 2D qu'ensuite vous extruderez ou ferez révolutionner.

Commençons par la création d'une patte en fer en L pour un établi, avec ces deux méthodes.

1st Method - By Constructive Solid Geometry

  • Start with the Part Workbench Switch PartWorkbench.JPG.
  • If you haven't opened a new FreeCAD document (most of the FreeCAD window looks greyed-out), from the pull-down menu click File > New or click the Create A New Document tool Document-new.png.
  • Click on the Part Box.png Box button to create a box
  • Change its dimensions by selecting it either in the 3D space, or by clicking it in the Project tab to the left, then
  • Click on the Data tab at the bottom, and change values for Height, Length and Width to 750mm, 50 and 50 (see Fig. 1.1)
  • Create a second box the same way, but with values 750, 40 and 40mm. By default this box will be superimposed on the first one. (see Fig. 1.2)
  • You'll now subtract the second box from the first. Select the first shape first (named Box), then the second one (named Box001), the selection order is important! (Make sure that both shapes are selected in the Project tree. One thing to remember: in Inventor navigation mode, Ctrl + click does not work for multiple selection. Switch to either CAD or Blender selection.)
  • On the Part Workbench toolbar, click on the Part Cut.png Cut tool.
Fig. 1.1 La première boîte
Fig. 1.2 La seconde boîte par dessus la première, prête à être soustraite
Fig. 1.3 Après la soustraction

Nous avons maintenant notre premier fer en L (Fig. 1.3). Remarquez que dans l'onglet Projet tab du panneau latéral, les deux boîtes ont été remplacées par un objet « Cut ». En fait, les formes initiales sont toujours présentes, mais groupées sous l'objet Cut. Cliquez sur le + situé devant, ce qui affichera leurs noms, mais en grisé (Fig. 1.4). Cliquez sur l'un ou l'autre et appuyez sur la barre d'espace pour afficher la boîte dans la fenêtre de modèle. La barre d'espace est un raccourci-clavier pour basculer la visibilité des éléments. (Fig. 1.5)

Vous voulez changer l'orientation du fer angle ? Vous n'avez qu'à modifier le placement de la boîte Box001. Sélectionnez-la, rendez-la visible, et dans l'onglet Données, cliquez sur le + devant Placement, puis déployez la Position, et changez les coordonnées X et Y. Appuyez sur la touche Entrée, masquez à nouveau la forme Box001, et l'angle d'orientation est maintenant différent. (Fig. 1.5) Vous pouvez également modifier n'importe quelle des dimensions de vos formes, et l'objet Cut s'adaptera automatiquement.

Fig. 1.4 L'opération Cut conserve ses objets originaux (les boîtes)
Fig. 1.5 Les boîtes originales peuvent être rendues visible

Par ailleurs, nous pouvons ajouter des congés afin de rendre le fer en L plus réaliste, à l'aide de l'outil Part Fillet.png Congé. (Fig. 1.6)

Fig. 1.6 Les arêtes avec congés

2nd Method - By extruding a profile

This method requires that you start by drawing a 2D profile. You need to activate the Draft workbench Switch DraftWorkbench.JPG.

  • If you haven't opened a new FreeCAD document (most of the FreeCAD window looks greyed-out), from the pull-down menu click File > New or click the Create A New Document tool Document-new.png.

Next we need to set the working plane. Depending on your FreeCAD version, you'll have right under the toolbar, on the right, a "None" button. Click it, and on the left will appear right after "active command": Select Plane Offset, then a text field and a series of buttons. Assuming you want to start your profile on the plan view, select XY. The "None" button will now show "Top" as active plane. See note.

Select the Draft Wire.png Wire (multiple-point line) tool, then start drawing a shape, using the text fields for X and Y positions. The "Relative" box should be checked, as well as the "Filled" box.

  • 1er point: 0,0
  • 2ème point: 50,0
  • 3ème point: 0,10
  • 4ème point: -40,0
  • 5ème point: 0,40
  • 6ème point: -10,0
  • Pas de 7ème point, cliquez plutôt sur le bouton « Fermer » pour fermer le profil. Vous devriez maintenant avoir le profil ci-dessous, nommé « Wire » dans l'onglet Projet :
Fig. 1.7 Le Wire de départ

Passez en vue axonométrique en appuyant sur la touche 0 du pavé numérique.

Activez l'atelier Pièce.

Cliquez sur l'outil Part Extrude.png Extruder.

Dans l'onglet Projet, sélectionnez l'objet Wire, puis entrez la valeur désirée, par exemple 750mm. Laissez la direction Z. Cliquez sur « Appliquer ». Un objet Extrude devrait apparaître dans l'onglet Projet (fig. 1.8)

Fig. 1.8 L'objet extrudé

Si cette méthode requiert moins d'opération que la première, elle présente un léger inconvénient : pour modifier la forme, il faut modifier l'objet Wire, ce qui est moins aisé que l'édition des formes primitives telles que les boîtes de la méthode précédente.

Et il y a aussi d'autres façons d'obtenir ce résultat ! Mais ces deux exemples devraient vous permettre de débuter avec FreeCAD. Vous rencontrerez certainement des difficultés en cours de route (c'est encore le cas pour l'auteur de ce tutoriel, et celui-ci a pourtant une certaine expérience en modélisation solide), mais n'hésitez pas à poser des questions sur le FreeCAD forum!


Note sur le bouton Draft working plane :

L'étiquette sur votre bouton peut-être être différent en fonction de votre version et aussi sur ce que vous faisiez précédemment. L'étiquette de bouton pourait être "top", "front", "side", "None" ou une représentation vectorielle telle que d(0.0,0.0,1.0). Il peut également être vide.

Par exemple :

Select Plane None
Select Plane Top
Select Plane View


Les instructions ci-dessus fonctionneront, quelle que soit l'étiquette sur le bouton.


Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎português • ‎русский