View Issue Details

IDProjectCategoryView StatusLast Update
0002903Path[FreeCAD] Bugpublic2017-03-20 16:27
Reportersliptonic 
Assigned Tosliptonic 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.17Fixed in Version[FreeCAD] 0.17 
Summary0002903: Path Viewprovider needs to handle arc planes correctly.
DescriptionGcode ars (G2 and G3) moves are always performed in the active plane.
The plane is selected by another gcode which is modal until changed.
G17 (default) selects the XY plane.
G18 selects the XZ plane
G19 selects the YZ plane.

At present, all arcs are calculated in the XY plane.



Additional InformationThis hasn't been a problem because G17 is the default and other arc planes are rarely used in 3 axis milling. However, as we implement lathe turning operations this will be a problem. A normal lathe configuration does all work in the XZ plane so arcs will be performed there. In order to correctly visualize lathe gcode, we will need to represent the arcs correctly.

http://linuxcnc.org/docs/html/gcode/g-code.html#gcode:g17-g19.1
TagsNo tags attached.

Relationships

Activities

2017-02-16 05:37sliptonicNew Issue

sliptonic

2017-03-20 16:27

developer   ~0008660

https://github.com/FreeCAD/FreeCAD/pull/610
2017-03-20 16:27sliptonicAssigned To => sliptonic
2017-03-20 16:27sliptonicStatusnew => closed
2017-03-20 16:27sliptonicResolutionopen => fixed
2017-03-20 16:27sliptonicFixed in Version => 0.17

Issue History

Date Modified Username Field Change
2017-02-16 05:37 sliptonic New Issue
2017-03-20 16:27 sliptonic Assigned To => sliptonic
2017-03-20 16:27 sliptonic Status new => closed
2017-03-20 16:27 sliptonic Resolution open => fixed
2017-03-20 16:27 sliptonic Fixed in Version => 0.17
2017-03-20 16:27 sliptonic Note Added: 0008660