View Issue Details

IDProjectCategoryView StatusLast Update
0002610FreeCADBugpublic2017-03-20 11:37
ReporterSandalphonAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformWindowsOSWindows 10OS Version64-bit
Product Version0.16 
Target VersionFixed in Version 
Summary0002610: Input Error: Removing Splitter Failed
DescriptionOS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6704 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: 0c449d7e8f9b2b1fb93e3f8d1865e2f59d7ed253
Python version: 2.7.8
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
I am going through the tutorials. While following the steps in the Piston tutorial I finish the fully constrained sketch 001 (two vertical lines and two arcs) and then click on the PAD task. I enter 48 mm and click OK and up comes the error message "Input Error: Removing Splitter Failed".
Edit:
Actually the error occurs much later at sketch 004. The revolution works when the sketch is one sided. When I cahnge the sketch to two sided that is when the error occurs.
Steps To ReproduceGo through the steps of the Piston tutorial up to the PAD task on the second sketch (sketch 001) and you should get the same error message. I have tried this several times. Even saved the file right after finishing the sketch, rebooting FreeCAD, then opening the file and starting the PAD right away before anything could get corrupted. Still gives me that error message.
What does it mean "Removing Splitter Failed"?
Edit:
Actually the error occurs much later at sketch 004. The revolution works when the sketch is one sided. When I cahnge the sketch to two sided that is when the error occurs.
Additional InformationI have been able to work around by doing a single vertical line and one arc for that sketch, padding that sketch, then doing another sketch with the other vertical line and arc, then padding that sketch (sketch 002) so the piston has two pads. That allowed me to proceed, but farther down the road there are other problems that may be due to the fact I'm using two sketches and two pads instead of one.
TagsNo tags attached.

Activities

2016-07-04 22:55SandalphonNew Issue

Sandalphon

2016-07-11 23:53

reporter   ~0007183

Actually the error occurs much later at sketch 004. The revolution works when the sketch is one sided. When I cahnge the sketch to two sided that is when the error occurs.
By the way, how can I delete my bug report if I screw up like on this one?
2017-01-27 02:57Kunda1Description UpdatedView Revisions
2017-01-27 02:57Kunda1Steps to Reproduce UpdatedView Revisions

Kunda1

2017-01-27 02:59

manager   ~0008011

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20265
2017-01-27 02:59Kunda1Statusnew => feedback

Kunda1

2017-02-06 05:22

manager   ~0008223

@Sandalphon please post an example file and also please conduct the rest of your responses in the forum thread ^ to generate dicussion. Thanks.

normandc

2017-03-19 21:30

manager   ~0008655

https://forum.freecadweb.org/viewtopic.php?f=3&t=21425#p166213

Kunda1

2017-03-20 11:37

manager   ~0008657

This is a workflow issue not a FC bug. See forum thread above. Closing.
2017-03-20 11:37Kunda1Statusfeedback => closed
2017-03-20 11:37Kunda1Resolutionopen => no change required

Issue History

Date Modified Username Field Change
2016-07-04 22:55 Sandalphon New Issue
2016-07-11 23:53 Sandalphon Note Added: 0007183
2017-01-27 02:57 Kunda1 Description Updated View Revisions
2017-01-27 02:57 Kunda1 Steps to Reproduce Updated View Revisions
2017-01-27 02:59 Kunda1 Note Added: 0008011
2017-01-27 02:59 Kunda1 Status new => feedback
2017-02-06 05:22 Kunda1 Note Added: 0008223
2017-03-19 21:30 normandc Note Added: 0008655
2017-03-20 11:37 Kunda1 Status feedback => closed
2017-03-20 11:37 Kunda1 Resolution open => no change required
2017-03-20 11:37 Kunda1 Note Added: 0008657