View Issue Details

IDProjectCategoryView StatusLast Update
0001611DraftBugpublic2017-04-28 19:07
ReporterteoboAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.14 
Target VersionFixed in Version 
Summary0001611: grid can not be put on initially on formerly non grid- document
DescriptionOS: Ubuntu 14.04 LTS
Word size: 64-bit
Version: 0.14.3728 (Git)
Branch: master
Hash: 1fd7bd98a46a7a0044476108476f01c44df635ee
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
SoQt version: 1.6.0a
Steps To Reproduce-open document http://forum.freecadweb.org/viewtopic.php?f=22&t=7009 attachment
-note: Gui:edit/Pref/Draft/snap "Always show grid": checked
-go back to draft canvas: notice grid is not on. -but should be on, no?
TagsNo tags attached.

Activities

2014-07-14 09:29teoboNew Issue

yorik

2014-07-14 14:55

administrator   ~0004790

There is no way to trigger an action after a preference has been changed, at the moment, and also no way to trigger an action when a document is created or loaded, so the grid will appear on the first Draft command being run after that. I'm sorry, but it's a limitaiton of freecad at the moment, and there is not much I can do about it...

teobo

2014-07-14 16:59

reporter   ~0004792

ok? as I have experienced it: pref-grid is triggered on the first GUI-command.
As happened in the indicated script, several python draft commands could not wake up grid - in other python scripts I remember a permanent grid, however.

It would be of use, if one had a work around to wake up draft grid noninteractively though. Gonna see if I find something.

yorik

2014-07-14 17:03

administrator   ~0004793

There is, actually... Draft->Utilities->Show Grid

teobo

2014-07-15 13:59

reporter   ~0004794

Work around for it:
with the indicated script there was no grid, so you maybe draw any line nearby.
After that you can put on grid non interactively at least:
import Draft
points=[FreeCAD.Vector(-2.54980707169,0.56199836731,0.0),FreeCAD.Vector(-1.83169817924,-0.176925450563,0.0)]
Draft.makeWire(points,closed=False,face=True,support=None)
FreeCADGui.Snapper.setGrid()
>"it's a limitaiton of freecad at the moment, and there is not much I can do about it..."
If I understand right than it is more bug a rather than a design flaw and should/could be fixed some day, right?

yorik

2014-07-15 14:02

administrator   ~0004795

It is not a bug (a bug is something that should be working but that is not working). It's just a feature that is not implemented yet.

teobo

2014-07-15 21:12

reporter   ~0004799

ok, as you mean. just to support my point one might consider that in the english prefs the option is named "show grid always". And it was confusing to us as freecad newbies when we noticed that it was not only not "always shown" but just initially not shown. So back to the definition "something that should be working" One would will not assume this behaviour as is.

I mean for me it`s ok, if it stays in the feature list though. Never mind.
2014-07-23 12:36wmayerProjectFreeCAD => Draft

Kunda1

2017-04-28 19:07

manager   ~0008812

Yorik wrote:
It is still not implemented, but actually with triplus's gui improvements the Draft grid now appears on file load, so we could consider this bug as not relevant anymore.

Based on the above feedback, closing ticket
2017-04-28 19:07Kunda1Statusnew => closed
2017-04-28 19:07Kunda1Resolutionopen => no change required

Issue History

Date Modified Username Field Change
2014-07-14 09:29 teobo New Issue
2014-07-14 14:55 yorik Note Added: 0004790
2014-07-14 16:59 teobo Note Added: 0004792
2014-07-14 17:03 yorik Note Added: 0004793
2014-07-15 13:59 teobo Note Added: 0004794
2014-07-15 14:02 yorik Note Added: 0004795
2014-07-15 21:12 teobo Note Added: 0004799
2014-07-23 12:36 wmayer Project FreeCAD => Draft
2017-04-28 19:07 Kunda1 Status new => closed
2017-04-28 19:07 Kunda1 Resolution open => no change required
2017-04-28 19:07 Kunda1 Note Added: 0008812